_divinc not showing in transaction reports

pjm572014
pjm572014 Member ✭✭
edited May 22 in Reports (Windows)
When I run a transaction report and include ALL categories, transactions with category = "_DivInc" are NOT included. This seems to be a somewhat recent change.
Tagged:

Best Answer

  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    Answer ✓
    That's odd.
    The investment transaction report I ran just before answering your question had that first radio button - Include transactions with any category (including uncategorized) - selected and the dividends in the Accounts showed up just fine.  You shouldn't have to take the route you described to make this work correctly.
    Go to Tools > Category list and make sure all the underscored investment Categories are not hidden.  Or, are they not hidden and you're just seeing some file-specific funkiness?


Answers

  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    I'm not seeing that when I run a transaction report on R34.24.  Under the Action tab of the customization window all all actions selected, including "Div"?
  • pjm572014
    pjm572014 Member ✭✭
    First of all, thank you for reading and responding.
    Second, yes I am running R34.24
    I found the problem, but it was a surprise.
    There is an option on the "Transaction" report on the Categories tab to select either
    <> Include transactions with any category (including uncategorized)
    <> Include only transactions with selected categories
    If I select the top one, it ignores "hidden categories". Instead, I have to select the bottom option, then choose "show (hidden categories)" and "Select All". If I do not do this, I do not get any transactions that have a category that begins with an _ Underscore.
  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    Answer ✓
    That's odd.
    The investment transaction report I ran just before answering your question had that first radio button - Include transactions with any category (including uncategorized) - selected and the dividends in the Accounts showed up just fine.  You shouldn't have to take the route you described to make this work correctly.
    Go to Tools > Category list and make sure all the underscored investment Categories are not hidden.  Or, are they not hidden and you're just seeing some file-specific funkiness?


  • pjm572014
    pjm572014 Member ✭✭
    You are correct that they were checked as "hidden" in the category list. I have never changed that in the decades that I have used Quicken :-) I just unchecked them. I then reran the report with the top choice selected. It now shows all transactions (since no categories are hidden). Something changed in the Quicken report defaults since I built the report. This works now. Your help is greatly appreciated!
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Note that the default setting for new files has the "underscore" Investment Categories hidden and the default Investment Transaction report now excludes hidden Categories. This means that a large number of investment transactions will not appear in the default report.

    This issue appears to be yet another unexpected consequence of the recent changes to Account and Category selection.
    QWin Premier subscription
This discussion has been closed.