Decimal points

I have had several issues where long after liquidating a security, Quicken is showing a very small fractional amount of shares still in the account. Some of these are 4 decimal points over, ie: .000834 shares or similar. Very frustrating. As one solution that I'm not fond of- I have gone back to a reconciled transaction and added or deleted the fractional shares depending on whether they show as a positive or negative. Is there some way to have Quicken ignore anything right of 2 decimal points or some other way to correct this? I'm not even sure why these show up, some of the securities were sold many years ago.


  • UKR
    UKR SuperUser ✭✭✭✭✭
    A while ago Quicken changed the number of decimal points used for calculating fractional shares, increasing to 6 decimal places.
    Fractional shares for mutual funds are usually traded with 3 decimal places, stock and other securities with 5.
    If you suddenly have a very small number of fractional shares (0.0000xx) showing for a security where you sold all shares, edit the last Sell transaction to "Sell all shares", but be sure to keep the total Amount the same. That should zero things out properly.
    The number of decimal places shown in reports and views for prices and shares is controlled in Edit / Preferences / Reports only. I recommend setting it to 6.

  • WDT
    WDT Member
    Thanks for the suggestion, I'll try that. As mentioned, some of these securities were sold long ago, so you could be right on as far as the change of decimal points from 4 to 6 causing those small fractional shares. Thanks again
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Besides going in and adding/removing the fractional shares you can usually go back to the last sell and select "Sell all".  Note that no matter how you do it, you aren't doing anything "wrong".  This is purely a rounding problem, and as such the shares don't exist in the real world in the first place.
    This is my website:
  • WDT
    WDT Member
    That sounds like it will solve it, thanks for the reply. I will go back and review these transactions and try this. Thanks again