Mutual fund purchases do not show up in portfolio view

K.
K. Member ✭✭
I have made a couple of mutual fund purchases which I successfully downloaded into my register. While the total balance in portfolio view is correct, these individual lots do not appear on the expanded view. There are no placeholder transactions or any other explanation I can come up with. Again, the individual lots are missing from the portfolio view but the total holdings of the security are correct.

Answers

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Can you see your transactions, or is that grayed out. It's possible the account which hols these mutual funds was set to Simple Investment Tracking Method and is not showing you transactions. Click on the account, then on Settings, and look to see if Investment Tracking Method is set to Simple or Detailed.
    Quicken Mac Subscription • Quicken user since 1993
  • K.
    K. Member ✭✭
    This is kind of embarrassing, but it's fixed. My portfolio view has always shown each individual lot of a security or fund chronologically, with the oldest lot at the top and the newest at the bottom. Somehow this got changed to re-ordering the lots by size. This caused the most recent lots to move up in the list while I was only looking at the bottom, which I thought to be the most recent. Turns out if you click on "name" in portfolio view, they are ordered by date. Click on "market value" and they re-order accordingly. I honestly don't know it it always worked that way or if it's new feature. Thanks.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Glad you got to the bottom of it!
    Quicken Mac Subscription • Quicken user since 1993
This discussion has been closed.