Quicken getting slower

Is it just me? Or with every update that Quicken pushes, it gets slower and slower. It takes longer to load, and when I reconcile an account it takes FOREVER to finish before it lets me move on to another account. Meanwhile, my video card fans go nuts (revving up to high speed). I'm using Win 10 with Core i7, so not a wimpy machine, and a decent gaming video card (not high-end, but pretty good middle-of-the-road). Quicken is the only thing I run that is doing this.

Answers

  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    If you think the slowness is due to video, try these Win10 graphics settings. Some of us believe it provides a small but noticeable improvement.

    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • onepoorguy
    onepoorguy Member ✭✭
    I changed the settings. Battery isn't an issue since this is a desktop. I'll see how it goes. Thanks. It's amazing to me just how much Quicken has slowed in the past year or so. I'm doing my weekly update (credit cards, etc) now, and the blue spinny circle is always popping up, and the fans are revving up. Even if all I do is "accept" a downloaded entry.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    It really sounds like there is some kind of conflict with your graph drivers in the way Quicken is using the display.  I see none of what you are talking about, and I definitely don't think most people have this problem.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • onepoorguy
    onepoorguy Member ✭✭
    I suppose it is possible. I have an NVIDIA GFORCE card. But I've only noticed the issues over the past year or so. I've had the card longer than that (maybe 3 years?). I especially noticed a dramatic slowdown after the update in Feb or March (can't remember exactly).

    I was in the middle of reconciling when you first commented, so have not yet rebooted to establish your settings. Hopefully it will improve things.

    But the short answer is "yes, it's just me". :-(
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    One thing to try is installing a Mondo patch from a year old (or more) version of Quicken to take it back the that point and see if it indeed makes a difference.

    You can find the old Mondo patches here:
    https://www.quicken.com/support/reinstalling-and-patching-your-quicken-subscription-version-after-your-membership-has
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    @onepoorguy , did the Windows graphics settings speed up Quicken for you at all?
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • onepoorguy
    onepoorguy Member ✭✭
    I'm not really sure. At first it seemed to be quicker, but then I started experiencing the same lags I always had. Maybe a little briefer? It certainly didn't seem to hurt anything. But the program start-up is very slow, and the time to record an entry once I hit "enter" is pretty slow. Reconciling also is slow, and I can't move to another account until it's done the reconcile of the account I'm looking at. It is closing a bit faster (I just closed it).

    So it may have improved things a bit, but it wasn't dramatic. I just did my end-of-the-month account downloads this past weekend.
This discussion has been closed.