Why can't quicken find both credit card accounts at Citi?

Trying to add a second Citi credit card account. When quicken searches for accounts at Citi it lists the first account but not the second. Both accounts at Citi use the same user id and password.
Tagged:

Answers

  • Quicken Paloma
    Quicken Paloma Moderator mod
    edited October 1
    Hello @JP_1

    Thank you for reaching out to Quicken Community. I apologize you are having difficulties connecting your credit card account(s). To better assist you, I need more information. For example, what instance are you using? Are you getting any sort of error codes or messages? Also, is this a credit card from Citi directly, or is it a store card issued by Citi bank(Costco Visa, Mastercard)?

    Please elaborate, so that we may assist further. 

    -Quicken Paloma
  • JP_1
    JP_1 Member
    I'm currently running Windows 10 and the subscription version of Quicken R35.31. Not getting any error messages. The card is direct from Citi. I have another direct Citi card that is set up on Quicken that I have used for a long time with no problems. When I got the new card Citi just included it on its website under my same user id and password. When I tried to add it to Quicken the search found my first card but not the second one leaving no way to add it (other than manually which I wouldn't be able to down load transactions)

    By the way, I have two direct cards from Chase that also use the same user id and password and have had no problems setting either up and the down loading of transactions work fine.

    Thanks for your help.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    Back up your data. Then deactivate the currently active card. Do Tools > Add Account and see whether Quicken will find both cards. Maybe it will work.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    How new is the new card account?
    Have you had at least one charge transaction on it?
    Will the new card appear on a separate statement or will it be "card 2" on the same statement as your old card and both cards are paid together with one payment?
  • JP_1
    JP_1 Member
    The card has been active for about a week and I have two transactions. I thought initially the problem was related to the fact that the transactions were still pending. I tried adding the account after the transactions were posted and still didn't work. The card will have a separate statement with a different billing period and payment due date from the other card. The puzzling thing as I mentioned earlier I have two Chase cards and when I added the second one quicken searched Chase and found both the old card and the new one. I was able to just add the new one. I thought the Citi cards would work the same.

    I haven't tried the suggestion from Rocket Squirrel yet.

    I was also wondering if there could be a problem on Citi's end.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    JP_1 said:

    I was also wondering if there could be a problem on Citi's end.
    My guess would be that it is a problem on Citi's end.  They send the information to Quicken of what accounts are available.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • richard13
    richard13 Member ✭✭✭
    Did this ever get resolved?  I am have the same problem after getting a 2nd Citi credit card.  I tried what Rocket J Squirrel suggested but it only turned up the original card again.
    Quicken Premier - Windows 10 VM on a Mac
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    I suggest looking at the OFX data to be sure where the problem is.
    When you select Add Account and go through the process it sends a request to the financial institution for a list of the accounts.  Now clearly if Citi doesn't return a list with both accounts in it, then there isn't anything Quicken can do about it, Citi would have to fix the problem.
    Help -> Log Files -> OFX Log  (New log entries are at the bottom of the file)

    Here is an example from my doing, but note I only have one Citi credit card.

    <!-- ***** SEND to https://mobilesoa.citi.com/CitiOFXInterface at 13:47:57 on 20211016 ***** -->

    <!--
    OFXHEADER:100
    DATA:OFXSGML
    VERSION:103
    SECURITY:NONE
    ENCODING:USASCII
    CHARSET:1252
    COMPRESSION:NONE
    OLDFILEUID:NONE
    NEWFILEUID:NONE

    -->
    <OFX>
    <SIGNONMSGSRQV1>
    <SONRQ>
    <DTCLIENT>20211016134757.123[-4:EDT]
    <USERID>XXXXX
    <USERPASS>X<GENUSERKEY>N
    <LANGUAGE>ENG
    <FI>
    <ORG>Citigroup
    <FID>24909
    </FI>
    <APPID>QWIN 
    <APPVER>2700
    <CLIENTUID>ee97a9e03f6a2dbaf47ab0f7b991bbf8
    </SONRQ>
    </SIGNONMSGSRQV1>
    <SIGNUPMSGSRQV1>
    <ACCTINFOTRNRQ>
    <TRNUID>2C5B47D0-7DF1-1000-8389-EEF15FF30026
    <ACCTINFORQ>
    <DTACCTUP>19900101
    </ACCTINFORQ>
    </ACCTINFOTRNRQ>
    </SIGNUPMSGSRQV1>
    </OFX>

    <!-- ***** RECV from https://mobilesoa.citi.com/CitiOFXInterface at 13:47:58 on 20211016 ***** -->

    <!--
    OFXHEADER:100
    DATA:OFXSGML
    VERSION:102
    SECURITY:NONE
    ENCODING:USASCII
    CHARSET:1252
    COMPRESSION:NONE
    OLDFILEUID:NONE
    NEWFILEUID:NONE

    -->
    <OFX>
    <SIGNONMSGSRSV1>
    <SONRS>
    <STATUS>
    <CODE>0
    <SEVERITY>INFO
    <MESSAGE>0
    </STATUS>
    <DTSERVER>20211016120000.000
    <LANGUAGE>ENG
    <FI>
    <ORG>Citigroup
    <FID>24909
    </FI>
    </SONRS>
    </SIGNONMSGSRSV1>
    <SIGNUPMSGSRSV1>
    <ACCTINFOTRNRS>
    <TRNUID>2C5B47D0-7DF1-1000-8389-EEF15FF30026
    <STATUS>
    <CODE>0
    <SEVERITY>INFO
    </STATUS>
    <ACCTINFORS>
    <DTACCTUP>19900101000000.000
    <ACCTINFO>
    <CCACCTINFO>
    <CCACCTFROM>
    <ACCTID>XXXXXXXXXXXXXXXX
    </CCACCTFROM>
    <SUPTXDL>Y
    <XFERSRC>N
    <XFERDEST>N
    <SVCSTATUS>ACTIVE
    </CCACCTINFO>
    </ACCTINFO>
    </ACCTINFORS>
    </ACCTINFOTRNRS>
    </SIGNUPMSGSRSV1>
    </OFX>
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • JP_1
    JP_1 Member
    I searched the Citi web site and it said when you download/export transactions from their site after choosing a generated statement to quicken it will automatically create a new quicken credit card account. I initially tried this before my first statement was generated and got nothing. But after my first Citi statement was generated I tried again and it worked fine.
  • richard13
    richard13 Member ✭✭✭
    I was able to resolve my issue by doing the below.  Sorry if I'm not using the exact wording, this is from memory:

    Deactivated online services on existing Citi credit card (BTW, it was using Express Web Connect)
    Tools > Add Account
    Searched for Citi (not clicking on the Citi icon)
    Chose Citi Cards, not Citibank
    Advanced Options, choose Direct Connect
    Entered account/password

    This initially failed and was told I needed to go to the citi.com/accountmanagement (I think that's the URL, I just followed where Quicken told me to go) to enable desktop application access.

    Logged in there with my account/password.
    Followed the instructions to enable desktop application access (Quicken) support.

    Back in Quicken, I clicked "Try again"

    The Add Account wizard continued, and both cards now showed!
    I chose "Link to existing account" for the original and "Add account" for the new one.

    Finished the wizard and Quicken downloaded the last few transactions from the original account (already downloaded previously and didn't cause a duplicate), and got a single "annual fee" transaction for the new one.  BTW, I haven't used this card yet and the annual fee is zero.  Glad that it got this no fee transaction though.  It proves downloads are working for the new card.

    Looks like I'm all good now.  Hope this helps!
    Quicken Premier - Windows 10 VM on a Mac
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    @richard13 based on what worked for you and based on what worked for @JP_1 that makes some sense.

    The original flow of Express Web Connect was the Express meant Intuit servers logging in to the financial institution's website as you, to find the "Web Connect/QFX" file and download and import it.
    (Newer flows sometimes get the data in a different format and convert it).

    It sounds like Citi is using this original flow.  So Express Web Connect would work just like @JP_1 experienced doing it manually (Web Connect flow), and not get the new account until after the statement.

    Note that the QFX file is the "receive" part of a request to send the account transaction information when using the OFX protocol (Which is what Direct Connect is).

    So it sounds like with Add Account for Express Web Connect the Account Information request is only coming back with the current accounts until the first statement.  But with Direct Connect this request is getting all the account information.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • J Smith
    J Smith Member ✭✭
    @richard13 wrote" I needed to go to the citi.com/accountmanagement (I think that's the URL, I just followed where Quicken told me to go) to enable desktop application access.

    Logged in there with my account/password.
    Followed the instructions to enable desktop application access (Quicken) support."

    This is the key and you have to make sure the 10 minute countdown clock starts. Once it does, go back to Quicken and do the "Add Account" thing. Works like a charm. Even though that page showed Quicken had access, you apparently have do it again to add a new card/account. Also thanks to @Chris_QPW for getting me to look at QFX files. BTW, Quicken phone support completely choked on this issue.