Why don't sub categories show in Category Window? (Q Mac)

Al Johnson
Al Johnson Member ✭✭
When I open the Category Window to change things for clarity, only a few sub categories show up. Looking at a register or a report or when adding/editing a transaction, I see all sorts of sub-categories.

Answers

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    At the top of the Categories window, there's a small drop-down menu which can be set to Show All Categories or to only Show Used/Unused, or to show only Income or Expense categories. Is yours set to Show All Categories?
    Quicken Mac Subscription • Quicken user since 1993
  • Al Johnson
    Al Johnson Member ✭✭
    @jacobs, Thanks. Yes it's set to Show all Categories. It's interesting that the only subcategories that show are either status "unused" or "required". I noticed this as I cycled through the options in the what categories to show drop down.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Hmm, I can't replicate this. I have a category with some used and some unused sub-categories. If I select Used Categories, only the used sub-categories show; if I select Unused Categories, only the unused sub-categories show; if I select Show All Categories, they all show. But you're saying that even set to Show All Categories, your Categories window is only showing unused and required categories? And you're sure the little triangle next to the main category names point down, right? If you collapse it and re-expand one, that doesn't make the hidden used categories show up, does it?
    Quicken Mac Subscription • Quicken user since 1993
  • Al Johnson
    Al Johnson Member ✭✭
    When Show All Categories is selected, it shows all the top Categories but only one unused Sub Category. I say all the Categories, but I'm not sure of that scrolling and counting. I've been using Quicken for about as long as you have and have transactions going back to the late 80s. I even did the decade of Q2007 just to get here today. So there's a lot of fluff and confusion in there that I'm trying to clean up.
    Here's a shot of the Category window and another of a portion of a category report showing the Sub Categories under Home and Household. I ran a report selecting all Categories and All Dates and it says I have 300 Categories. I'm assuming that means main and sub categories combined.
    As you can see, there's not even a "twisty" next to most of the Categories in the edit window.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Hmmm, and I'm wondering why a lot of your categories are grayed out. I seem to remember briefly seeing this once before with my data, although I can't remember if it was in my live data file or a test file I use for beta testing... nor can I remember what resolved that issue.  
    Quicken Mac Subscription • Quicken user since 1993
  • Al Johnson
    Al Johnson Member ✭✭
    It's strange having only the Category window 'broken'. It doesn't seem to be affecting anything else, yet. I'll let this question sit here for a couple days and then contact Q support.
  • Kantim67
    Kantim67 Member
    When I select Categories under "Window", I see the category but there is no triangle mark left of category to expand to show subcategories. on select few I can expand Category to view sub categories. I am unable to rename sub category as I am unable to expand the category it is in. I know I have selected "All Categories" under the drop down menu.
  • Al J
    Al J Member ✭✭
    Thats exactly what I see. A couple weeks ago I spent 2 hours+ with Quicken support. We tried many things, including exporting to a file and importing into a new file.
    Nothing worked and the technician couldn't replicate the problem. At the end of the day there was no resolution.
    I'm resolved that I'll have to take an empty file, load it with an export and recatagorize everything fresh. Time consuming but not that difficult.
  • I have the same issue. Everything was fine for a long time. Then I got tired of seeing Quicken's default categories since I already had my own hierarchy. So I deleted the unused categories, including all of the quicken default categories. That's when the problem started. Before that I could see all subcategories properly. Is that the same pattern you experienced?
  • BTW, I created new categories with subcategories and those show up fine in the category window. So rather than exporting, importing and re-categorizing, I'll probably do it gradually, making a new hierarchy in parallel to the old one and moving transactions gradually as I go. Then just remove the old ones once they are empty. Even if they don't show up, "remove unused categories" would maybe get rid of them...
  • Al J
    Al J Member ✭✭
    Now that you mention it, I did do a major clean up of unused, default categories some time back. Can't say for sure it was causal, but might be worth an investigation by some developer somewhere. (Hint to Quicken)
    I like the idea of keeping things as is and just building a new hierarchy. Then doing a gradual migration as time allows. Have to test if "remove unused" will get rid of the old ones.
  • Hello all,

    Thank you all for coming to the Community to report the issues you are having, though I do apologize that you are having them. And thank you to everyone who has taken the time to add to this discussion as well. 

    Unfortunately, I am unable to recreate this on my end either. As you can see my categories do not appear the same as yours. (pictured below)


    I am curious if you all have converted from earlier versions of Quicken, and if this happened after that conversion? How long have you all noticed this being an issue? Are you all running the latest version of QMac(6.4.4)? 

    Being that the new categories show correctly, it seems that the existing ones are damaged in some way. I do not think this is a bug or we should all see the same behavior. Nevertheless, anyone who is experiencing this can report the issue to Quicken by going to Help>Report a Problem. Please be detailed in your description and provide screenshots if possible. 

    Look forward to hearing any feedback any of you may have on this. Thank you.



    Quicken Alyssa

  • Kantim67
    Kantim67 Member
    I had no need to modify or delete subcategories for quite some time other than from time to time delete UNUSED categories. This unusual issue might have arisen since or when I carried out latest update. can't be sure.
  • Al Johnson
    Al Johnson Member ✭✭
    Finally getting a chance to respond to @Quicken Alyssa.
    I went in to recreate the category hierarchy. I can see the new categories/subcategories in the Category window as long as they are unused. Once I assign a transaction, that subcategory disappears. If I assign a transaction to a category that has no unused subcategories below it, the category will grey out.

    I also tried exporting my data to a QXF and importing it into a new file. The same thing happens, existing (sub)categories with transactions assigned are not visible/greyed out. Once I assign a transaction to an unused (sub)category, that (sub)category disappears/goes grey.

    So essentially, in the Category Window I can see and manipulate unused (sub)categories while in a category Report I can see the used (sub)categories.
  • RobGonzalez
    RobGonzalez Member ✭✭
    I am having the same problem. In my Categories list, they are all there. But when I try to assign a transaction to one of these categories, it is not there. I also did quite a bit of category cleanup a year or two ago. I see that may be the common theme between all of us. I guess I'll create new categories that I can use.
  • Al Johnson
    Al Johnson Member ✭✭
    @RobGonzalez I tried creating new categories, and they have the same problem. Once I assign a transaction they disappeared.
  • Finally getting a chance to respond to @Quicken Alyssa.
    I went in to recreate the category hierarchy. I can see the new categories/subcategories in the Category window as long as they are unused. Once I assign a transaction, that subcategory disappears. If I assign a transaction to a category that has no unused subcategories below it, the category will grey out.

    I also tried exporting my data to a QXF and importing it into a new file. The same thing happens, existing (sub)categories with transactions assigned are not visible/greyed out. Once I assign a transaction to an unused (sub)category, that (sub)category disappears/goes grey.

    So essentially, in the Category Window I can see and manipulate unused (sub)categories while in a category Report I can see the used (sub)categories.
    Al Johnson,

    Thank you again for bringing this matter to our attention here on the Quicken Community. Be sure that your application has been updated and is currently running version 6.4.5. Additionally, please be sure that your OS is one of those currently supported. You can find a list of these here: https://www.quicken.com/support/mac/quicken-system-requirements.

    Thanks,

    Quicken Jared
  • Al Johnson
    Al Johnson Member ✭✭
    Hi Jared. I'm running Quicken 6.4.5 on macOS 11.6.1 (Big Sur). Haven't yet upgraded to Monterey
This discussion has been closed.