Morningstar x-ray won't open

GK2108
GK2108 Member
edited November 23 in Investing (Windows)
I just updated to the newest version of Premier for Windows and I am having the same problem (never fixed) that I had with the last 2 versions of Quicken. When I try to open Morningstar x-ray, I get this message - "Invalid User...Error in decrypting the UserId-Auth Token Not Found...Cannot Authenticate - User Not Found.
I tried the fix on this forum from May 2020 and it did not work. Edit/Preferences/Quicken ID & Cloud Accounts/Sign in as different user/type "yes"/Close and re-open Quicken/Sign In.

Answers

  • Quicken Alyssa
    Quicken Alyssa Moderator mod
    Hello @GK2108,

    Thank you for choosing to come to the Community with your questions and concerns, though I apologize that you are experiencing this.

    I was not able to recreate this from my end, so I'm hoping you can provide some more information for us.

    Can I have you provide a screenshot of the error you are seeing when you try to use the Morningstar X-Ray tool? Also please go to Edit>Preferences>Investing.Quicken.com portfolio, and take a screenshot of this window for me as well. (pictured below)


    If needed, please refer to this Community FAQ for instructions on how to attach a screenshot. Alternatively, you can also drag and drop screenshots to your response if you are not given the option to add attachments.



    Quicken Alyssa

  • GK2108
    GK2108 Member
    I hope these are the 2 screenshots you requested
  • Quicken Alyssa
    Quicken Alyssa Moderator mod
    Hello again,

    Thank you for that update and I apologize for the delayed response. The screenshots that you provided were perfect!

    Can I please have you go to Help>Report a Problem from within your software. Describe the issue that you are having, leave the log files attached. Send it to Quicken and then let us know when you have completed this. Thank you!



    Quicken Alyssa

  • GK2108
    GK2108 Member
    Sent to Quicken at 2:50 PM on 11/28//21
  • Quicken Alyssa
    Quicken Alyssa Moderator mod
    Hello @GK2108,

    Thank you for submitting those! I am going to need you try something else for me if that's ok.

    Can I have you create a test file? This way we can see if the issue persists there as well.

    Here is a Knowledge Base article with instructions on how to open a new file. Once that is done, you can just add a manual "offline" brokerage account. That way you can see if the Xray tool works in this new file. 

    Please update us on the results of this, looking forward to hearing back from you. 



    Quicken Alyssa

  • GK2108
    GK2108 Member
    I still get the same "Invalid UserId ..." blah blah blah message with the new fake account.
  • Hello @GK2108

    Thank you for your response. Could you please reset your cloud data? Before starting the process please ensure that you have a backup of your current file. 

    To do this select Edit >Preferences >Quicken ID & Cloud accounts >Sign in as a different user. On the popup window type "yes" and click Sign out. You will then be prompted to sign back in with your Quicken ID and password. After you have signed back in select Investing >Refresh X-Ray.

    When you have a moment please attempt the steps above and let us know how it goes!

    -Quicken Paloma