New bug in 37.37: Validate breaks Schwab Bank online connections

MontanaKarl
MontanaKarl Member, Windows Beta, Mac Beta Beta
I had been running successfully for 2.5 days with the mondo patch for QWin build 37.37 downloading transactions from all institutions including Charles Schwab brokerage and bank accounts from two separate Schwab logins.  Reconciled all November statements.

So, silly me, I thought:  why not do a File > Validate just to make sure there's nothing else amiss and everything is really back to normal?

There were no errors - except these "fixed" (now broken) qel/qdf inconsistencies in the DATA_LOG report that appeared at the end of the Validate:

QEL:Fixed qel/qdf inconsistencies for acct Karen Schwab Bank (Both Banking & Inv in qel. )
Fixed qel/qdf inconsistencies for acct Schwab Bank (Both Banking & Inv in qel. )
Fixed qel/qdf inconsistencies for acct Schwab Savings Acct (Both Banking & Inv in qel. )


Checking each of the three bank accounts after this found that all three previously working accounts were now disconnected from online services / Schwab.

To add these three back to Quicken, I have to use the Add Account functionality, selecting Charles Schwab... as that is the only way that I am ever presented with the Add/Link/Ignore dialog in order to re-link just these accounts. If instead, for any one of these accounts, I click the "Set up Now..." under Online Services, I never see the 'link' dialog and every Schwab account is added as a duplicate.

These issues are not new.  When can we expect bug fixes from Quicken so that we don't have to do these workarounds (e.g., NOT use the Validate function, and only set up online services from the Add Account function)? 



Quicken Windows and Mac subscription.  Quicken user since 1990.

Comments

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited December 2021
    If you haven't already, I suggest you report the issue to Quicken: select Help > Report a problem...
  • MontanaKarl
    MontanaKarl Member, Windows Beta, Mac Beta Beta
    Done  B)
    Quicken Windows and Mac subscription.  Quicken user since 1990.

  • Quicken Paloma
    Quicken Paloma Alumni ✭✭✭✭
    Hello @MontanaKarl

    Thank you for providing feedback and a bug report with the log files. It is much appreciated. If you come across any other issues or have concerns please let us know. 

    Thank you!

    -Quicken Paloma
  • MontanaKarl
    MontanaKarl Member, Windows Beta, Mac Beta Beta
    edited December 2021
    Hello @MontanaKarl

    Thank you for providing feedback and a bug report with the log files. It is much appreciated. If you come across any other issues or have concerns please let us know. 

    Thank you!

    -Quicken Paloma
    Thanks.  Well... 37.37 did crash several times when I did no more than click on a downloaded transaction.  Those crash reports were submitted as they happened ... 2 maybe 3 of them...with my Quicken ID email included.  Each crash was when clicking on a newly downloaded transaction... before that transaction was highlighted and entered into the register - Quicken just vanished and the bug reporter popped up.

    Quicken Windows and Mac subscription.  Quicken user since 1990.

  • mikeweberatl
    mikeweberatl Member ✭✭✭
    edited December 2021
    same thing happened to me - I validated my file and my Schwab Investor Checking is no longer connected to Schwab. I also ended up with a $9.95 reconciliation error which did not exist before validating. All my Schwab accounts were migrated and working fine until I validated. I fixed it, downloaded new transactions, then validated again and it's broke again so now I have confirmed the cause.

    Update: I fixed it after breaking for the 2nd time, and my 9.95 reconciliation error is gone. Looks that error was caused by the fact that Schwab downloads new transactions but there's a delay updating the online balance. Probably best to only download Schwab first thing in the mornings because it no longer seems to update instantly.
  • MontanaKarl
    MontanaKarl Member, Windows Beta, Mac Beta Beta
    Today's 37.62 release / mondo patch resolved the issue with Validate disconnecting Schwab checking accounts for me.  The first validate still complained about something with the QEL for all three checking accounts, but did not disconnect them.  An OSU completed successfully and I did another validate with no messages for those accounts.

    This release also resolved another bug I had where if I clicked on a downloaded transaction immediately after a OSU (I manually accept downloaded transactions) ... Quicken would crash.  No crashes.  So far.

    Quicken Windows and Mac subscription.  Quicken user since 1990.

  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    mikeweberatl said:   I validated my file and my Schwab Investor Checking is no longer connected to Schwab.
    just to clarify - are these accounts setup with Schwab BANK -
    or are they the Linked Account created with the Schwab Brokerage One account

    QWin Deluxe Subscription - Win10
  • MontanaKarl
    MontanaKarl Member, Windows Beta, Mac Beta Beta
    @Ps56k2
    These Schwab Bank accounts are connected via the new Charles Schwab connection.  There is no longer a separate Schwab Investor Checking connection.  In any case, this bug is now fixed... see my post just before yours.

    Quicken Windows and Mac subscription.  Quicken user since 1990.

  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    edited December 2021
    Just wanted to clarify -
    between the Charles Schwab BANK entries vs the Charles Schwab & Co. (brokerage) entry,
    that may also have a "linked" checking account....

    QWin Deluxe Subscription - Win10
  • MontanaKarl
    MontanaKarl Member, Windows Beta, Mac Beta Beta
    @Ps56k2
    Yes, that is the entry you choose for ANY Schwab bank or investment account.  I'm really not sure why the others ('-Investor C' and '- Web Connect') are still listed.
    Quicken Windows and Mac subscription.  Quicken user since 1990.

This discussion has been closed.