Why do Manual Credit Card Bills appear twice in Bills & Income list in QMac?

RickB_Mac
RickB_Mac Windows Beta, Mac Beta Beta
I created a manual bill for Apple Card, scheduled a payment to recur every month-end.  For Account, I use my checking account. For Category, I choose Transfer:[Apple Card], which is how Quicken has worked forever.  In QuickenMac, it lists this as 2 transactions. The 1st lists as "Apple Card", "My Checking", and the 2nd lists as "Apple Card", "Apple Card". If I just use "Transfer" as the Category, without the Checking Acct, it only creates one Bill Reminder line.  This page is programmed incorrectly, as a Credit Card bill will always do a transfer from a cash account and into the credit card account, so it creates the 2-sided transaction.  Quicken Windows behaves properly, creating a single transaction.

Can this behavior be fixed in QuickenMac so that a manual credit card bill set up as a cash account transfer will only appear once in the Bills & Income list?

Best Answer

  • RickB_Mac
    RickB_Mac Windows Beta, Mac Beta Beta
    Answer ✓
    So I tried again in my primary data file, it created the duplicate lines.  Then tried turning off the Preferences/Register setting to allow creating linked transfers with the category field, created the reminder with "Transfer:Credit Card Payment".  Then toggled it back to allow category transfers, went back into the scheduled transaction, changed it back to the credit card account, saved, and it left it with the single row as expected.  Went back to my beta file, tried the same, and it started working properly. Best guess I have is there was a conversion/update in one of Quicken's releases that mishandled this file setting, which affected both my files, which are both greater than a year old.

Answers

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Hmmm, I'm not seeing this. I created a payment in my checking account to Payee Test, with a Transfer to one3 of my credit card accounts. I scheduled this as a monthly transaction. In the Bills & Income screen on the Bills tab, I see only one reference to this transaction: a payment to Test in the checking account coming up next month. 

    The only place I can see this transaction twice is if I select the Projected Balances tab, and set the filters to All accounts and All Types. Then, logically, it shows both sides of the transaction, since both sides affect the projected balance of all accounts. Changing the Type filter to show only expenses or only income shows only one side of the transaction; setting the account filter to All Banking Accounts or All Credit Card accounts similarly shows only one side of the transaction. 
    Quicken Mac Subscription • Quicken user since 1993
  • RickB_Mac
    RickB_Mac Windows Beta, Mac Beta Beta
    Thanks for checking that out.  Funny, it happens in my data file in both beta and current production. I did just try it with a fresh file, and it worked as you described, and how I would expect.  So now I guess I'll play around and try to find out what could be causing my data file to present this way.  I've verified the credit and checking accounts are set with the correct respective account "Type" in Account Settings.  If nothing else, perhaps there's something wrong with my data file that could be causing this behavior.  I'll keep playing and see if I can find a setting that could impact and/or correct this behavior in my file.  Thank you again for running through a test, really appreciate it.
  • RickB_Mac
    RickB_Mac Windows Beta, Mac Beta Beta
    Answer ✓
    So I tried again in my primary data file, it created the duplicate lines.  Then tried turning off the Preferences/Register setting to allow creating linked transfers with the category field, created the reminder with "Transfer:Credit Card Payment".  Then toggled it back to allow category transfers, went back into the scheduled transaction, changed it back to the credit card account, saved, and it left it with the single row as expected.  Went back to my beta file, tried the same, and it started working properly. Best guess I have is there was a conversion/update in one of Quicken's releases that mishandled this file setting, which affected both my files, which are both greater than a year old.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Wow, that's good testing by you, and a surprising result. But I'm glad you got it to clear up.
    Quicken Mac Subscription • Quicken user since 1993
This discussion has been closed.