Duplicate Transactions

Bleena
Bleena Member
I have migrated from an older MACbook Pro to the new 14" MacBook Pro running OS Monterey 12.1. When I check my accounts for new transactions, they download duplicate transactions to those already in the registers from October to January. I am interested in knowing how to keep this from happening going forward. Thank you!

Best Answer

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    edited January 20 Answer ✓
    I'm guessing this is likely a one-time problem. Were you using the same version of Quicken on your old computer as you are using on the new one? Were you downloading transactions on the old computer? Did you have to re-connect your accounts for downloading? 

    When you connect to a financial institution, it will download everything it has available — typically the past 90 days. To prevent duplicates in Quicken, the financial institution generates a unique ID number for every transactions (the FITID number); Quicken maintains a database of all these FITID numbers, and discards any downloaded transactions which have FITID numbers already in its database, because it knows those have been previously downloaded. But if you change connection methods, login IDs or anything which makes a financial institution think it's talking to a different instance of you, it may generate new FITID numbers for every transaction — and since your Quicken hasn't seen these numbers before, it accepts all the downloads. so once you delete the duplicate the first time, they won't come back, because the FITID numbers exist in your Quicken file now.

    There's a different possible culprit if you have Sync turned on for using the mobile app or web interface. Do you? (In Preferences > Mobile, Web & Alerts, is Sync on or off?) If it is on, it shouldn't happen, but in some cases, Quicken things the data in the Quicken Cloud is newer than the data in your desktop file, so it keeps trying to re-download that data into your file. (For this reason, I and many other longtime Quicken users don't use the Sync services to avoid such problems.) Even if just temporarily, I'd suggest turning Sync Off. Once it is off, or if it already was, go to Preferences > Connected Services and click the Reset button to reset your Cloud account for this data file. (Every data file has an associated Quicken Cloud account; if Sync is off, none of your transaction data exists in this Quicken Cloud account, just some identifying data Quicken uses to manage back-end processes.) Clicking Reset will not affect your desktop data, but will delete the Quicken Cloud file associated with your data file and create a new one. If there was any transaction data in the Cloud account which was overwriting your desktop data, this will prevent that from happening. 
    Quicken Mac Subscription • Quicken user since 1993

Answers

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    edited January 20 Answer ✓
    I'm guessing this is likely a one-time problem. Were you using the same version of Quicken on your old computer as you are using on the new one? Were you downloading transactions on the old computer? Did you have to re-connect your accounts for downloading? 

    When you connect to a financial institution, it will download everything it has available — typically the past 90 days. To prevent duplicates in Quicken, the financial institution generates a unique ID number for every transactions (the FITID number); Quicken maintains a database of all these FITID numbers, and discards any downloaded transactions which have FITID numbers already in its database, because it knows those have been previously downloaded. But if you change connection methods, login IDs or anything which makes a financial institution think it's talking to a different instance of you, it may generate new FITID numbers for every transaction — and since your Quicken hasn't seen these numbers before, it accepts all the downloads. so once you delete the duplicate the first time, they won't come back, because the FITID numbers exist in your Quicken file now.

    There's a different possible culprit if you have Sync turned on for using the mobile app or web interface. Do you? (In Preferences > Mobile, Web & Alerts, is Sync on or off?) If it is on, it shouldn't happen, but in some cases, Quicken things the data in the Quicken Cloud is newer than the data in your desktop file, so it keeps trying to re-download that data into your file. (For this reason, I and many other longtime Quicken users don't use the Sync services to avoid such problems.) Even if just temporarily, I'd suggest turning Sync Off. Once it is off, or if it already was, go to Preferences > Connected Services and click the Reset button to reset your Cloud account for this data file. (Every data file has an associated Quicken Cloud account; if Sync is off, none of your transaction data exists in this Quicken Cloud account, just some identifying data Quicken uses to manage back-end processes.) Clicking Reset will not affect your desktop data, but will delete the Quicken Cloud file associated with your data file and create a new one. If there was any transaction data in the Cloud account which was overwriting your desktop data, this will prevent that from happening. 
    Quicken Mac Subscription • Quicken user since 1993
  • Bleena
    Bleena Member
    Jacobs, thank you! I will spend some time on this after reading your answer in more depth. I am using the same version (6.4.4) of Quicken on both computers, I did download on the old computer but did not have both open at the same time, and I did have to reconnect to each account on the new computer. All things considered, it may very well be what you described. Thanks again.
This discussion has been closed.