Create a year-end archive -> I only want transactions in my current data file ... DOES NOT WORK

Scott30
Scott30 Member ✭✭
My Quicken file (QDATA.qdf) is 128MB and has transactions back to the last century (i.e., to 1994). It takes about 30 seconds for Quicken to start up.

I cannot get the "I only want transaction in my current data file starting with this date" feature to work. Based on Quicken's documentation and based on the quoted statement in the previous sentence, I would expect the process to delete transactions before the date I entered (1/1/2015). I understand that it will delete only reconciled and NON-investment transactions. I have thousands of transactions that meet those two criteria. Yet, when I run the process, QDATA still retains ALL of the old transactions. (BTW, the process does properly create the archive file, which, correctly, contains everything in QDATA except for this year's transactions.

I contacted Quicken support twice:
Support Person #1: Run the "Create a copy or template" process. The problem with that is that the copy or template is disconnected from connected services. That is not the right answer.
Support Person #2: “Yes, you are right. The Archive process does not work correctly. It was reported in November.”
I noted that Quicken must have hundreds of thousands of customers, and I am surprised that Quicken is not addressing this more quickly. I assume that they have more than five or six programmers.

Hoping this process will be fixed soon.

OR... maybe I am doing something wrong, and neither support person was able to give me the correct answer. I know that not everyone wants to truncate transactions, but I have to believe that many thousands of users do, and I'm surprised that there's not more complaining about this on the support site. So, maybe I'm just doing something wrong.

Comments

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    We are running Quicken R36.38 on Windows 10 on a 10 year old 2.5 Ghz dual core CPU with 8 GB of RAM and 750 GB internal hard drive disk which we access using a remote desktop client from various locations.  Our Quicken file is about 325 MB.  Quicken opens in about 1 second and the Quicken file loads in about 10 seconds.  The first open of the day may take longer as Quicken calls home and we're a few releases back. 

    To understand why Quicken is taking 30 seconds to load your Quicken file, you need to determine what resource Quicken is waiting on.  The first thing to do is take get accurate measurements.  Time how long it takes to open Quicken while pressing the Ctrl key and how long it takes to load the Quicken file.  Repeat the test a few times.  If the open or load times are significant, the first thing I would suggest is to perform a clean uninstall, install and update, and repeat the tests.  If the load time is significant, create a new temporary test Quicken file in a local folder on an internal drive with Don't use mobile and with no accounts, and repeat the tests.  This should enable you to establish a baseline for opening Quicken and the Quicken file in your environment. 

    Some generic things that may improve the time it takes open your Quicken file are accessing the Quicken file in a local folder on an internal drive, minimizing the startup activity (select Edit  > Preferences... and Startup), and performing a Copy and Validate.
  • Scott30
    Scott30 Member ✭✭
    My bad... the load time is NOT the main issue, and now that I've timed it I see that it is more like 12 seconds, when it used to take under five seconds in the past. However I mentioned that just to note that the load time is a little slow. My PRIMARY ISSUE is that I would like to reduce the size of the file. I don't think I need transactions going back to 2008. Just trying to find out how to make the Year-End-Copy process to delete the transactions that are before the cutoff date I entered.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Scott30 said:
    My bad... the load time is NOT the main issue, and now that I've timed it I see that it is more like 12 seconds, when it used to take under five seconds in the past. However I mentioned that just to note that the load time is a little slow. My PRIMARY ISSUE is that I would like to reduce the size of the file. I don't think I need transactions going back to 2008. Just trying to find out how to make the Year-End-Copy process to delete the transactions that are before the cutoff date I entered.
    If you haven't already, you may want to review: FAQ: Year End Copy
  • Scott30
    Scott30 Member ✭✭
    Thank you, Sherlock. So, it sounds like a 128MB QDF file is no big deal as far as the app is concerned (it is certainly insignificant from a space point of view on my laptop). It also sounds like the Quicken company is not pushing anyone to cut off old transactions but that the feature is there (well… not right now) if people want to use it. But your bottom line is that there’s no real need to do this. The “slow” load time is not a sign of trouble (and searching and reporting are still extremely fast once I’m in the app).
  • rpmind_248
    rpmind_248 Member
    To Scott 30:
    I too have not been able to get the year end copy to work. I spent an hour on the phone with a support person and we tried all kinds of scenarios and nothing produced a new copy of current transactions while eliminating the reconciled ones. I always seemed to have trouble with this process and somehow got it to work in past years, but this year, after the latest program revision, it would not work. The copy program is all messed up.....
  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    edited January 29
    never understood why anyone wants to chop off their previous financial history.... I have ALL mine is a single place -
    The file size really doesn't matter - for general performance or disk space usage.
    If you want to see and compare your Quicken data file stats....   Help --> CTRL+About Quicken


    QWin Deluxe Subscription - Win10
This discussion has been closed.