Quicken is not deleting old backups

SteveY
SteveY Member ✭✭
My Quicken has for years been set "maximum number of backup copies: 4" however it stopped deleting old backups in April 2021. I found I have 9 GB of backup files, between the normal backups and QDATA-R-* backups which I'm guessing are version updates.

04/11/2021 03:19 PM 164,306,944 QDATA-2021-04-11.PM04.19.QDF-backup
04/17/2021 09:20 PM 164,445,032 QDATA-2021-04-17.PM10.20.QDF-backup
04/29/2021 04:34 PM 164,757,504 QDATA-2021-04-29.PM05.34.QDF-backup
05/05/2021 07:36 PM 165,351,424 QDATA-2021-05-05.PM08.36.QDF-backup
05/21/2021 03:02 PM 165,642,821 QDATA-2021-05-21.PM04.02.QDF-backup
05/24/2021 04:57 PM 165,830,773 QDATA-2021-05-24.PM05.57.QDF-backup
05/30/2021 03:30 PM 166,166,528 QDATA-2021-05-30.PM04.30.QDF-backup
06/09/2021 11:10 AM 166,575,317 QDATA-2021-06-09.PM12.10.QDF-backup
06/18/2021 07:41 PM 166,881,821 QDATA-2021-06-18.PM08.41.QDF-backup
06/25/2021 10:28 AM 167,067,648 QDATA-2021-06-25.AM11.28.QDF-backup
07/02/2021 09:36 PM 167,428,488 QDATA-2021-07-02.PM10.36.QDF-backup
07/11/2021 12:18 PM 167,616,512 QDATA-2021-07-11.PM01.18.QDF-backup

Changing the number to keep doesn't seem to have any effect. Screen cap of the setting attached.
Tagged:

Comments

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    When Quicken upgrades itself, Quicken saves an automatic backup of the current release (-R-XX.XX).  I suspect this resets the number of backups saved counter.

    I suggest occasionally checking the automatic backup folder and deleting the backups you no longer wish to save.
  • SteveY
    SteveY Member ✭✭
    It still seems like a bug if it 1) used to do it, and 2) has a setting for the maximum number of copies. Your suggestion is a (the only) workaround but for a couple decades it hasn't been a problem.

    The other option is to turn off backups in Quicken and just depend on my backup software. It took them a couple years to stop erasing paycheck data, I guess we can wait out this fix.

    I guess we don't get notifications of replies here, so sorry for the delay replying.
  • SteveY
    SteveY Member ✭✭
    PS - I have heard from others they have the same issue so it's not just me.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited March 1
    SteveY said:
    It still seems like a bug if it 1) used to do it, and 2) has a setting for the maximum number of copies. Your suggestion is a (the only) workaround but for a couple decades it hasn't been a problem.

    The other option is to turn off backups in Quicken and just depend on my backup software. It took them a couple years to stop erasing paycheck data, I guess we can wait out this fix.

    I guess we don't get notifications of replies here, so sorry for the delay replying.
    SteveY said:
    PS - I have heard from others they have the same issue so it's not just me.
    This has been an issue ever since Quicken started automatically saving the Quicken file backup prior to upgrading from within the program.  If you want to report the issue to Quicken: select Help > Report a problem...

    If you want to receive notification of replies to your discussions, I suggest you set the Notify me when people comment on my discussions notification preference appropriately in your community profile.
  • SteveY
    SteveY Member ✭✭
    I'm new to the subscription Quicken last year so if it's been an issue for a while then I didn't know. Still, I would think that would apply to the automated backups, not other backups. So basically it is just ignoring the setting.

    It took a year or more to get the sync/paycheck data loss bug figured out, hopefully they'll get around to this at some point. :) I had hopes paying significantly more for Quicken would improve program quality but so far I've been disappointed.

    Thanks for the pointer on the notification setting. Apparently I have a "wall" too.
This discussion has been closed.