Autofill

I am entering transactions and expecting the next time I enter it, quick fill will fill in the merchant name and category from my prior entry. I have checked everything I can find in preferences but continue to have to fully enter transaction info every time I enter the same transaction.

Answers

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Do you have the global preference turned on for creating QuickFill rules? When you enter a transaction, and you're in the Category field, is the pop-up blue box above the Category header checked? If you open Window > Payees & Rules > QuickFill Rules, do you see the rule created after you enter a transaction?
    Quicken Mac Subscription • Quicken user since 1993
  • Winthrop
    Winthrop Member
    When I enter a transaction, the category field presents the option to save the quick fill rule and I have it checked. I close and reopen Quicken and find the transaction listed in Window/Payee & Rules/QF rules, but it does not quick fill the next entry. Where is the "global preference for creating QF rules found?
  • RickO
    RickO SuperUser, Mac Beta Beta
    Since you see the QF rule in the list, it sounds like the global preference is already enabled. But in any case, you can find it in Quicken > Preferences > Registers:


    I think what's happening is you need to select the QF rule from the dropdown list when you start entering the payee name the first time you want to use it. If you've never selected the QF rule when entering the payee, it will usually default to a "bare" transaction for that payee like this:



    If you hit tab, you will get nothing filled but the payee name. The solution is to hit the keyboard down arrow at this point to select the QF rule you want to use, resulting in this:



    Then tab to the next field and enter the transaction. The next time you start to enter a transaction for this payee, the last QF rule you used will be pre-selected and you won't need to use the down arrow to select it.

    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • Winthrop
    Winthrop Member
    So my transaction I am working on is Publix. I have hundreds of Publix entries over time. When I go to enter a new transaction, I have to remove the x at the end of Publix for the option to "create new payee" to stay active. So I saved "Publi" and went to window/Payees & Rules to edit it to "Publix". Went to enter a new transaction and autofill is not working.
  • Winthrop
    Winthrop Member
    PS It also doesn't work for "Publix"
This discussion has been closed.