All transactions are blank

johncr
johncr Member
For about a month now every time I open quicken all the transactions in every account are blank. I survive by backing up to an NAS at the end of every session then restoring the backup every time I use the program.
I contacted support but no real help.
It looks like quicken is syncing a blank file every time I start up even though I have turned off sync everywhere I could, I still get a dialog box asking me if I want to sync and I never do. I don’t know where the blank file could have come from.
Any help would be appreciated

Best Answer

  • BK
    BK Member ✭✭✭✭
    Answer ✓
    It is possible that your installation of Quicken is corrupt which may have possibly damaged your data file.  I would suggest a reinstall which takes less than a minute.  You have not told us what version you currently have?  Going with the assumption that you are on the latest version (as of now R39.23), you can reinstall the latest version using the Mondo patch from this Quicken link.
    - QWin Deluxe user since 2010, US subscription on Win11
    - I don't use Cloud Sync, Mobile & Web, Bill Pay/Mgr

Answers

  • splasher
    splasher SuperUser ✭✭✭✭
    Rather than starting Quicken using the desktop program icon (or the Start menu entry), go to the location of your data file using Windows Explorer.  Then double click on the data file which will cause Quicken to start and use that data file.
    If this works, then Quicken is not remembering the location of your data file and opening up an empty file.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Just a shot in the dark ...
    If the "Quicken not remembering the last used data file" problem really is what's causing your problem: This was reported in the past if the data file name contains a trailing blank, e.g. QDATA_.QDF (where the underscore represents the trailing blank space)
    Using File Explorer with Quicken closed, rename the file to remove the trailing blank space and then double-click the renamed file to start Quicken using it. Quicken should now be able to remember the last used file name.
  • johncr
    johncr Member
    Thanks for responding tried and no success
    Created a new quicken file, changed the name of the backup so there was no connection to previous files
    Restored the backup and everything was there.
    Closed the file, reopened it and all transactions blank. Everything else is there accounts etc just no transactions.
  • johncr
    johncr Member
    UKR
    Thanks Sorry did not see your response before previous answer
    This is the name of the qdf file as it shows in Explorer qb new 2022 3 15 - Copy
  • splasher
    splasher SuperUser ✭✭✭✭
    johncr said:
    UKR
    Thanks Sorry did not see your response before previous answer
    This is the name of the qdf file as it shows in Explorer qb new 2022 3 15 - Copy
    Do a restore and rename it to something short like qdata.qdf to see if that changes things.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • johncr
    johncr Member
    Thanks for your help
    Tried renaming but no luck
    So rerestored and ran valdate repair and that took out just about all transactions.
    So guess my data file has issues.
    I guess I can backtrack in my backups till one works, then add back the transactions since then.
    Any suggestions on this?
    Thanks again
  • BK
    BK Member ✭✭✭✭
    Answer ✓
    It is possible that your installation of Quicken is corrupt which may have possibly damaged your data file.  I would suggest a reinstall which takes less than a minute.  You have not told us what version you currently have?  Going with the assumption that you are on the latest version (as of now R39.23), you can reinstall the latest version using the Mondo patch from this Quicken link.
    - QWin Deluxe user since 2010, US subscription on Win11
    - I don't use Cloud Sync, Mobile & Web, Bill Pay/Mgr

  • johncr
    johncr Member
    Took BK advice and uninstalled and reinstalled quicken. May have had a problem as I had to delete the Quicken folder for it to install.
    Had a backup from a month and a half ago used that and it seems to be working OK . Open and closed quicken a few times and data seems to be intact.
    Corruption somewhere. This the first time this has happened to me and I have been using quicken for 20 years.
    Backups are the key to safety

    Thanks for all your help
This discussion has been closed.