Scheduling a Transaction

This used to work. Likely dumb user error on my part but here goes.

How do I schedule a transaction?

I think I used to right-click on the transaction, choose "Schedule Selected Transaction", and then I could adjust the details of the transaction.

Now nothing happens...
1.jpg 43.9K

Best Answers

  • RickO
    RickO SuperUser, Mac Beta Beta
    edited April 5 Answer ✓
    @CharPatton This is a known issue that's been reported and presumably will be fixed in a coming update.

    Usually what happens is not nothing, but it may appear so. A monthly scheduled transaction is instantly created with no dialog. Depending on your settings for showing scheduled transactions in the register, you may not see it appear.

    The workaround is to use the menu Transactions > New Scheduled Transaction instead of the contextual menu for now. This will open the full new scheduled transaction dialog.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Answer ✓
    …or… schedule the transaction using Schedule Selected Transaction and, although it may seem nothing happened, look in the account register for the gray scheduled transaction one month from today. Double-click that transaction and select Edit All Instances from the small blue pop-up menu; this will let you set the details of the recurring transaction.

    Hopefully the developers will be fixing this in an update this spring. 
    Quicken Mac Subscription • Quicken user since 1993

Answers

  • MontanaKarl
    MontanaKarl Member, Windows Beta, Mac Beta Beta
    It's right in your screenshot above Set Selected ... and below Report...
    Quicken Windows and Mac subscription.  Quicken user since 1990.

  • RickO
    RickO SuperUser, Mac Beta Beta
    edited April 5 Answer ✓
    @CharPatton This is a known issue that's been reported and presumably will be fixed in a coming update.

    Usually what happens is not nothing, but it may appear so. A monthly scheduled transaction is instantly created with no dialog. Depending on your settings for showing scheduled transactions in the register, you may not see it appear.

    The workaround is to use the menu Transactions > New Scheduled Transaction instead of the contextual menu for now. This will open the full new scheduled transaction dialog.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Answer ✓
    …or… schedule the transaction using Schedule Selected Transaction and, although it may seem nothing happened, look in the account register for the gray scheduled transaction one month from today. Double-click that transaction and select Edit All Instances from the small blue pop-up menu; this will let you set the details of the recurring transaction.

    Hopefully the developers will be fixing this in an update this spring. 
    Quicken Mac Subscription • Quicken user since 1993
  • CharPatton
    CharPatton Member ✭✭
    Thanks to RickOand Jacobs for thoughtful answers!
This discussion has been closed.