Export defaults to text file when I select tab-delimited file.

Trying to print a report to Excel. I clicked on Print, selected Export to tab-delimited file. When I click Export, the only option I have is text file. Tested several reports with the same result. I am using the Quicken Deluxe, version 40.21 and Windows 10 Pro, version 21H1. Is there a fix for this? I have screen shots if you need them.
Tagged:

Best Answer

  • [Deleted User]
    Answer ✓
    @anyoneva - When you do save it in Windows, it does say *.txt.  But, if you open the file with Excel it does seem to work properly.  Right click on the file, choose "Open with" and then open it with Excel.  If Excel is not an option on your list, you would need to search for it with "Choose another App".  You might have to keep drilling down to "Look for another app on this PC".  Here is where my Excel is - 

    C:\Program Files\Microsoft Office 15\root\office15\MSExcel.exe

    Once you do this once, the Excel option will always then be on your list of "open with" options.

Answers

  • [Deleted User]
    Answer ✓
    @anyoneva - When you do save it in Windows, it does say *.txt.  But, if you open the file with Excel it does seem to work properly.  Right click on the file, choose "Open with" and then open it with Excel.  If Excel is not an option on your list, you would need to search for it with "Choose another App".  You might have to keep drilling down to "Look for another app on this PC".  Here is where my Excel is - 

    C:\Program Files\Microsoft Office 15\root\office15\MSExcel.exe

    Once you do this once, the Excel option will always then be on your list of "open with" options.
  • [Deleted User]
    edited May 2022
    @anyoneva - have you tried the "Export to Excel Workbook" option?  In the upper right of the report window, just click on the little spreadsheet icon with the green arrow, and choose the Export to Excel" option and it will automatically save your report to Excel.  One caveat - if you have a large report, then your way works better.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    There isn't any "type" for "tab delimited", and as such, .txt is actually the right file type for it.
    Most of the time .PRN is the better choice.  If you save it with a .CSV suffix, it will open easier into Excel or other spreadsheet programs.  With the tab delimited/.txt Excel will ask you about the formatting when you open it, with a CSV it knows it is separated by comas.  One quirk in this format is I don't believe it handles comas in the data correctly.

    And these days as @Damian pointed out you can do an export to Excel format. You can also right on the report and select to Copy to Clipboard.  And then Ctrl+V to paste it into an Excell spreadsheet.
    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • anyoneva
    anyoneva Member
    Thank you Damian. The first option worked!
  • You are welcome.  Glad you got it to work.
This discussion has been closed.