T.Rowe Mutual fund changed to iClass, however, download still compares to old investments

Jim Stickler
Jim Stickler Member ✭✭
In January TRowe Price changed 3 of my accounts from standard to iClass shares. I correctly used the Mutual Fund Conversion function to reclassify the transations based on the new per share value of the account.
However when I download, I get a message that 2 of the 3 accounts have a securities comparison mismatch.
The system is showing that the transactions downloaded are for the standard shares and the iClass shares are shown as a zero balance.
The 3rd account works fine.
I have:
Updated the ticker symbol to the new symbol for all accounts
Run a reset and selected the correct account number just to make sure.

Any ideas what else I can try?

I've attached screen shots of the messages.

Comments

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    I suspect the CUSIP IDs for the Quicken securities have been mismatched.  I suggest you uncheck Matched with online security on the Edit Security Details window of the mismatched securities.

    The CUSIP ID is provided by the financial institution when we download transactions. The CUSIP ID is assigned to a Quicken security when we match an online security to a Quicken security.   Quicken should prompt to match an online security to a Quicken security when the financial institution provides a security with a CUSIP ID that has not been assigned to a Quicken security.  If a Quicken security has been mismatched, we may uncheck Matched with online security on the Edit Security Details window and the Quicken security will become available to be matched to an online security when Quicken next encounters an unmatched online security.
  • Jim Stickler
    Jim Stickler Member ✭✭
    Thank you for your reply.

    I opened the three funds and found that the one that is working had the box checked, while the other two had the box unchecked, but grayed out. I will attempt to download again and see what happens.
    Unfortunately, there won't be any new transactions to download until next month. I 'll get back to you with the results.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited July 2022
    Thank you for your reply.

    I opened the three funds and found that the one that is working had the box checked, while the other two had the box unchecked, but grayed out. I will attempt to download again and see what happens.
    Unfortunately, there won't be any new transactions to download until next month. I 'll get back to you with the results.
    There shouldn't need to be any new transactions.  Quicken should request to match the unmatched securities based on the downloaded share balances.  For example, open an investment register, press Ctrl + Shift + N, and select Reconcile Shares....
  • @Jim stickler another thing you can do to verify that you have the right Fund IDs or Tickers for the funds is to go into "Edit Security Details" and then click on "Look Up" to the right of the fund symbol box.  If you have the correct fund id/ticker for the fund, then the correct Fund Name will show in the list box.
  • Jim Stickler
    Jim Stickler Member ✭✭
    I found the problem and the solution. The funds that had the problem had a memorized investment transaction for the old security. Apparenlty the memorized transaction over-rode the transaction with the new i-class security.
    I deleted the memorized transactions and memorized the new i-class transactions. I still have to wait until next month to fully test this solution.
This discussion has been closed.