MIGRATION HELP: Quicken 2007 PowerPC ---> Quicken (current version)

JPR66 Member ✭✭
I have three intact and working Quicken 2007 data files (one personal, two business) running on a G4 PowerPC G4 (10.5.8 / Leopard) that I am trying to import into an iMac (12.0.1 OS / Monterey) running the latest Quicken version.

I keep getting this error:

"Could not import "myaccounting.qdfm"

An error occurred while preparing the file to be imported."

I have read through the forums and here's what I've done:

1. Rebuilt the database on the existing file, "Save a Copy" to an HFS+ formatted thumbdrive, ZIPped that copy as well, brought it over to new iMac. Neither the original nor the ZIPped file would import.

2. On the G4, I created a *brand new* Quicken file and populated it with two accounts with two entries each. Same error result and failure to import.

3. Tried exporting/importing the data as a QIF file, and got this error:

"The file “NEW_QFILE2.qif” couldn’t be opened because the text encoding of its contents can’t be determined.

You may be able to open the file by specifying a text encoding."

Has anyone successfully migrated a PowerPC Q2007 file to an Intel version?

Is there anything I may try that I haven't?


  • JPR66
    JPR66 Member ✭✭
    (I should note that I am using Quicken's icloud conversion method. The file seems to upload, convert, and download the file as it should, then immediately gives me the error message noted above.)
  • JPR66
    JPR66 Member ✭✭
    @jacobs I thought I'd loop you in here, since you seem to be very knowledgable on this subject! Thank you in advance.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Hmm, I'm not sure what the issue is. There should be no problem importing a Quicken 2007 data file; it doesn't matter if it's the original PPC version or the updated Lion version. The fact that you created a new Quicken 2007 data file with a few transactions, and it failed to import correctly, is what has me stumped.

    I wouldn't expect the QIF export to work. The fact that your attempt to create a file and say it did the upload to the Quicken Cloud part okay, but then failed after the intermediate file from the cloud wouldn't import is what concerns me. I don't know if it's possible the developers broke something in the import portion of the code with any of their recent changes to Quicken Mac. There aren't a lot of people converting from Quicken 2007 these days, but there have still been a few people posting about earlier this year. 

    One question: you said you've been trying to import your old data file. I just wanted to make sure you are not using the File > Import command, and are using File > New. I think you are but just wanted to check. 

    Hopefully someone else might have an idea. The next thing I might try downloading a slightly older copy of the Quicken app to see if that makes a difference (e.g. if they broke something in the app recently that we're not aware of). I can tell you how to do that once you follow up.
    Quicken Mac Subscription • Quicken user since 1993
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    @JPR66  If you want to try my hunch to see if a slightly older version of Quicken Mac will convert the Quicken 2007 files correctly, go to this Quicken web page, which has links to download older versions of subscription Quicken Mac. I would maybe try the January 2022 6.5.3 release. If they have the installer built correctly to not instantly update you to the current release, you should get the older version installed, and you should hit Remind Me Later for the dialog box about a newer version being available. If the files convert correctly to Quicken Mac, then you can easily upgrade the application to the current 6.8 release and you'll be all set. Again, this will only help if there's a bug in the current version which wasn't present in the older version; I don't know if that's the case, so it's just something to try.
    Quicken Mac Subscription • Quicken user since 1993
  • JPR66
    JPR66 Member ✭✭
    @jacobs Thank you much for seeing my request and adding some info. I am going to digest your thoughts and suggestions, then come back here to post the results.

    Just to get this out there, I now have the Intel Q2007 (16.1.0 / build 19.725.400) running on an Intel iMac (El Capitan), so I am going to try creating a new data file there + Save A Copy + ZIP + importing to Q202* as well.

    Stay tuned!
  • JPR66
    JPR66 Member ✭✭

    Update: I ran with your suggestion of downloading an older version of Q202* and trying to import that way. Using my Q2007 on the Intel iMac (El Capitan), I

    1. Created a NEW data file and populated it with two accounts and two entries each.

    2. Made a "Save a Copy" of that file and ZIPed it.

    3. Moved it to the new (Catalina) iMac on an HFS+ thumbdrive and unZIPped it.

    3. Downloaded and installed every version of Q202* beginning with 6.4.5 through the latest version (with one install on the iMac at a time, of course).

    4. Tried "new" (opening and converting) the data file just created in Step 1 above, via the Quicken cloud, and got the same error each time (see screenshot). It uploads > converts > downloads > tries importing > error

    Since Q202* continues to offer the option of opening and converting Q2007 files, I am admittedly frustrated. Could there be anything weird with my computing environment?

    I've tried using different WiFi signals to no avail (I have two coming from a combo Modem/Router, and two more coming from a router-only connected to that Modem/Router). I even tried using my iPhone hotspot to see if the router was causing an issue.

    Anything else to try before I abandon the idea of ever being on modern Quicken? Different thumbdrive (although it seemingly works properly for all other uses)? Use an SSD external to move the file? Wave a wand? ;)

    I appreciate any suggestions!
This discussion has been closed.