Why doesn't Quickfill work? (Q Mac)

robinelisabeth
robinelisabeth Member ✭✭
I finally switched from Quicken Mac 2007 to Quicken Mac Deluxe about 6 months ago, and there are still some things that I'm finding difficult. I really don't understand how the Quickfill feature works, at all. For instance, I have a Quickfill rule for Express Toll. If I want to manually enter a payment to Express Toll, I begin typing it into the register, and a drop down box appears which initially offers me the option to "Create New Payee 'Express Toll,'" but when I finish typing in the name, the option to create a new payee has disappeared, and I always have to type in the entire name, it never fills in for me. I tried typing "Express Toll" into the list of Payees, but I get an error message when I try to save it, which says "Duplicate Payee Name." So I have to manually type in each payee every single time. I thought maybe my Quickfill file was corrupted, so I deleted all of the rules and started over, but now things are even worse, because it won't let me add Quickfill rules for at least some of the payees that I deleted, again indicating that they are "Duplicate Payee" names, even though they're not on the list any more. What's the deal? There are lots of inexpensive little bookkeeping programs that I could purchase online that will fill in payee names. Even MS Xcel does it. Why can't Quicken do this?

Best Answers

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Answer ✓
    @robinelisabeth I can come up with a scenario which I think matches what you're describing: a hidden Payee.

    Open the Window Payees & Rules window. Do you see a Hidden column on the far right? Now see if the "Show Hidden?" checkbox at the top left is checked. I'm guessing it's not, so check it. Now type "Verizon" in the Search box and see if it shows there is an existing Payee called Version which has a checkbox in the Hidden column. Uncheck that checkbox, and then try entering a transaction for Verizon; it should now show Verizon in the dropdown under Best Matches. And if you have one or more QuickFill rules for Verizon, they should all show up, as in the screen shot John provided above.
    Quicken Mac Subscription • Quicken user since 1993
  • robinelisabeth
    robinelisabeth Member ✭✭
    Answer ✓
    YES! Thank you! I actually just figured this out right before I saw your message :-) The only problem now is that I discovered I didn't delete any payees, I just hid them all, and there doesn't seem to be an easy way to unhide multiple payees. It looks like I'll have to uncheck each one individually...

Answers

  • John_in_NC
    John_in_NC SuperUser, Mac Beta Beta
    Corruption is quite rare on this Mac version, so I highly doubt that. You might have caused more (temporary) hardship by deleting all your rules, though.

    QuickFill is relatively simple: start typing in the payee, and as typing matching recent transactions, it pops up suggested QuickFill rules for matching payees that you can up/down arrow or click on:



    Your mention of continually "creating a new payee" confuses me.  You should only see that for a new, unique payee and not for every new transaction. That might be part of your confusion. In my above screenshot, "Food Lion" is only a single payee, with several variations of QuickFill rules. Every transaction I enter is a suggested QF template of that payee. Even if I have a new variation of the QuickFill rule, it is the same Payee "Food Lion."

    I suspect you might be your own worst enemy by deleting all these rules and/or payees-let the program do its job. QuickFill and memorized transactions works quite nicely once you get used to how they work.
  • Hi John,
    Thank you for answering my question. This is how I would expect things to work. But, strangely, for me, it doesn't. So, for instance, if I type in "VERIZON" as soon as I type the last letter, the option to save the Payee name disappears.



    If I try to manually enter the name in the Payee list, I get a message saying it's a duplicate name, and I can't enter it.


    But when I try again to type in "VERIZON" I'm not offered any option to select that name from a list. Until I type the last letter of the name, it offers me the option to save it as a new payee (so I could save the name VERIZO), but as soon as I type the last letter, it disappears.

    I've tried talking to Quicken support about this, but they didn't seem to be able to help me. I wish I could figure it out. I'm tired of having to type in every single entry.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Answer ✓
    @robinelisabeth I can come up with a scenario which I think matches what you're describing: a hidden Payee.

    Open the Window Payees & Rules window. Do you see a Hidden column on the far right? Now see if the "Show Hidden?" checkbox at the top left is checked. I'm guessing it's not, so check it. Now type "Verizon" in the Search box and see if it shows there is an existing Payee called Version which has a checkbox in the Hidden column. Uncheck that checkbox, and then try entering a transaction for Verizon; it should now show Verizon in the dropdown under Best Matches. And if you have one or more QuickFill rules for Verizon, they should all show up, as in the screen shot John provided above.
    Quicken Mac Subscription • Quicken user since 1993
  • robinelisabeth
    robinelisabeth Member ✭✭
    Answer ✓
    YES! Thank you! I actually just figured this out right before I saw your message :-) The only problem now is that I discovered I didn't delete any payees, I just hid them all, and there doesn't seem to be an easy way to unhide multiple payees. It looks like I'll have to uncheck each one individually...
  • Actually, I figured this out, too. I can select multiple payees in the payee window, and then right click (or control click) on one of them, and I get an option to "Show Payees." If I click on that, it unhides all of the ones I've selected. Thank you again for your help.
This discussion has been closed.