How Do I Prevent Quicken for Windows from Updating ?

I am a 20 year Quicken for Windows veteran...so yes I'm a certified masochist and have a high tolerance for troubleshooting issues.

I have spend hours trying to troubleshoot my investment accounts showing incorrect balances recently. They related to both Well Fargo Brokerage accounts and especially Morgan Stanley accounts. I even tried starting over with fresh accounts. Nothing worked.

TLDR...I ran across a post on these forums by " @"Rocket J Squirrel" that the latest updates were supper buggy and that he recommended rolling back to the R44.28 mondo-patch. I did this and to my joy everything was magically and instantly fixed!

His post was here ...

https://community.quicken.com/discussion/7925457/morgan-stanley

So my question is...how do I keep on the non-buggy older version in the Mondo-Patch above and prevent Quicken from auto-updating me back to version 45 aka "Buggy Hellish Version"?

Do I need to keep constantly mondo-patching back to the older version daily or is there a way to prevent quicken auto updates?

Thank you!

Best Answer

  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    edited January 27 Answer ✓
    Since Quicken does not have a "Turn Off Quicken Updates" button perhaps the best thing to do is to go to your User Account Control Settings and make sure it is set to "Always Notify".  Then when Quicken tries to update your version you will be given the opportunity to either allow the update to proceed or to deny it.

    Another option is to go to Advanced Security for Windows Defender Firewall and block Outbound access by disabling QuickenPatch.exe:  Double click on QuickenPatch.exe > General tab > uncheck the box for "Enabled" > OK.  (NOTE:  If QuickenPatch.exe is not listed there, it will need to be manually added before it can be disabled.)  This will definitely stop Quicken from being able to check for updates and update the version entirely, even why you prompt Quicken to check for updates.  If you ever want to try to update Quicken in the future you will need to go back to the firewall properties in Advanced Security and then check the box for "Enabled", again.  (If you are using a different firewall than Windows Defender Firewall, then you'll need to find out how to block or disable QuickenPatch.exe from making an outbound Internet connection with the firewall you are using.)
    (QW Premier Subscription: R44.20 on Windows 11)

Answers

  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    edited January 27 Answer ✓
    Since Quicken does not have a "Turn Off Quicken Updates" button perhaps the best thing to do is to go to your User Account Control Settings and make sure it is set to "Always Notify".  Then when Quicken tries to update your version you will be given the opportunity to either allow the update to proceed or to deny it.

    Another option is to go to Advanced Security for Windows Defender Firewall and block Outbound access by disabling QuickenPatch.exe:  Double click on QuickenPatch.exe > General tab > uncheck the box for "Enabled" > OK.  (NOTE:  If QuickenPatch.exe is not listed there, it will need to be manually added before it can be disabled.)  This will definitely stop Quicken from being able to check for updates and update the version entirely, even why you prompt Quicken to check for updates.  If you ever want to try to update Quicken in the future you will need to go back to the firewall properties in Advanced Security and then check the box for "Enabled", again.  (If you are using a different firewall than Windows Defender Firewall, then you'll need to find out how to block or disable QuickenPatch.exe from making an outbound Internet connection with the firewall you are using.)
    (QW Premier Subscription: R44.20 on Windows 11)
  • Flux
    Flux Member ✭✭
    > @Boatnmaniac said:
    > Since Quicken does not have a "Turn Off Quicken Updates" button perhaps the best thing to do is to go to your User Account Control Settings and make sure it is set to "Always Notify".  Then when Quicken tries to update your version you will be given the opportunity to either allow the update to proceed or to deny it.
    >
    >
    > Another option is to go to Advanced Security for Windows Defender Firewall and block Outbound access by disabling QuickenPatch.exe:  Double click on QuickenPatch.exe > General tab > uncheck the box for "Enabled" > OK.  This will definitely stop Quicken from being able to check for updates and update the version entirely, even why you prompt Quicken to check for updates.  If you ever want to try to update Quicken in the future you will need to go back to the firewall properties in Advanced Security and then check the box for "Enabled", again.  (If you are using a different firewall than Windows Defender Firewall, then you'll need to find out how to block or disable QuickenPatch.exe from making an outbound Internet connection with the firewall you are using.)


    Perfect! Thank you :)
  • D Barnes
    D Barnes Member ✭✭
    Perfect solution. Now on to roll back to R44.28... I'm so glad they gave us the option on how to highlight a register row in R47.7 /s/ but didn't fix the load time. R47.7 took 2 minutes and 19 seconds to load -- UNACCEPTABLE.
    Thanks for the tips @Flux & @Boatnmaniac
  • Zeker
    Zeker Member ✭✭
    Well, it works, but makes my entire use of the computer subject to UAC when I only want choice whether to update Quicken or not. Shameful. Even Microsoft allows some user control over updates.
  • mrzookie
    mrzookie Member ✭✭✭✭
    @Zeker

    If you drop down 1 notch from "always notify", you will get far few notifications. Quicken, however, will still be subject to your approval.
  • Zeker
    Zeker Member ✭✭
    > @mrzookie said:
    > @Zeker
    >
    > If you drop down 1 notch from "always notify", you will get far few notifications. Quicken, however, will still be subject to your approval.

    That's where it is set. Pops up for many routine operations. Quicken just needs to implement some kind of "skip" or "postpone this update" option.