Stock sale allocations

When selling a partial position in a stock am I able to assign the sale to a specific purchase?
Tagged:

Comments

  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    Yes, you can do that.  In the situation where you have more than one lot you have a variety of ways of selecting lots, like FIFO, LIFO, specific identification, and other ways of selection:

    Clicking that "specify lots" button will get you into that process.
  • MISCOPT
    MISCOPT Member ✭✭
    Tom, good news, thank you, though Specify Lots is not an option offered in me entry window. I am in Investment account registers and I am wondering why that option isn't available to me. Any thoughts?
  • NotACPA
    NotACPA SuperUser ✭✭✭✭✭
    @MISCOPT, what Q product are you running and what BUILD of that product?  Do HELP, About Quicken for this info.
    I ask because I'm also able to designate specific lots in a partial sale.
    And, as @Tom Young did, can you please provide a graphic of a Sale transaction?
    Q user since DOS version 5
    Now running Quicken Windows Subscription, Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    edited January 13
    I'm surprised. I have never in my life seen a "Specify Lots" button inline in the investing register. I see "Enter Edit Delete Attach".
    I do see "Specify Lots" in the transaction dialog for a Sold transaction and am prompted for lots when I do a partial sale. My understanding is for the prompting to occur, preferences must be set to not automatically accept investment transactions and not to automatically assign lots. Like this:

    Quicken user since version 2 for DOS, now using QWin Premier Subscription (US) on Win10 Pro.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    I'm surprised. I have never in my life seen a "Specify Lots" button inline in the investing register. I see "Enter Edit Delete Attach".
    IF you start manually entering a Sold directly in-line in the register, identify the security, and specify fewer shares sold than owned in that account, THEN the in-line Specify Lots button appears.  After the transaction is entered, you need to go through the Edit button to get to that Specify option.  

  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    @q_lurker, any idea how long that functionality has been there?

    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    edited January 13
    mshiggins said:
    @q_lurker, any idea how long that functionality has been there?

    Almost definitely a subscription era addition ... but even that is just my aging recollection.

    PS.  I've found it a valuable addition when in manual entry mode, even if I never did see anyone ask for it.  Have not noticed it applicable for download situations which have had their own issues with Lot Specification prompts.  Maybe this got introduced when they brought in the options to default to FIFO or LIFO for downloaded sales.
  • MISCOPT
    MISCOPT Member ✭✭
    I appreciate all of the input though I remain confused as to why some of us have the ability to specify Lots within a register and others do not. Here is my Version and Build number (asked for by one of the contributors) VERSION: R46.12 Build: 27.1.46.12 Windows 10 Home
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    Just tried it in QW2017. As @q_lurker instructed, start entering a Sell transaction in the register, with the number of shares less than the total available shares of that security. The Specify Lots button becomes visible. 

    I don’t typically use the register entry to enter transactions, mostly use the Enter Transactions form, so missed seeing the button in the register previously.  

    @[email protected] if you edit the Sell transaction it will open the Edit form. The Specify Lots button is available in the Edit form just below the Commission field.

    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • MISCOPT
    MISCOPT Member ✭✭
    @mshiggins I went back and edited the transaction that created the issue and it worked. The solution offered by @q_lurker with screen shot appears to be a solution too, though I manually enter my transactions vs. downloading them so it doesn't apply. Glad for all the help, though you have to wonder why it's so many steps.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    edited January 14
    MISCOPT said:
     … The solution offered by @q_lurker with screen shot appears to be a solution too, though I manually enter my transactions vs. downloading them so it doesn't apply.
    I’m confused. What I was pointing out to my knowledge ONLY works with manual entries so it absolutely should apply to your manual entries.

    That Specify lots button only appears when the security field is filled and the number of shares specified is less than the shares owned and before the in-line transaction entry is first made. Once the transaction is actually entered, the button will not reappear. So it is there for a very short period of time. 
  • MISCOPT
    MISCOPT Member ✭✭
    You are correct and thank you for clarifying. The screen shot I was referring to was posted by Robert J. Squirrel relating to setting up the Lots button by default for downloaded transactions.