Need help.

HELP! I cannot open my Quicken. Nothing happens when I click on the Quicken icon. Can anyone help me with this problem?


  • Quicken Jasmine
    Hello @jenrose4523,

    Thank you for taking the time to visit the Community and adding to this discussion with details about your issue, though I apologize that you are experiencing this.

    Have you tried uninstalling/reinstalling Quicken? Please refer to the following support articles for instructions on uninstalling here and reinstalling here.

    Please let me know how this goes!

    -Quicken Jasmine

    Make sure to sign up for the email digest to see a round-up of your top posts.

  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    edited January 2023
    Have you tried to reboot your computer?  Sometimes programs can become non-responsive (including not being able to launch a program) because of some memory, CPU or other resource constraint.  Rebooting the computer can often help eliminate that issue.

    (Quicken Classic Premier Subscription: R55.15 on Windows 11)

This discussion has been closed.