Printing page scaling is greyed out in Quicken Premier

htconant Member
edited March 26 in Reports (Windows)
I have a brother printer with latest factory (not windows) driver. Quiken Premier report page scaling is greyed out whether or not page scaling is set in printer properties. And the report doesn't actually print anything like the preview. Its trial and error and a waste of time.


  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭

    Is your problem that the print preview shows the report text too small and in the top left of the page? Is the printed output also incorrect, or does it fill the whole page?

    If so, try right clicking on the Windows desktop and selecting Display settings. Is the Scale under Scale and Layout set to something other than 100%? If so, set it temporarily to 100%. This will make everything on your screen look small, but does the print preview now match the printed output?

    Please let us know…

    QWin Premier subscription
  • htconant
    htconant Member
    Yes the print is small in top right corner.
    Yes change Display settings to 100% (from the recommended 200%) does make the preview match the printed output.
    That said, the app print settings still has the scaling greyed out, and my prefered scaling of 1 page wide is not available, not is "Adjust to" setting. So it did react as you asked, but it doesn't solve my issue.
  • htconant
    htconant Member
    Was hoping for a solution to this. The printer is a Brother MFC-J880DW. I use it all the time and use print scaling often for Quickbooks reports and other apps. Do not have this problem on anything other than Quicken which just installed for the first time today to try it out.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭

    As far as I know, the only actual page scaling that works with Quicken is when you use the Quicken-supplied PDF driver. You might give that a try and see if it meets your needs. Of course then printing becomes a 2-step process of generating the PDF file and printing that.

    There have been several discussions about this over the years - search this forum for “page scaling” and you will see them - but no resolution. Usually these discussions get tangled up with the Print Preview issue discussed above.

    QWin Premier subscription
  • UKR
    UKR SuperUser ✭✭✭✭✭

    The issue with the Print Preview showing a smaller than usual preview image was supposed to have been fixed in the US version R 47.7
    If you're not on this version or the current higher version R 47.15 yet, please install the missing updates.

    For your hi res monitor also please consider the following:

    Font size problems? Display issues? (Windows)

    If you are using a version of Quicken at the Quicken 2019 US R 19.44 patch level or newer and you have previously made the following Compatibility change, please undo the change.
    Users of other Quicken versions please try the following:

    • Close Quicken !!! (This process won't work while Quicken is running!)
    • Check the Compatibility tab settings in your Quicken Desktop program icon:
    • In the Windows Start Menu right-click the Quicken icon. Select "Open File Location". This brings up a Windows File Explorer window. Right-click the highlighted Quicken shortcut line item.
    • Go to the traditional Windows Desktop and right-click the Quicken program icon.
    • Use Windows File Explorer, navigate to C:\Program Files (x86)\Quicken\ and right-click qw.exe
    • Now click Properties.
    • Select the Compatibility tab.
    • Uncheck all settings.
    • Windows 7, 8.1: Check "Disable display scaling on high DPI settings".
      Windows 10, 11: Click "Change high DPI settings". Check "Override high DPI scaling behavior. Scaling performed by:" and select "Application" (also try the other available options repeating the entire procedure!). Click OK.
    • Be sure to uncheck the "Run this program in compatibility mode for [older Windows version]" setting.
    • Click the "Change settings for all users" button.
    • Click Apply and exit.
    • Reboot Windows.
    • Now start Quicken and see if that makes a difference.

    Some additional tuning suggestions:

    • Try this workaround for 4k monitors
    • System requirements: 1024x768 or higher screen resolution, 1280x1024 minimum for Large Fonts settings
    • Unless absolutely required, try not to use "View / Use large fonts"
    • Try setting the bank account registers to use a different font style or size: go to Edit / Preferences / Register, click the Fonts button and try different fonts.
    • Try adjusting the bank account registers' row height: go to Edit / Preferences / Register, choose among the available Row Height choices: Compact, Comfortable or Standard
    • If all else fails, try changing Windows Control Panel / Display options for "Make text and other items … smaller or larger" to use a different scaling level, but try not to exceed 125%
    • Try using the Windows Magnifier. Press the Windows logo key and the = key to open Magnifier. Customize Magnifier to increment Zoom in 25% intervals.

  • I am on Version R47.15 Build running Win10. Setting the high DPI setting to Application makes the entire app format improperly on the monitor so that cannot be used. This would seem simplest if the Page Scaling in the Print box was not greyed out and the settings, such as fit one page wide, or the percentage settings could be changed at the app Print box. It is very unusual in my experience to that those very important settings unavailable.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭

    Did you try the Quicken PDF driver in conjunction with setting the Windows page scaling to 100%? You access the PDF driver by picking Quicken PDF Printer as your printer. For some reason that appears to be the only “printer” that supports scaling.

    That is inconvenient but would give an indication of whether enabling scaling would do what you want. A quick experiment indicates that for example Fit to 1 page wide x 1 page tall works as expected.

    QWin Premier subscription
  • Actually I did that with Adobe PDF printer and Quicken PDF printer. It seems any PDF printer, including Microsoft print to PDF works as far as scaling. That said, it is a very inconvenient work around for a modern app like quicken. It should simply work without have to create a PDF and then print that, so in the case of multiple reports now you have unnecessary files that need to be deleted.
  • UKR
    UKR SuperUser ✭✭✭✭✭

    Instead of “Application”, did you try the other available settings? At least one of them should work …

This discussion has been closed.