Some Search Results & Credit Transactions Show as Debit in Transaction Report

The Keeper
The Keeper Member ✭✭✭✭
edited April 2023 in Reports (Windows)

When I run a transaction report for a credit card, SOME transactions appear as "debit" on the report.

Likewise, when I conduct a search for a transaction amount, the search window opens and MAY display the transaction as a debit under the "number" column. When I double-click the transaction it opens in the credit card account where it IS NOT shown as a "debit" because the credit card register has no way to enter a transaction as "debit."

Sometimes the same merchant transaction appears as "debit" in the search window and the transaction report window and other times for the month it does not show as debit.

This quirk does not cause any reconciling issues etc; so perhaps I shouldn't lose any sleep over this issue. I'm just wondering if I am inadvertently doing something to trigger a credit card transaction to sometimes show as a debit on a transaction report.


  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭

    Well of course transactions that are true debits (as accountants use that term) certainly can occur if you do a return and the charge is subsequently reversed, but I take it that actual charges on the credit card sometimes and in some places show up as debits in your file instead of credits?

    I seldom run any reports on my credit cards but I ran Banking > Transaction reports on two of my most used credit cards covering a 12 month period and did not see and charges that showed "in reverse." I certainly can't think of anything you're doing that could be causing this odd behavior.

    You might want to Validate the file and see if anything shows up in the report and if this behavior is corrected.

  • The Keeper
    The Keeper Member ✭✭✭✭

    thanks for your reply. I should have clarified my post as it is Banking>Transaction report that I run. I'm not going to lose any sleep over this as it is just a "curiosity" question and doesn't affect any transactions just being a label.

This discussion has been closed.