How can I prevent the automatic visual shift to the right when typing in the register notes?

For me, the visual auto shifting thing, while I'm still looking at the content i.e. what I'm working on, while typing, is very disruptive to my workflow. I'm seeing this trend in other applications as well. In Quicken, The Memo/ Notes section in the register shifts the view to the right when I insert the cursor or type long notes. Then I can't see the Date, etc for reference and confirmation. I'm not given ANY choice about this. FileMaker/ Now they shift the entire record upward if the record is partially visible and you insert a cursor when getting ready to type. In Numbers, the whole cell moves upward if you insert a cursor when getting ready to type. I wish this trend would GO AWAY! How can I stop the automatic shifting to the right when typing in the Notes section in Quicken?

Best Answer

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Answer ✓

    If you intentionally put Memo/Notes on the right, and it goes beyond the side of your Quicken window, then it will always result in the horizontal scrolling you're trying to avoid. If you positioned the Memo/Notes column fully within the width of your Quicken window — either by moving the column to the left, or narrowing one or more columns enough that all the columns are fully visible in the window, or widening your Quicken window to create more horizontal space — you'd eliminate the horizontal scrolling.

    I rarely do extensive work other than searches from the account groups in the sidebar (e.g. All Transactions or Cash or Credit Card); I work in individual account registers, so there's no column for Account in those registers. I've found I can narrow the date column so it's just wide enough for mm/dd/yy, and I narrow the Payee and Category columns a bit from their defaults so I can see enough to determine the field contents without seeing every character of long Payee names or Categories. I also use the two Payment and Deposit (money in/money out) columns instead of the unified Amount column, and even with the Transfer column visible, I can make Memo/Notes my widest column and fit all columns on a screen that's not quite the full width of my 13" laptop:

    On my larger iMac screen, I can make the columns a bit wider. I could (and do in some accounts) also hide the Transfer column, allowing me to make the Memo/Notes column wider. The Memo/Notes field isn't wide enough for my longest notes, but the text scrolls within the field so there's no jumping.

    You originally asked: "How can I stop the automatic shifting to the right when typing in the Notes section in Quicken?" The answer is simply to make all your columns visible within the width of your Quicken window. I always size my registers so there is no horizontal scrolling

    Quicken Mac Subscription • Quicken user since 1993

Answers

  • RickO
    RickO SuperUser, Mac Beta Beta

    If I'm properly understanding what you are describing, it sounds like the widths of the columns in the register are such that they don't all fit within the screen width dimension. When this is the case, the window will automatically scroll sideways to show the full column you are working in on screen.

    The solution is to adjust the column widths so everything fits within the width of your screen. The default width of many columns is wider than what's needed, so you may be able to narrow them without losing sight of any info. To adjust a column width, hover your cursor over the vertical line to the right of the column header you want to adjust. It will turn into a left/right arrow icon. Click/drag that line to adjust the width.

    Another solution might be to re-arrange the column order so that the memo column is closer to the other columns you want to keep in view while entering the memo. To change the order of columns, click/drag the column header into the new postion.

    BTW, in macOS Settings > Appearance, you can adjust when scroll bars are displayed. This can make it more obvious when a window is wider or taller than display and thus will scroll to view other parts of the window. I have mine set to "always" so I always have that visual clue when a window is taller or wider than the screen.

    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • UKR
    UKR SuperUser ✭✭✭✭✭

    Could this be a Mac OS setting, dependent on the Primary Language, Region or other setting which enables "Right-to-left Reading Order", as is used some Oriental languages?
    In Quicken for Windows, there is such a setting and a simple keyboard command to enable/disable right-to-left reading order.

  • jacobs
    jacobs SuperUser, Mac Beta Beta

    @UKR You're overthinking, I think. 😉 The original post said "the register shifts the view to the right", meaning it scrolls horizontally to the right, in order to make the active field fully visible. Quicken Mac by default does not show the Memo field, and when a user adds it, it appears on the far right — so horizontal scrolling is likely unless one has a large monitor and a wide Quicken window to show all the fields fully. As @RickO suggested, moving the Memo field further to the left, as well as possibly narrowing one or more fields, is likely to resolve this issue. I generally have Status, Date, Payee, Category, Memo as the first five fields in my registers.

    Quicken Mac Subscription • Quicken user since 1993
  • Everyone is trying hard to help. That's appreciated.
    - UKR The right to left reading order setting is the most interesting. Couldn't find it in the Preferences for the Mac version. Where is this setting in Windows? Maybe I can find it that way.
    - I've worked with stretching the note section out to the right. Frankly, stretching out something approx. 10 inches just isn't practical and wastes space on my 2 27" screens. I want to be able to see the date and amount on the left while I'm typing. Scanning with peripheral vision helps keep context for me mentally. The sudden shift, look for the cursor again thing is mentally disruptive and to avoid that, Quicken would hog space. I need something better.
    - Re-ordering the Quicken columns-I already have them in the order I want. Date, Amount,Account,Payee,Category,Notes. Notes are a last priority and the longest column at the end on the right.
    - I've already narrowed the more important fields on the left.
  • wWY245nY890PNy89
    wWY245nY890PNy89 Member ✭✭
    edited April 2023
    RickO & Jacobs.

    I shortened the memo/notes column on the end on the right. I can still see everything on the left and see the notes as I type. If I have to see all the notes, which isn't often, I'll just stretch the notes column to the right. Thanks for helping leading me to a workable solution.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Answer ✓

    If you intentionally put Memo/Notes on the right, and it goes beyond the side of your Quicken window, then it will always result in the horizontal scrolling you're trying to avoid. If you positioned the Memo/Notes column fully within the width of your Quicken window — either by moving the column to the left, or narrowing one or more columns enough that all the columns are fully visible in the window, or widening your Quicken window to create more horizontal space — you'd eliminate the horizontal scrolling.

    I rarely do extensive work other than searches from the account groups in the sidebar (e.g. All Transactions or Cash or Credit Card); I work in individual account registers, so there's no column for Account in those registers. I've found I can narrow the date column so it's just wide enough for mm/dd/yy, and I narrow the Payee and Category columns a bit from their defaults so I can see enough to determine the field contents without seeing every character of long Payee names or Categories. I also use the two Payment and Deposit (money in/money out) columns instead of the unified Amount column, and even with the Transfer column visible, I can make Memo/Notes my widest column and fit all columns on a screen that's not quite the full width of my 13" laptop:

    On my larger iMac screen, I can make the columns a bit wider. I could (and do in some accounts) also hide the Transfer column, allowing me to make the Memo/Notes column wider. The Memo/Notes field isn't wide enough for my longest notes, but the text scrolls within the field so there's no jumping.

    You originally asked: "How can I stop the automatic shifting to the right when typing in the Notes section in Quicken?" The answer is simply to make all your columns visible within the width of your Quicken window. I always size my registers so there is no horizontal scrolling

    Quicken Mac Subscription • Quicken user since 1993
  • jacobs
    I agree. And that works with the compromise that I won't be able to see the entire text while I'm typing, without the Quicken drama shift to the right.
    As you suggested, "...make all your COLUMNS visible within the width of your Quicken window." I'm shortening the Notes COLUMN, on the far right. At least I will be able to see my new typing, without the "jump".
  • UKR
    UKR SuperUser ✭✭✭✭✭

    @wWY245nY890PNy89 ,

    in a Windows system, the right-to-left reading order can be set with a simple keystroke sequence. Please read this for more information.

    In a Mac OS System, there may be something you need to set or change if your primary system language is defined as an Oriental language which writes and reads from right to left instead of US-English or another Western language. Search the Internet or ask Apple Support for help on that.

  • RickO
    RickO SuperUser, Mac Beta Beta

    If the content of the Notes field is more than what can be shown in its current width, you don' have to widen the column to see it all. Open the transation for edit, put your cursor in the Notes field, then use the keyboard right-arrow key to move the cursor to the right. As it moves past the right end of the field, those characters which were off the end will be shown.

    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • Hi RickO

    Thanks. Yeah. I've done that and also Command and the right arrow to go to the end.
  • Hi UKR

    For my Quicken for Mac, I did get a drop down menu, with a control/click, while in the Momo/Notes column, but no choices for right to left were offered. Nice try though. Thanks
This discussion has been closed.