Quicken crashing on Windows 11

Chillbill
Chillbill Member ✭✭
I have a new Windows 11 computer and every time I try to open Quicken, it immediately crashes with the "Quicken unexpectedly quit the last time it was run" error. I called support. This is a known problem, and the only workaround is to hold down the shift-control keys when opening Quicken, and then selecting the data file to open. Using this process does allow me to open my file and work on it, but other things do not work like validation. I can open the exact same file on a Windows 10 PC with no errors and the file checks out clean from validation and super validation on the Windows 10 PC. I also cannot create a new file on the Windows 11 PC, so this is not a file issue. It's a program issue and incompatibility with Windows 11. According to support, there is no ETA for when this will be fixed.

Comments

  • UKR
    UKR SuperUser ✭✭✭✭✭
    • Where is your Quicken data file located on the Windows 11 computer?
      Usually it should be on your C: - drive in C:\Users\username\Documents\Quicken\
      Your Quicken data file must NOT be processed by MS OneDrive at all.
      On some recent systems, MS OneDrive is active in the background even if you're not using it, or if you're using another backup software process. Check and reconfigure MS OneDrive to exclude your Quicken data file from being processed.
      Optionally, to create backups of your Quicken data file configure the Backup options in Quicken. Send the Manual Backup file to a folder which is processed by OneDrive and sent offsite to a OneDrive server.
    • To make sure that Quicken is allowed to update and save its configuration files please check if Windows Defender Controlled Folder Access feature Ransomware protection is enabled.
      If it is, configure it to add Quicken as an "allowed app" without turning off Ransomware protection. Perform the last step in

  • Chillbill
    Chillbill Member ✭✭
    I went through this with Quicken Support. My Quicken file is stored in the location you list above and it is not synced to OneDrive. Controlled Folder Access is not enabled. As I mentioned, Support said this is a known issue and is on the list of bugs to fix soon.
  • UKR
    UKR SuperUser ✭✭✭✭✭

    Please verify this:

    In Windows Control Panel / System / Advanced System Settings / Environment Variables ensure that both the TEMP and TMP variables point to a valid and existing folder, typically C:\Windows\Temp or C:\Users\your_username_here\AppData\Local\Temp
    If they point to an incorrect or non-existent folder or drive change both variables to an existing folder on C:\ (or create one) e.g., C:\Temp, and reboot Windows.

    If the Temp folder is located on a too-small SSD C: - drive and you have an internal standard hard disk, too, move the Temp folder to the internal hard disk and change the TEMP and TMP variables
    If the folder exists … does your Windows User Account have proper access rights to this folder?
    If Quicken cannot create and use temporary files, all sorts of malfunctions will occur.
    If the Temp folder is full of junk, clean it out. Delete all files and subfolders within the Temp folder structure that Windows allows you to delete. You may have to skip a few that are actively in use.

    Make sure that files in the Temp folder are NOT accessed by cloud backup software at all.

    Run CHKDSK C: /r on your C: - drive (or perform Error Checking from Windows File Explorer, Properties, Tools tab).

  • Chillbill
    Chillbill Member ✭✭
    edited April 18
    We went through all of this. It all checks out with no issues. Support has the Quicken log files from my PC. Hopefully, they will get to the bottom of it. All I can say is what they told me — that this is a known issue that is not only affecting me. They escalated it to senior techs and came back and told me it is a known bug that they need to fix. That’s where they left things with me.
  • Chillbill
    Chillbill Member ✭✭
    edited April 20
    I just called back again this morning and talked to someone else in Support. We went through all the same things as before. The conclusion is that something deep in my user settings was blocking Quicken from connected to my online account. We could not figure out what exactly was blocking access. We tried disabling anti-virus and disabling the firewall. The only thing left to try was to delete my user account and start fresh. This worked! So, while it was a hassle, I did not lose any data. I just needed to delete my Windows user account and start over. Perhaps this will help others who may be experiencing a similar issue. It was not a Quicken data file issue. It was something in my Windows user configuration that was blocking the Quicken app from connecting to my online Quicken account. I am very relieved that it is working again.
This discussion has been closed.