Now have to click "update now" twice when launching?

Drinkingbird Member ✭✭✭✭

Ever since the previous update a couple weeks ago (the small one, not the big one that just came today for many) - when launching Quicken, I put in my vault password and click "update now". That brings up a screen showing all the accounts to update and have to click "update now" again to actually kick off the update.

Previously just clicking "update now" after putting in my vault password went direct to the update.

Obviously I have it set to update when starting Quicken.

Is this an intentional change?


  • MHSwizzleStick
    MHSwizzleStick Member ✭✭✭✭

    This happened to me last year. I was only able to fix it by restoring backup data files one at a time till I found one that didn't have the problem.

  • Drinkingbird
    Drinkingbird Member ✭✭✭✭

    Yeah no way I can do that after a couple weeks and a lot of transactions. I guess I could try disabling all online services, doing a repair, etc but it probably isn't worth the effort for one extra click. It seemed to start with a recent update but could have been coincidence, that update finished breaking something that was already broken on my file.

    Have already tried deleting and rebuilding my password vault etc. I guess if nobody else is having the issue after any recent updates it is probably just something messed up in my file.

  • MHSwizzleStick
    MHSwizzleStick Member ✭✭✭✭
    edited May 3

    You might try each of the more recent backups that are automatically saved in the folder:


  • Drinkingbird
    Drinkingbird Member ✭✭✭✭

    I store my backups on a NAS, not in the default local folder, but its been a couple weeks and a lot of stuff done since then, so rolling back isn't an option. If it doesn't resolve itself at some point I'll try deactivating all online accounts, validating, signing out of quicken ID, then resetting them up but that's a lot of work to eliminate an extra click. Ideally if we've both had this issue, would be good if Quicken team can find whatever bug causes it and fix it, but not holding my breath.

  • Drinkingbird
    Drinkingbird Member ✭✭✭✭

    Well I tried deactivating all accounts, deleting password vault, disabling update on startup. Signed out of quicken ID, re-launch, sign in, validate, re-set up all online services, re-enable update at launch, validate again. Problem is still there. There were actually many more steps than that, relaunched quicken many times in between every step and even tried a file copy etc. Some sort of glitch. Maybe it will get fixed, or maybe my last 2 FIs will convert to EWC+ (Fidelity probably soon I'd think, Empower/Prudential 401K less likely) then I can just ditch password vault and it will only prompt me once. Just gotta live with the extra click for now.

  • UKR
    UKR SuperUser ✭✭✭✭✭

    Just guessing … it appears to me that Quicken "thinks" that one of the items shown in the One Step Update Settings view requires an action before OSU can proceed.
    Is there an unchecked item or a bank password that needs entering?
    Have you clicked the Apply button before clicking Update Now, to see if that eliminates the issue?

  • Drinkingbird
    Drinkingbird Member ✭✭✭✭

    Nothing is unchecked, no missing passwords. Have applied many times. Even tested after I deactivated all my accounts so the only thing there was "update quotes" and it still brought up the window. Then after re-activating all my accounts, I unchecked all but one EWC account (which doesn't use the password vault) and it still happened. Doesn't seem to be anything to do on that screen to fix it. As of now everything is checked off, all passwords filled in (only 2, all the rest are EWC or EWC+) and it comes up.

    I tried on another computer with same data file and same thing so not an issue with my install. I did confirm (on that other PC) that if I reverted back to a backup from 2 weeks ago, the problem is gone. Unfortunately I can't go back that far, have done a lot of stuff since then.

    It must be related to the fact that when trying to close a HELOC out of quicken (which was originally put into MS money and converted 15 or so years ago) it was tied to my house asset and wanted to close that too. So I had to create new accounts, copy transactions over, and delete the old accounts, to resolve that issue. Then I did a super validate which did find some errors. So something in that process broke something else (possibly the validate).

    Have tried creating a copy of the file, validating, super validating, deactivating and reactivating all accounts (signing out of quicken ID and back in between those steps), lots of other stuff. Guess I just have to live with it until they either fix it or someone figures out some fix somewhere. Or once my last 2 FIs move to EWC+ then I can delete my password vault and will just have to click once (though at that point I should not have to click at all).

    To note though - in the past when I've deactivated and reactivated an account and it is unchecked, it would not bring up this screen at startup, it simply would not update that account during the startup OSU. So that isn't a reason for it to pop up that screen.

  • Bob_L
    Bob_L SuperUser ✭✭✭✭✭

    I know this doesn't help you, but FWIW, I had that same issue way back when, and it magically corrected itself after just living with it for months! If you usually update via the automatic updates, you could try applying a manual patch as a long shot.

    Quicken Premier Subscription, Windows 11 Home
  • markus1957
    markus1957 SuperUser, Windows Beta Beta

    This is a recurring problem

    It does seem to be data file related rather than the install so in theory if you could get someone in upper-level support interested, a sanitized data file submitted in Report a Problem might be used to uncover the problem.

    This is normal behavior (OSU Settings Window pop-up) except for the first OSU session after Quicken is opened so it seems like the flag used to determine first use is not getting reset after closing Quicken.

    I'll offer one other long-shot option. In Tools>Online Center, hover the mouse over the "C" in Contact Info, hold Ctrl+F3 keys and click. An FI Action Required window will pop up. Check the list and make sure only FIs that are currently set up for download are in the list. Delete any old FIs that are not active.

    If you use Mobil/Web or even if not, have you tried toggling that On/Off and running OSU in between? If you don't use it, try turning it On but deactivating all accounts from syncing, then run OSU with cloud account active in OSU settings. Try Reset Cloud account. Long shot

  • Drinkingbird
    Drinkingbird Member ✭✭✭✭

    Nah, helps to know that it isn't just me and it may resolve itself. I tried on two different computers/installs and it is the data file (I tested restoring a data file from a few weeks ago and it doesn't have the issue). Not worth rolling back and re-entering everything, maybe it will fix itself at some point.

  • Drinkingbird
    Drinkingbird Member ✭✭✭✭
    edited May 5

    Yeah tried on a couple installs and it is the data file. I've also noticed sometimes after a quicken patch/update it will say last backup "never" even though I've backed up several times, then it will finally start showing a date, so yeah what you say about not flagging that I closed the file might be on to something.

    I've played with the online center, nothing extra showing up on that screen, and on the shift-ctrl screen did try refreshing branding/profile and downloading fi list etc. I don't use mobile but I did do a complete reset of online data already as part of troubleshooting this, and made sure there were no extra data files etc. I just enabled synch with no accounts selected, it was unchecked when I clicked update which was promising. Checked it and did an update, then closed and reopened, unfortunately same thing.

    In the FI Action screen I just hit refresh on all of them, so they all went to branding/profile needs updating (some said branding up to date but profile needs updating before that). After an OSU my two direct connect now show up to date on both, which they did before. Looks like I have to wait for EWC and EWC+ to do one of the full 2 minute downloads before those will refresh, even after going to the account and doing "update transactions" they say need updating.

    Most likely I'll stumble on the solution by accident at some point, and not even know what it was.

This discussion has been closed.