R51.12 asks me to check my Internet connection and try again - but it is just fine -

Options
Ducksoup_SD
Ducksoup_SD Member ✭✭✭

Quicken forced me to update to R51.12 and now it just asks me to check my internet connection. Clicking on the Retry button in the dialog box does nothing. I can run Ookla Speedtest while Quicken is running and my connection is +600 Mbps, so the internet is fine. I deleted the McAfee firewall entries so it would rebuild them and they look the same as before - I've used Quicken for over 20 years. I've uninstalled Quicken, deleted the Quicken program folder, and reinstalled, shut down, and rebooted - no difference.

Any suggestions?

Windows 10 Home, 64-bit V. 22H2; 32 GB RAM; 1 TB+ free disk space; AMD Ryzen 7 3700x processor

Tagged:

Comments

  • UKR
    UKR SuperUser ✭✭✭✭✭
    Options

    If you are getting "Oops, something went wrong" or "Check Internet Connection" …
    • To make sure that Quicken is allowed to update and save its configuration files please check if Windows Defender Controlled Folder Access feature Ransomware protection is enabled.
    If it is, configure it to add Quicken as an "allowed app" without turning off Ransomware protection. Perform the last step in


    • Have you recently enabled a VPN?
    If so, this might be the problem. Try turning the VPN off, reboot with VPN disabled and see if that helps.
    • Is there a corporate or otherwise external firewall getting in the way? Contact the IT people maintaining the firewall and ask for permission.
    • Does your Antivirus software allow Quicken to connect to the Internet?
    Quicken needs to be able to establish outbound Internet connections for the program to work.
    For example, in McAfee Firewall, one user states "By editing the Quicken Firewall entry Selecting Incoming and Outgoing, and changing it from "Default" to "Open to all devices" it now works without having to turn off the entire firewall!"
    If necessary, contact the Antivirus / Firewall vendor's Support Center.
    • In Windows 11 or older Windows systems go to Windows Control Panel and select Internet Options (or in Internet Explorer, click on Tools / Internet options.)
    Click the Advanced tab.
    Scroll down the list to "Use TLS 1.x" and click to put checkmarks on all available choices even though some of them are no longer supported "Use TLS 1.0, 1.1, 1.2 and 1.3 (if available)"
    Turn off "Use SSL 3.0"
    Click Apply. Reboot.
    • If all else fails: Try rebooting your network router. When done reboot your PC
    • Please let us know which of the above solved your problem.

  • Ps56k2
    Ps56k2 Alumni ✭✭✭✭
    edited August 2023
    Options

    what is your actual physical Internet connection from the computer - WiFi or Ethernet or ?

    What networking icons do you see on the Windows bottom right corner ?

    Quicken sometimes sees ALL the Windows Network Adapters -
    and might see a Ethernet adapter as "not connected" vs it not being properly "disabled" ….
    and Quicken gets confused -

  • QWinUser
    QWinUser Member ✭✭✭✭
    Options

    @Ducksoup_SD - This also can happen if your data file is located on a network or an external hard drive.

  • Ducksoup_SD
    Ducksoup_SD Member ✭✭✭
    Options

    QWinUser: Thanks, but data is on a local hard drive (magnetic, not SSD).

  • Ducksoup_SD
    Ducksoup_SD Member ✭✭✭
    Options

    Ps56k2: Thanks - hardwired 1 Gbps Ethernet. WiFi was turned on, but not connected (or used). I turned it completely off - no change. Networking icon is the screen with mouse - wired networking.

  • Ducksoup_SD
    Ducksoup_SD Member ✭✭✭
    Options

    UKR: Thanks — 1) No Windows Ransomware option available, so not turned on. 2) Never had a VPN. 3) No external firewalls - home system. 4) Changed McAfee (Cox derivative) settings for Quicken (3 related programs shown in McAfee) to "Open to all devices." 5) Windows 10 Internet option settings were already set as described, except for TLS 1.3 (experimental) - still not checked. 6) Router then computer rebooted (router soft reboot, computer power off reboot).

    No change!

  • Ducksoup_SD
    Ducksoup_SD Member ✭✭✭
    Options

    Tried creating a new Quicken file to see if it would work (maybe a corruption of my old one?). Same problem - file appears to open, then is covered up by the Check Internet Connection full page. Clicking on the Retry button just makes it blink.

  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    Options

    With respect to TLS settings, in my Win 11 setup only TLS 1.2 & 1.3 are checked. Also make sure Quickenpatch.exe is not blocked in the firewall. It runs when QW.exe launches.

    You could open Windows Resource Monitor network connections before starting Quicken and then watch to see if QW related connections are opened. Quicken connects to both IPv4 and IPv6 servers so verify they are both set up and have valid DNS addresses.

  • Ducksoup_SD
    Ducksoup_SD Member ✭✭✭
    Options

    marcus1957: Thanks - All Quicken related programs are not blocked; all are "Open to all devices" in McAfee, as recommended by UKR. >Requiring< the use of TLS 1.3 by an existing commercial product like Quicken, when Windows 10 lists it in its Internet Options as "TLS 1.3 (experimental)" seems very risky, at best. RE: Win Resource Mon — qw.exe and quickenpatch.exe have multiple connections (IPv4 - never saw an IPv6 connection) and download some data. After a few seconds, there is no more activity and the connections are closed. If I click on the Retry button (multiple times), no connections return and nothing happens in Quicken. It looks like once it decides things aren't right, it won't even bother to try again.

  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    Options

    FWIW, TLS 1.3 has been implemented since 2018. That Win 10 still shows it as experimental says more about Win 10 than TLS 1.3. No experimental tag is associated with TLS 1.3 in Win 11.

  • UKR
    UKR SuperUser ✭✭✭✭✭
    Options

    If anybody's having these Internet connection issues and "only TLS 1.2 & 1.3 are checked", try adding TLS 1.0 and 1.1 to the mix, reboot and see if that resolves the issue.
    There might be an ancient piece of IP code written for TLS 1.0 or 1.1 only that's causing this issue … I'm, of course, just firing shots in the dark here and hoping to hear an "ouch".

  • Ps56k2
    Ps56k2 Alumni ✭✭✭✭
    Options

    here's what I show for Win10 - Quicken R47.15 -

  • Ducksoup_SD
    Ducksoup_SD Member ✭✭✭
    Options

    Ps56k2: RE: Quicken R47.15 - I had no problems with Quicken permanently locking me out of my files until R51.12.

  • Ducksoup_SD
    Ducksoup_SD Member ✭✭✭
    Options

    I finally discovered what the problem was! Quicken DOES NOT SPECIFY in any of their System Requirements documentation for Windows that it REQUIRES Microsoft Edge WebView 2 to be installed and up to date to operate. I am not interested in having Edge or any other MS browser, because of their poor security in the past, so I've blocked them, and their update programs, from connecting to the internet. While searching for answers, I stumbled on to a discussion that involved Quicken and WebView 2 and that's why I tried updating it.

    Clearly, it wasn't my INTERNET connection that was bad - a program, that isn't written or maintained by Quicken, which I don't even want on my system, is actually REQUIRED NOW by Quicken for internet connectivity. They've decided they don't have to disclose it to their customers or even check its operation when the internet connection isn't working. 👎️👎️👎️👎️👎️

  • QWinUser
    QWinUser Member ✭✭✭✭
    Options

    @Ducksoup_SD - an amazing find. Until now, all users who had a problem with WebView2 had an error message. Glad you found the solution.

This discussion has been closed.