Why does Quicken access the internet when I perform a local backup?

Options
raustin316
raustin316 Member ✭✭✭

If I am disconnected from the internet, the local backup occurs very quickly within a second or two. If I am connected to the internet, the backup can take up to 15 seconds. To my knowledge I am not set up to store a copy of my data file on the internet. Why does quicken behave this way?

Tagged:

Answers

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Options

    Click on File and look at the top entry in the file list at the bottom of the menu for the path to your data file. Then click on Copy or Backup file and Create a complete backup to see the backup path.

    If either of the paths you see includes "OneDrive" then the corresponding file location is being managed by OneDrive, which would explain the delay.

    QWin Premier subscription
  • retird
    retird Member ✭✭✭✭
    edited April 24
    Options

    Only if OneDrive has been enabled…. my file and backup path has OnerDrive in the path but has never been enabled. I have no issue nor delay as it doesn't access the cloud…

    How do I enable OneDrive?How do I enable OneDrive backup?

    1. Select OneDrive blue cloud icon in the Windows notification area.
    2. Select the Gear icon for Help and Settings.
    3. Select the Manage Backup button.
    4. Toggle all folders that should be backed up as depicted below and click Save changes.
    5. Close the Help and Settings window.

    Windows 11 (2 separate computers)..... Quicken Premier.. HAVE USED QUICKEN CONTINUOUSLY SINCE 1985.

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited April 24
    Options

    Thanks for the details, @retird

    My point is that Windows 11 encourages users to enable OneDrive and by default backs up the entire Documents folder, including the Quicken folder, which is the default location for Quicken data files.

    If your data file is in a folder controlled by OneDrive and synching is active, you may experience delays like what the OP @raustin316 reports, or crashes or other trouble. One way to work around this if you want to keep the file in a OneDrive-controlled folder is to pause OneDrive before starting Quicken.

    QWin Premier subscription
  • raustin316
    raustin316 Member ✭✭✭
    Options

    The file is not being saved to OneDrive in any of the locations mentioned. I deleted the OneDrive app a while back.

  • raustin316
    raustin316 Member ✭✭✭
    Options

    Update - Even though I removed OneDrive on my computer, my folders were updating in onedrive.com. No data files, but the Documents folder was being tagged on the website with a date/time stamp. I don't recall ever setting up OneDrive. Does Microsoft do this by default when you create a Microsoft account?

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Options

    Windows 11 is very aggressive about setting up OneDrive. When you set up a new computer or upgrade to Win 11, it asks if you want to back up your computer. Answering Yes to this gives OneDrive control of your entire Documents folder, including the Quicken folder and the BACKUP folder in it, where automatic backups are stored.

    If OneDrive is running on your system, you will see a little gray cloud-shaped icon in your System Tray (the area at the bottom right of your screen) and a pop-up box will say OneDrive when you hover your mouse over it. If you don't see the cloud icon in the System Tray, click on the little up arrow at the left end of the System tray and look for it there.

    To disable OneDrive, right click on the cloud icon and select Pause syncing. Choose a time longer than you will be using Quicken. If you pick Quit OneDrive, synching will be disabled until you restart Windows. To disable OneDrive more permanently, click on the cloud icon, click the gear at the top right, select Settings, then click on Unlink this PC. This logs you out of OneDrive until you sign back in again. Windows will periodically nag you to log back in.

    QWin Premier subscription
  • QuickUserPSP
    QuickUserPSP Member, Windows Beta Beta
    edited April 25
    Options

    Another additional step you can take in addition to the ones @Jim_Harman describes is to uninstall One Drive after you unlink your PC. You will no longer be reminded to sign back in, but there is still a "gentle" reminder to install OneDrive (Windows 11).

  • raustin316
    raustin316 Member ✭✭✭
    Options

    Update - Thanks everyone for your comments, I am on Windows 10 and uninstalled OneDrive a while back (years). 2 days ago when Jim and retird mentioned OneDrive, I went in to onedrive.com and deleted the folders that were there (documents and pictures) and verified the vault was empty. Today, I backed up Quicken and checked onedrive.com again and there were no indications of activity on my account. But there is still a pause when I back up the Quicken file while connected to the internet so I am at a loss as to what is causing it now. It may be a leftover procedure from when I deleted OneDrive possibly without stopping the sync task first.

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Options

    Another possible reason for a delay is that Quicken is syncing your data so that it can be accessed by the mobile and web apps. If you do not use these, you should go to Edit > Preferences > Mobile & Web and move the Sync slider to the left (off) position.

    QWin Premier subscription
  • raustin316
    raustin316 Member ✭✭✭
    Options

    Jim - checked the setting for mobile & web sync and it is not enabled.

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited April 28
    Options

    Even if you have disabled data syncing, it appears that if you have an internet connection, Quicken contacts its servers each time you open and close the program. This could account for the delay you are seeing. You can see this by going to Help > Contact Support > Log files.

    If you exit and restart Quicken, you will see that at the end of the Cloud sync file there are entries with timestamps corresponding to the time you closed Quicken and the time you re-opened it.

    [adding] I have been assuming that we are talking about a manual backup, not the automatic one that can be done on exiting Quicken, and that you have set the manual backup to occur when you exit. To further diagnose this question, is there a delay if you perform the manual backup from the File > Copy or Backup menu without exiting Quicken? Is there a delay if you disable the manual backup on exit?

    QWin Premier subscription
  • Cyclone67
    Cyclone67 Member
    Options

    OK, read through all of the comments on OneDrive and backups and I am still confused.

    I am looking for a simple solution to stop having my Backups going to OneDrive and the internet. I have a large file at 268MB and when the Backup goes to OneDrive it takes forever. I also do a manual Backup to a thumb drive which goes quickly.

    Just looking for an easy method of having an automatic primary backup to my local disk when I shut down Quicken. I will still continue to use the thumb drive extra protection. This is the way I previously had, but then OneDrive took over and not sure what I did by mistake to initiate the change.

    Any help is very much appreciated.

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Options

    To change the location where automatic backups are stored, got the Edit > Preferences > Backup and next to Automatic local backups, click on Change.

    QWin Premier subscription
  • Cyclone67
    Cyclone67 Member
    Options

    Jim,

    Thanks for your response. I have now been able to create the local on computer file Backup. Unfortunately the OneDrive backup is still occurring and takes forever to complete. Did I miss another step to have the OneDrive not do a Backup?

    Before I started Quicken I discontinued OneDrive usage by shutting OneDrive down. Then did my work on Quicken and created a local Backup successfully. Shutdown Quicken. Then restarted OneDrive and there was a file syncing with the same info I did with the local Backup. Did I miss a step?

    Thanks and look forward to your thoughts.

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited May 6
    Options

    That sounds like your data file (QDF file) is in a folder controlled by OneDrive. In Quicken, click on File and look at the file list at the bottom of the menu. If OneDrive is in the path, then it will sync your data file as soon as you restart it.

    To prevent this, you must move the data file to a folder that is not under the Documents folder and not synched by OneDrive. For example, you could use Windows Explorer to create a Quicken folder under Downloads and move your QDF file there.

    QWin Premier subscription
This discussion has been closed.