I sold all shares of a stock and it still shows on my Portfolio Value as $0 balance?

Options
Cobra53
Cobra53 Member ✭✭

Good evening all. I bought a stock 10 years ago, and throughout the years, there were some reinvested dividends. June of 2024, the company was taken private and my broker cashed me out of all shares. This has happened with other securities and after I reported all shares sold, said securities no longer shows on my portfolio report.

When I recorded the sale of this particular stock in Quicken, I did mark the box to sell all shares. As expected, it no longer shows up in my portfolio dashboard, but when I run a Portfolio Value report, there it is with no shares, a $0.01 cost basis, a -$0.01 loss, and a balance of $0.

Although it no longer is being counted in any value, its the technical side of me that no longer wants to see this stock in my report. I have read some threads and I did mark the "sell all shares" box. Any ideas would be welcome.

Answers

  • Frankx
    Frankx SuperUser ✭✭✭✭✭
    Options

    Hi @Cobra53

    Apparently, there was a one cent error made as part of the transaction that was entered when you "recorded the sale". Please keep in mind that when you click the box "to sell all shares" that only affects the shares not the "dollars and cents" of the transaction. To fix it, you just need to edit the "sell transaction" by one cent. That should fix the problem.

    Frankx

                            Quicken Home, Business & Rental Property - Windows 10-Home Version

                                             - - - - Quicken User since 1984 - - - 
      -  If you find this reply helpful, please click "Helpful" (below), so others will know! Thank you.  -

  • QuickUserPSP
    QuickUserPSP Member, Windows Beta Beta
    Options

    @Cobra53 these penny residual cost amounts happen from time to time, even if all transactions were entered correctly. I have several in my investment portfolio. I haven't figured out why they happen, but I am chalking it up to a "rounding" issue.

    I have found an easy fix using the "Add" transaction with zero shares.

    In the "Number of shares" enter zero. The "Total Cost" is the cost adjustment that can be a positive or negative number depending on the adjustment required. The "Date acquired" should be the date of the last sale to close out the security.

  • NotACPA
    NotACPA SuperUser ✭✭✭✭✭
    Options

    @Cobra53 @QuickUserPSP One reason why these penny differences occur is due to rounding, or not.

    Quicken rounds using standard 4/5 rounding logic while Fidelity Investments, and perhaps others, truncate the fractional pennies.

    Q user since February, 1990. DOS Version 4
    Now running Quicken Windows Subscription, Business & Personal
    Retired "Certified Information Systems Auditor" & Bank Audit VP

  • QuickUserPSP
    QuickUserPSP Member, Windows Beta Beta
    edited June 6
    Options

    @NotACPA that makes sense. Usually, the penny differences are not a problem, but if the residual cost balance is greater than +/- 0.01, the closed security shows up on portfolio reports and the only way to suppress them is to exclude them from the report which is sometimes a pain. So I routinely check closed securities for residual cost balances and adjust them to zero.

  • Cobra53
    Cobra53 Member ✭✭
    Options

    @QuickUserPSP So I added 0 shares and put a -$0.01 cost basis, and that zeroed out the -$0.01 but now the security shows up a all zero's. To be more clear, that security only shows up on the portfolio value report - it does not show up on my Investing screen or dashboard. I have sold many investments before and usually it was a rounding issue with 0.001 shares and I either re-entered the sale and clicked the "sell all shares" or entered a sale of 0.001 shares to remove it from the report but why it now shows up as all zeroes, I can't explain it. I'll try the other suggestion and hope that removes it from the report.

    So on the "Portfolio Value" report, it shows up like this. This is adding 0 shares but a cost of -$0.01

  • NotACPA
    NotACPA SuperUser ✭✭✭✭✭
    Options

    It's NOT "all zeroes". That negative zero for shares indicated that there's a fractional share in the 4th, or smaller, decimal. Go to your LAST sale of this security and mark it as "Sell All" with the correct amount (that you actually received).

    Then, if you have "Show closed lots" in the Portfolio not checked (via the Options link in the Portfolio) the position should go away.

    And Delete that 0 shs for -0.01 that you added. It isn't helping.

    Q user since February, 1990. DOS Version 4
    Now running Quicken Windows Subscription, Business & Personal
    Retired "Certified Information Systems Auditor" & Bank Audit VP

  • Cobra53
    Cobra53 Member ✭✭
    Options

    @NotACPA This security was only sold once which was the final transaction. I input the exact amount that I received and after removing the -$0.01 transaction previously suggested, I am still at -$0.01 cost. I agree that the red shares, even if it displace 0, is probably because of a truncation issue so it could be an amount of 0.0001 or something like that. I don't know why checking "sell all shares" would not fix that unless, as mentioned, it only sells up to 2 or 3 decimal places and this is out to the 4 or 5 place.

    Where do I find the "show closed lots" you mentioned? Thanks again for your help

  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Options

    Regarding the reinvested dividends, did you enter those as x.xxx dividends valued at $y.yy letting Quicken calculate a price per share? That is the recommended process. Entering the total price and price per share can lead to such rounding issues and create a final share count issue.

    Under tools/preferences, there is an option for reports to show more decimal precision. Going to the max of 6 (?) might help clear up what you need to do.

  • Cobra53
    Cobra53 Member ✭✭
    Options

    @q_lurker For reinvested dividends, I would input the number of shares and as you said, instead of entering the price per share, I would jump down to the total amount of the dividend so that Quicken calcualtes the price per share. In hindsight, maybe I should have entered, at most, a 3 digit cents to avoid it calculating even small shares that are now probably causing this issue.

    That is what could be calculating the tiniest of shares. Even when I sold the shares, the price per share was $62.99988. I did update it to $63.00 thinking that might fix the report but it didn't. I would hate to go through 18 years of dividends to fix each fractional price.

    I did not find the tools/preference where you said it could show a more precise decimal. Can you please be more specific where I might find that?

  • NotACPA
    NotACPA SuperUser ✭✭✭✭✭
    Options

    EDIT, Preferences, Investments and

    Investing, Portfolio, click OPTIONS in the upper right corner.

    And, SELL ALL, for the correct amount is the proper course. Changing to $63 was your error. The IRS only cares about total received … not the Per Share.

    Q user since February, 1990. DOS Version 4
    Now running Quicken Windows Subscription, Business & Personal
    Retired "Certified Information Systems Auditor" & Bank Audit VP

  • Cobra53
    Cobra53 Member ✭✭
    Options

    @NotACPA Just an update but unfortunately nothing changed. I found the sections you referred me to (thank you for the detail instructions). I deleted the sale of MDC and reentered it and it still shows the same issue. When I clicked on show closed positions, it shows the other investments that I sold using the method I always used, and did find anther security that had a $0.01 balance - same as the MDC position. So I must have hidden that because that security no longer shows on the report.

    I won't spend more time on it and very much appreciate all the input from you all. I think the only way to "remove" it is to know exactly how many shares were in Quicken. I guess extending the decimal in shares doesn't go backwards meaning it only affects transactions after you make that change. It would be nice, if like in Excel, you can extend out. By the way, I did export the transactions in Excel but it must truncate like Quicken did. Its not worth it to me to recalculate in Excel where I could get many more decimal places just to find out what the exact number of shares were sold that round up to what Quicken showed. Thanks again.

  • NotACPA
    NotACPA SuperUser ✭✭✭✭✭
    Options

    You can correct that remaining $0.01 by changing it to a Sell All with the correct amount and letting Q adjust the Per Share.

    Q user since February, 1990. DOS Version 4
    Now running Quicken Windows Subscription, Business & Personal
    Retired "Certified Information Systems Auditor" & Bank Audit VP

  • Cobra53
    Cobra53 Member ✭✭
    Options

    @NotACPA I showed a screenshot where I clicked on the Sell All and put the amount that I received. That is where Quicken calculated the share price at 62.99986. I even went back and changed the share price to $63.00 thinking that would correct the issue and it didn't. In both cases, it shows the same -$0.01.

    As you said, I don't think its the dollar amount, its the fact that I have a red share balance of 0.000. It must have to do with the shares over the hundredths of decimal point that shows the shares in red.

    Even though I said I had no more time, I did work on that Excel file that exported and got close to the 118+ shares sold. The share balance definitely go out past 3 decimal point but its not worth it to me to spend another 2 hours just so that security does not show up anymore on my report. Maybe one day when I am retired, I'll tackle that. Thanks again

  • NotACPA
    NotACPA SuperUser ✭✭✭✭✭
    Options

    NO, Sell All sells even non-displayable fractions.

    At this point, you've mucked around with it so much, that I'd delete the transaction and re-input. If you take a backup before that, you can always Restore.

    Q user since February, 1990. DOS Version 4
    Now running Quicken Windows Subscription, Business & Personal
    Retired "Certified Information Systems Auditor" & Bank Audit VP

  • QuickUserPSP
    QuickUserPSP Member, Windows Beta Beta
    edited June 6
    Options

    I know you been through a lot with this but if you could try one last thing, it might work. Sorry, I didn't see your comment to me until now.

    Go to Edit→Preferences→Investments - and then checkmark the "Extend share precision to 8 digits", and then click "OK".

    Then, do the Sell again with the "Sell all shares" checked. You might need to delete the "old" sell transaction and add a new one, in order for it to work. Sometimes just re-editing a sell transaction won't change it.

  • Cobra53
    Cobra53 Member ✭✭
    Options

    Maybe I am missing something but I did click the box that says "Sell all shares in this account" - that is what you are saying, correct? I would think that it sells ALL shares including the non-displayable fractions. I'm going to try it one more time but I delete the transaction and enter the security, date, click on sell all and enter the amount I received. I don't enter the number of shares manually and let Quicken calculate the share price.

    By the way, when I click "Enter/Done", the sell all shares checkmark disappears. So maybe you think I am not marking that box, but I am and then it goes away.

    Here is what I am entering and after I calculate, the result is: no change

  • QuickUserPSP
    QuickUserPSP Member, Windows Beta Beta
    Options

    @Cobra53 please take a look at my comment to you I just posted. I think you need to change the share percision to 8, and then delete the old sell transaction and add a new one with "sell all shares" checked.

  • Cobra53
    Cobra53 Member ✭✭
    Options

    Are you referring to this? If so, I did make sure that was on, deleted the sale and then re-recorded it. The updated sale had the "sell all shares" checked, but when I go to review it again, the sell all is not checked. i don't know if that is because there are un-displayed shares that it doesn't sell because it is truncated…

  • Cobra53
    Cobra53 Member ✭✭
    Options

    I just saw your post and think we are talking about the same thing. I made sure to extend, and then I deleted the old sale and re-entered the new sale and no difference

    I always check the sell all box when I am exiting from a position and assume it sells every last share, but again, this security has 18 years of dividends and what I found out are some fractional stock splits that I am sure, the actual number of shares go out 6 decimals or more so I am guessing the share balance is red because it "oversold" because of the rounding. You guys are awesome for trying to help me with this. I appreciate it more than you can imagine.

  • QuickUserPSP
    QuickUserPSP Member, Windows Beta Beta
    Options

    @Cobra53 there is a way to confirm if MDC has residual shares. Go to Edit→Preferences→Reports only, and change the "Decimal places…" to 8, and then click "OK".

    Then run the Portfolio Value report. You should see all Share balances with 8 decimal places. Check MDC to see if the residual shares are visible.

  • QuickUserPSP
    QuickUserPSP Member, Windows Beta Beta
    Options

    @Cobra53 if the report still shows no residual shares, then the only other thing I can recommend is to run a data file validate, if you haven't done so already.

    Validate:

    1. Go to File in Menu Bar
    2. Click Validate and Repair File...
    3. ChecK Validate File
    4. Click OK
    5. Close the Data Log

    Super Validate:

    1. Go to File in Menu Bar
    2. Hold CTRL + Shift and click Validate and Repair File...
    3. Check Super Validate File
    4. Click OK
    5. Close the Data Log

    After the validates are done, rerun the Portfolio Value report to see if the share amount for MDC has changed to zero.

  • Cobra53
    Cobra53 Member ✭✭
    Options

    WOW is all I can say. I changed the decimal to 8 and found it to the 6th decimal - so I guess it did not sell the 2-millionth of a share. So after manually changing the shares to account for 0.000002, it no longer shows up on the report. THANK YOU and the Quicken community VERY MUCH!!!

  • QuickUserPSP
    QuickUserPSP Member, Windows Beta Beta
    Options

    Phew! Glad we were able to help you find a solution. Sometimes it just takes a little investigating and persistence.

  • Cobra53
    Cobra53 Member ✭✭
    Options

    Well I appreciate your help. If you need any retirement planning help, let me know

  • QuickUserPSP
    QuickUserPSP Member, Windows Beta Beta
    edited June 6
    Options

    LOL ok thank you, but I have been retired for 10 years already since I was 55. I also worked in the retirement industry in one form or another for 30 years (US Bank (formerly First Trust) and Wells Fargo (Formerly Norwest)).

  • Cobra53
    Cobra53 Member ✭✭
    Options

    I have been licensed since 2001 and the money business has changed alot, even in the past 5 years. Products now have down side protection against losses. Anyway, if you want to chat, let me know and we'll find a way to connect. But thanks for the help, its so small but it helps.