Itemized Payees Report "Select Payee" filter not working

Options
jhg
jhg Member ✭✭
edited June 8 in Reports (Windows)

I ran an itemized payees report filtering on a single specific payee, which produced the desired result.

Then I attempted to print via the Adobe PDF printer, and Quicken became unresponsive. I left it alone for about 10 minutes but it never returned. Eventually I terminated the Quicken process and restarted.

Now, specifying the same single payee filter no longer works. The report includes several other payees unrelated to the one I specify in the filter. If I return to the customization menu I see many other payees checked. If I then click "Clear All" and re-select the single payee I want, the report still includes other payees, totally unrelated.

I have run the "File/Validate and Repair" function and it detects no problems.

I have closed and restarted Quicken several times, and also rebooted the system.

Windows 11 Build 22631; Ryzen 9 7940HS; 32GB RAM, 8TB disk
Quicken R56.9 Build 27.1.56.9

How do I restore the report filter functionality?

Additional Info: I restored the QDF file from last night's backup, and it now exhibits the same incorrect behavior. Also, if I use the Itemized Categories report and filter on the payee, THAT report works. It is only the Itemized Payees report that is producing spurious output.

Payee Selection Dialog

I have confirmed that the only selected payee is "Prunus"

Report

None of the additional payees show bear any relation to the one selected payee.

Workaround:

I found a workaround, which is to use the filter dialog and then ALSO specify the payee name in the "Matching" section, as in:

Tagged:

Answers

  • NotACPA
    NotACPA SuperUser ✭✭✭✭✭
    Options

    After you tried the Validation, did you try a SuperValidate?

    Take a backup and then run a regular file Validation.

    When that completes, hold down the CTRL & Shift keys while re-performing the File Validation steps until the term "SuperValidaiton" appears.

    While not guaranteed to help, it frequently corrects errors that the regular validation can't … because it's almost certain that your "terminated the process" corrupted your data file.

    Your only other option is to keep Restoring older backups until you find one without the issue … but then you'll have to re-download/re-input everything since that backup was created.

    BTW, I can't (without also killing the process) re-create your error.

    Q user since February, 1990. DOS Version 4
    Now running Quicken Windows Subscription, Business & Personal
    Retired "Certified Information Systems Auditor" & Bank Audit VP

  • jhg
    jhg Member ✭✭
    edited June 8
    Options

    Turns out this is a well-known issue with the "new" report interface. Switching to the old interface fixes the problem.

    There are many more, but I can't find them right now.