Quicken for Mac 2017 v4.4.2 Released

Quicken MarcusQuicken Marcus Employee ✭✭✭✭
Quicken for Mac 2017 v4.4.2 is a critical release that is required before the Quicken cloud is updated in a few weeks.  There's a change in the service that will cause Mac clients to become inoperable after a transaction download if certain conditions are met.  Please upgrade as soon as you can.  The only change in 4.4.2 is this fix.  Everything else is the same.

Retail or quicken.com purchasers should be able to update today.  Mac App Store customers will have to wait for a bit as we go through the App Store review process.  We won't make the cloud changes until we're sure most people have upgraded.

Please post any issues with this release as comments in this forum post so we can spot them quicker.  We'll be monitoring this post.

NOTE: We just released v4.4.3 so please upgrade and post any new issues on that forum post.
«1

Comments

  • edited August 2018
    I upgraded from Quicken 2007 in August of 2015.  Is it worth it upgrade again to Quicken 2017???
    Thanks
  • smayer97smayer97 SuperUser ✭✭✭✭✭
    edited January 2017

    I upgraded from Quicken 2007 in August of 2015.  Is it worth it upgrade again to Quicken 2017???
    Thanks

    This should be a question in a separate thread as this has nothing to do with the above post.
    Have Questions? Check out these FAQs:COMPLETE list of Product Ideas - Quicken for Mac to VOTE on

    Object to Quicken's business model, using up 25% of your screen
    ? Add your vote here:
    Quicken should eliminate the LARGE Ad space when a subscription expires


    (
    Canadian Q user since '92, STILL using QM2007)

  • DremeeDremee Member
    edited January 2017
    I upgraded to Quicken 2017 4.4.2 today. Now my Wells Fargo information won't sync. 4.4.1 worked flawlessly. Quicken can connect to Wells Fargo without issues so there's no password or internet issues. The information from my checking and savings accounts just won't port into Quicken. 
  • pbGuypbGuy Member
    edited January 2017
    My QM2017 4.4.2 (updated from v4.4.1) syncs reliably with my WF accounts (checking, savings, & cc) via Quicken Connect.
  • DremeeDremee Member
    edited January 2017
    It seems to be working now. Must have been a one off issue.
  • DerrickDerrick Member
    edited March 2017
    My 4.4.2 update is downloading painfully slow.  Did the whole modem reset with the IP.  Back to 100+Mbps and still 32MB download taking 20 minutes?  Any ideas welcome.
  • Andy ArhelgerAndy Arhelger Member
    edited March 2017
    2 things are not working for me with 4.4.2
    1) Dragging a transaction to manually match doesn't work anymore. I get a cursor indicating this item can't be dropped here as I move it. There is a fine line under the matching transaction where the cursor changes and allows me to drop but the match doesn't work. There is no way to manually match transactions now!
    2) In the calendar view I used to be a be able to double click on a scheduled transaction to go to that transaction but double clicking no longer does anything.
    Can I go back to 4.4.1, this is very annoying.
  • Andy ArhelgerAndy Arhelger Member
    edited January 2017

    2 things are not working for me with 4.4.2
    1) Dragging a transaction to manually match doesn't work anymore. I get a cursor indicating this item can't be dropped here as I move it. There is a fine line under the matching transaction where the cursor changes and allows me to drop but the match doesn't work. There is no way to manually match transactions now!
    2) In the calendar view I used to be a be able to double click on a scheduled transaction to go to that transaction but double clicking no longer does anything.
    Can I go back to 4.4.1, this is very annoying.

    OK, now the matching is working. Don't know what changed. I clicked around and selected different transactions, seemed to fix something.
  • edited April 2018
    I'm having an issue with 4.4.2 for Mac - my budget has not pulled in actual downloaded expense transactions that are split between categories.  What's interesting is that my budget IS pulling in actual downloaded income transactions that are split (e.g. paycheck), but excluding the expenses (e.g. Home Insurance).  Is there a resolution for this?
  • BruceBruce Member
    edited March 2017
    Was using Quicken 2015 on my Mac, upgraded to 2017.  Some WF Bank transactions in different accounts do not download.  Really frustrating. I've deactivated and reactivated the link and still the same transactions did not load. If I have to manually check through every transaction, what's the point? Help in resolving this would be greatly appreciated.
  • hfmhfm Member
    edited December 2017
    My Wells Fargo is not syncing at all with 4.4.2; all my other accounts look like they synced fine. Strangely, no error is reported, and the Account Status window shows "Last Connecton Successful", but with last weekend's date (when I last used Quicken).

    I tried quitting and redoing it, no luck.  The log shows:

    2017-01-16 21:41:51 +0000: Response encoding: (null), length: 11, MIME type: text/html, and statusCode: 400
    2017-01-16 21:41:51 +0000: HTML error 400 from server:
    Bad Request
  • Quicken MarcusQuicken Marcus Employee ✭✭✭✭
    edited January 2017

    I upgraded from Quicken 2007 in August of 2015.  Is it worth it upgrade again to Quicken 2017???
    Thanks

    If you're happy with what you have then I wouldn't necessarily upgrade.  Take a look at what's been added since 2015 to decide.  Check out our website at https://www.quicken.com/mac.
  • Quicken MarcusQuicken Marcus Employee ✭✭✭✭
    edited January 2017

    2 things are not working for me with 4.4.2
    1) Dragging a transaction to manually match doesn't work anymore. I get a cursor indicating this item can't be dropped here as I move it. There is a fine line under the matching transaction where the cursor changes and allows me to drop but the match doesn't work. There is no way to manually match transactions now!
    2) In the calendar view I used to be a be able to double click on a scheduled transaction to go to that transaction but double clicking no longer does anything.
    Can I go back to 4.4.1, this is very annoying.

    There is literally one little thing that's different between 4.4.1 and 4.4.2 which is centered around a specific error message that is returned when syncing and this shouldn't affect anything until we make a change on the service.  In other words, nothing should work differently between 4.4.1 and 4.4.2. 
  • Quicken MarcusQuicken Marcus Employee ✭✭✭✭
    edited January 2017

    I'm having an issue with 4.4.2 for Mac - my budget has not pulled in actual downloaded expense transactions that are split between categories.  What's interesting is that my budget IS pulling in actual downloaded income transactions that are split (e.g. paycheck), but excluding the expenses (e.g. Home Insurance).  Is there a resolution for this?

    Were you on 4.4.1 before?  We didn't change anything in budgets so there shouldn't be any difference between the two.  Possibly Quit the app and restart to see if the issue continues to happen.  Also double check that the category of the item you are budget is turned on in your budget.  Not all categories automatically appear in the budget.
  • hfmhfm Member
    edited January 2017
    hfm said:

    My Wells Fargo is not syncing at all with 4.4.2; all my other accounts look like they synced fine. Strangely, no error is reported, and the Account Status window shows "Last Connecton Successful", but with last weekend's date (when I last used Quicken).

    I tried quitting and redoing it, no luck.  The log shows:

    2017-01-16 21:41:51 +0000: Response encoding: (null), length: 11, MIME type: text/html, and statusCode: 400
    2017-01-16 21:41:51 +0000: HTML error 400 from server:
    Bad Request

    @quickenMarcus, then any thoughts on what's happened with WF for me here? Worked fine last weekend with 4.4.1. Now, no error notification, no transactions uploaded or downloaded, just the normal message "No transactions downloaded" and the error 400 in the log. The submittal it's responding to involves a description change for a payee.
  • Quicken MarcusQuicken Marcus Employee ✭✭✭✭
    edited January 2017
    Bruce said:

    Was using Quicken 2015 on my Mac, upgraded to 2017.  Some WF Bank transactions in different accounts do not download.  Really frustrating. I've deactivated and reactivated the link and still the same transactions did not load. If I have to manually check through every transaction, what's the point? Help in resolving this would be greatly appreciated.

    Again, this is probably nothing related to 4.4.2 since nothing changed in this area between 4.4.1 and 4.4.2.  My hypothesis is that Quicken is displaying what we're receiving from the bank.  If you are using Direct Connect, we get what the bank sends us.  If you're using Quicken Connect, we're displaying what the account aggregator sends us.   I would check your logs or work with our support team to review the logs.  You can get to them by using the Help menu item called Show Logs in Finder.  This will tell you where the issue resides.  If the logs don't show the missing transaction then the issue is with the bank/aggregator and not Quicken Mac.  
  • hfmhfm Member
    edited January 2017
    hfm said:

    My Wells Fargo is not syncing at all with 4.4.2; all my other accounts look like they synced fine. Strangely, no error is reported, and the Account Status window shows "Last Connecton Successful", but with last weekend's date (when I last used Quicken).

    I tried quitting and redoing it, no luck.  The log shows:

    2017-01-16 21:41:51 +0000: Response encoding: (null), length: 11, MIME type: text/html, and statusCode: 400
    2017-01-16 21:41:51 +0000: HTML error 400 from server:
    Bad Request

    So, looking at the log, I see that the Payee name has an ampersand in it. Always has, but because I changed the description field, Q apparently needs to resend the payee up to Wells. But in the OFX, the current version (no idea when/if this changed) is not escaping the ampersand with "&". So it's indeed an ill-formed OFX submittal, and Wells is properly rejecting it. (Although the error reporting is abysmal here)

    So I have no idea how to proceed, as Q won't let me edit the name of an existing payee; I've tried putting the description field back, but Q just submits it again with the revised description. I tried creating a new payee with "and" instead of &, and then merging them, but Quicken uses the old name for the merged entry (saying happily "and you can rename it after merging if you want a different name", which is false, btw).

    Suggestions for how to recover?

    Edit: and yes, the fact I changed the description at the same time as migrating to 4.4.2 means this is probably independent of that.
  • Quicken MarcusQuicken Marcus Employee ✭✭✭✭
    edited January 2017
    hfm said:

    My Wells Fargo is not syncing at all with 4.4.2; all my other accounts look like they synced fine. Strangely, no error is reported, and the Account Status window shows "Last Connecton Successful", but with last weekend's date (when I last used Quicken).

    I tried quitting and redoing it, no luck.  The log shows:

    2017-01-16 21:41:51 +0000: Response encoding: (null), length: 11, MIME type: text/html, and statusCode: 400
    2017-01-16 21:41:51 +0000: HTML error 400 from server:
    Bad Request

    Given that there are a bunch of Wells Fargo issue being reported, my guess is that something changed at Wells Fargo or with our account aggregator for Wells Fargo.  Again, there's nothing in 4.4.2 that would affect only Wells Fargo and no other bank.  I would try to update again to see if the issue gets resolved.   
  • Quicken MarcusQuicken Marcus Employee ✭✭✭✭
    edited January 2017
    hfm said:

    My Wells Fargo is not syncing at all with 4.4.2; all my other accounts look like they synced fine. Strangely, no error is reported, and the Account Status window shows "Last Connecton Successful", but with last weekend's date (when I last used Quicken).

    I tried quitting and redoing it, no luck.  The log shows:

    2017-01-16 21:41:51 +0000: Response encoding: (null), length: 11, MIME type: text/html, and statusCode: 400
    2017-01-16 21:41:51 +0000: HTML error 400 from server:
    Bad Request

    Sorry just read the most recent post.  Let me investigate more.
  • Quicken MarcusQuicken Marcus Employee ✭✭✭✭
    edited January 2017
    hfm said:

    My Wells Fargo is not syncing at all with 4.4.2; all my other accounts look like they synced fine. Strangely, no error is reported, and the Account Status window shows "Last Connecton Successful", but with last weekend's date (when I last used Quicken).

    I tried quitting and redoing it, no luck.  The log shows:

    2017-01-16 21:41:51 +0000: Response encoding: (null), length: 11, MIME type: text/html, and statusCode: 400
    2017-01-16 21:41:51 +0000: HTML error 400 from server:
    Bad Request

    hfm.  We investigated and  you nailed it on the head and uncovered a bug.  We're going to fix it but the fix won't make it to customers until probably February.   The bug is in the Payee modification call.  It should escape the ampersand but doesn't.  Creating a new payee is fine and since most people don't change their payees, most don't run into the issue and of course, even a smaller subset have "&" in their payee name.  I think the only workaround, for now, is to create a new Payee.  Use that to pay bills and then merge that payee with the existing one after we fix the bug.  Will that work for now?  I can't think of another workaround.  
  • hfmhfm Member
    edited January 2017
    hfm said:

    My Wells Fargo is not syncing at all with 4.4.2; all my other accounts look like they synced fine. Strangely, no error is reported, and the Account Status window shows "Last Connecton Successful", but with last weekend's date (when I last used Quicken).

    I tried quitting and redoing it, no luck.  The log shows:

    2017-01-16 21:41:51 +0000: Response encoding: (null), length: 11, MIME type: text/html, and statusCode: 400
    2017-01-16 21:41:51 +0000: HTML error 400 from server:
    Bad Request

    Good to hear!  I did more or less that, and I'm clear for now.
  • Quicken MarcusQuicken Marcus Employee ✭✭✭✭
    edited January 2017
    hfm said:

    My Wells Fargo is not syncing at all with 4.4.2; all my other accounts look like they synced fine. Strangely, no error is reported, and the Account Status window shows "Last Connecton Successful", but with last weekend's date (when I last used Quicken).

    I tried quitting and redoing it, no luck.  The log shows:

    2017-01-16 21:41:51 +0000: Response encoding: (null), length: 11, MIME type: text/html, and statusCode: 400
    2017-01-16 21:41:51 +0000: HTML error 400 from server:
    Bad Request

    That's great to hear.  Thanks for tracking it down which made it easy for us to confirm the issue and fix it.
  • Quicken MarcusQuicken Marcus Employee ✭✭✭✭
    edited January 2017
    Derrick said:

    My 4.4.2 update is downloading painfully slow.  Did the whole modem reset with the IP.  Back to 100+Mbps and still 32MB download taking 20 minutes?  Any ideas welcome.

    You probably already did this but Quitting and starting Quicken again may help.  Sometimes there could be issues with our servers regarding load during peak times so trying at a different time may help.   I don't see any issues with our servers on our internal dashboard but let me know if this continues to be slow for you.
  • edited January 2017

    I'm having an issue with 4.4.2 for Mac - my budget has not pulled in actual downloaded expense transactions that are split between categories.  What's interesting is that my budget IS pulling in actual downloaded income transactions that are split (e.g. paycheck), but excluding the expenses (e.g. Home Insurance).  Is there a resolution for this?

    Yes, I was on 4.4.1 before without this issue.  I just quit the app and restarted my computer.  After synching Quicken once I restarted, the problem did not fix itself.  One thing to note after reviewing other issues in this thread is that the expense transactions in question are from my Wells Fargo checking account with a Direct Connect connection type.  I confirmed the categories in question are included in my Budget and I can see that the categories are correctly allocated on the transaction itself.  
  • edited January 2017

    I'm having an issue with 4.4.2 for Mac - my budget has not pulled in actual downloaded expense transactions that are split between categories.  What's interesting is that my budget IS pulling in actual downloaded income transactions that are split (e.g. paycheck), but excluding the expenses (e.g. Home Insurance).  Is there a resolution for this?

    I just posted in the other thread but wanted to post here to close out.  The details of the split included the details of a transfer to another account not included in my budget.  When I removed the link, it allowed Quicken to show the expense in my budget.
  • smayer97smayer97 SuperUser ✭✭✭✭✭
    edited January 2017

    I upgraded from Quicken 2007 in August of 2015.  Is it worth it upgrade again to Quicken 2017???
    Thanks

    I was going to put this into a reply once a new thread was created but I guess I'll put it here.

    Right...there is not a lot that is new in QM2017 vs QM2007. I suggest that you make sure that Quicken 2017 for Mac will meet your needs, since it is not an upgrade from QM2007 but rather from Quicken Essentials (which was re-written from the ground up, starting in 2010), so there are some features that are still not there e.g. loan amortization, 2-line display, QuickMath, or are not as fully developed yet, e.g. Customized Reports, investment lot management, performance reports and stats (therefore some data may not carry over). You can start here:
    http://www.quicken.com/mac/compare

    Currently, the main advantages of QM2017 over QM2007 include the ability to sync cash, bank, and credit card accounts using Quicken Mobile for mobile devices (iOS and Android) and the ability to save receipts with transactions via computer or mobile device. There are a few other minor features that QM2007 does not have. Note that QM2017 is being supported until April 30, 2020 whereas it has been announced that security fixes have ceased for QM2007 since QM2017 is released...see http://www.quicken.com/support/update-quicken-mac-2007-support-policies-may-2016 yet online access will continue as long as the FI/Bank supports it and their security updates don't prevent it.

    You may want to review the List of Obstacles and Hindrances for Migrating from QM2007 or QWin to Quicken for MacAdd your vote to any features that are missing for you.

    Be aware of data that will and will not carry forward: 
    https://www.quicken.com/support/what-data-gets-carried-over
    Then look at the updates since the original release here:
    https://www.quicken.com/support/quicken-2017-mac-release-notes
    Also read some of the Fixes and Improvements that are being released soon here:
    http://www.quicken.com/upcoming-product-fixes-and-improvements
    You will also want to look at a more detailed comparison done by a SuperUser which also identifies nuances not mentioned elsewhere (and read on for comments from other users too on that same discussion thread): 
    https://getsatisfaction.com/quickencommunity/topics/can-anyone-who-has-switched-from-2007-to-2015-he...
    Take a look at the following videos to give you a better idea:
    https://www.youtube.com/user/QuickenMac

    If you find that QM2017 does not meet your needs, the alternative is to continue to run QM2007 Lion Compatible (LC), which will run on Mac OS X 10.6.8 to 10.12 Sierra (so far).

    (If you find this reply helpful, please be sure to click "Like", so others will know, thanks.)
    Have Questions? Check out these FAQs:COMPLETE list of Product Ideas - Quicken for Mac to VOTE on

    Object to Quicken's business model, using up 25% of your screen
    ? Add your vote here:
    Quicken should eliminate the LARGE Ad space when a subscription expires


    (
    Canadian Q user since '92, STILL using QM2007)

  • Quicken MarcusQuicken Marcus Employee ✭✭✭✭
    edited January 2017
    hfm said:

    My Wells Fargo is not syncing at all with 4.4.2; all my other accounts look like they synced fine. Strangely, no error is reported, and the Account Status window shows "Last Connecton Successful", but with last weekend's date (when I last used Quicken).

    I tried quitting and redoing it, no luck.  The log shows:

    2017-01-16 21:41:51 +0000: Response encoding: (null), length: 11, MIME type: text/html, and statusCode: 400
    2017-01-16 21:41:51 +0000: HTML error 400 from server:
    Bad Request

    hfm, we fixed this issue and are going to release an update early next week.  Thanks again for helping us track down this issue.  I think it's been in the product for a long time so not many people have hit it but it's important to fix.
  • Quicken MarcusQuicken Marcus Employee ✭✭✭✭
    edited April 2018

    I'm having an issue with 4.4.2 for Mac - my budget has not pulled in actual downloaded expense transactions that are split between categories.  What's interesting is that my budget IS pulling in actual downloaded income transactions that are split (e.g. paycheck), but excluding the expenses (e.g. Home Insurance).  Is there a resolution for this?

    Thank you for the update.  Yes, we don't currently support transfers in a budget but we know people want to track them for things like mortgage payments and moving money for savings.  It's definitely on our long-term roadmap for budgets.
  • perry123perry123 Member
    edited January 2017
    installed 4.4.2 all my accounts sync except 1 of 3 for security service federal credit union. my checking won't sync says its a dead account, I can login so its not dead  my 2 other accounts at ssfcu were working fine , now has error 105 no syncing,  tried  to stop downloads on checking and restart it up now it won't communicate  error 105   an error between quicken and ssfcu in communication.   I login thru this link  https://mybranch.ssfcu.org  and yours is https://www.ssfcu.org    can this be in issue I can log in both sites   Really sucks cause  this is one of my bill pay accounts
  • EdEd Member
    edited January 2017
    Cannot update. Continuously get "relaunch" error. Have re-installed Sierra, even started in safe mode. No difference.
Sign In or Register to comment.