Why has my trusted Q2015 suddenly started displaying all my security currencies in GBP?

I had successfully added reinvested dividends to a USD mutual fund account and saved the change. For some reason the entry was slaow to update and was duplicated when I hit save. Upon trying to enter the next reinvested dividend the 'Security' field was blank. When I typed in the security name I got the message security currency does not match account currency. When I checked my security list, I discover all of my securities which were previously denominated in USD are now denominated in GBP. The currency cannot be edited.
How do I restore the correct currencies to my mutual funds and resume entering reinvested dividends :| ?

Answers

  • Frankx
    Frankx SuperUser ✭✭✭✭✭
    Hi @Richardh888

    It sound like you have somehow switched from using a single currency to using multiple currencies in Quicken.

    When was the last time that you backed up your Quicken data file? The easiest option may be to restore a recent backup. Otherwise, you could try to reset back to a single currency by first deleting all foreign accounts and securities.  Then, do this:
    1. Choose Edit menu > Preferences.
    2. In the left pane, select Calendar and currency.
    3. In the right pane, clear the check box for "Multi currency support".
    4. Click OK. 
    Good luck.

    Frankx

                      Quicken H&B-Subscription Ver. 34.24 - Windows 10-Home Version
                                             - - - - Quicken User since 1984 - - - 
      -  If you find this reply helpful, please click "Helpful" (below), so others will know! Thank you.  -

  • Hi Frankx
    Thanks for your answer.
    In fact I do need multi-currency support. I should have mentioned my 'home' currency is GBP but I have investments in various other currencies.
    Nevertheless your suggestion to restore from backup was helpful and I have done this. However that one investment account still wouldn't allow me to enter new transactions. I finally set up a 'new' account; entered duplicate transactions from the old account; and then deleted the original account. It seems to be behaving itself (for now :# )

    I'm randomly getting asked to enter my Quicken ID password - which is something new. There is a message saying this feature is not compatible with older versions of Quicken. I don't know my quicken ID password and it doesn't seem to recognise my Quicken ID when I try to reset the password. I'm wondering if this is why it has started behaving strangely. Do you know if Quicken ID can be turned off in Q2015?
  • Frankx
    Frankx SuperUser ✭✭✭✭✭
    Hi again @Richardh888

    Glad to hear that your were able to get the file back in shape.  I believe that you may avoid the Quicken ID login request if you disable your network connection before starting Quicken, but I am not sure that this will work with Q2015.  Try it and let me know how that goes.

    Frankx

                      Quicken H&B-Subscription Ver. 34.24 - Windows 10-Home Version
                                             - - - - Quicken User since 1984 - - - 
      -  If you find this reply helpful, please click "Helpful" (below), so others will know! Thank you.  -

  • Hi Frankx
    Thanks for your response.
    The login requests did stop when I opened Quicken offline.
    But they also didn't appear again when I subsequently opened it with a network connection - so all appears to have gone back to normal - fingers crossed!
    Thanks for your help.