"Investing --> Portfolio" tab

ken123
ken123 Member ✭✭
The tab Investing --> Portfolio displays a "Shares" column. One of the entries shows the number of shares as 234456.00000. This is annoying for two reasons, first why have the zeros after the decimal? Second, the number to the left of the decimal has no commas. Is there any way to fix this?

Best Answer

  • UKR
    UKR SuperUser ✭✭✭✭✭
    Accepted Answer
    ken123 said:
    The tab Investing --> Portfolio displays a "Shares" column. One of the entries shows the number of shares as 234456.00000. This is annoying for two reasons, first why have the zeros after the decimal? Second, the number to the left of the decimal has no commas. Is there any way to fix this?

    More details, please.
    Does this anomaly apply to all numbers displayed in Quicken or does it apply to one line item only?
    Your example displays with 5 decimal places.
    Quicken is capable of storing and working with fractional shares using up to 6 decimal places. See setting in Edit / Preferences / Reports only. Try setting the number of decimal places to 6. It's quite possible that your number of shares actually is something like 234456.00000x (where x = 1 to 9)

Answers

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    That's strange.  I don't know how to change it, but mine shows it like this:

    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Accepted Answer
    ken123 said:
    The tab Investing --> Portfolio displays a "Shares" column. One of the entries shows the number of shares as 234456.00000. This is annoying for two reasons, first why have the zeros after the decimal? Second, the number to the left of the decimal has no commas. Is there any way to fix this?

    More details, please.
    Does this anomaly apply to all numbers displayed in Quicken or does it apply to one line item only?
    Your example displays with 5 decimal places.
    Quicken is capable of storing and working with fractional shares using up to 6 decimal places. See setting in Edit / Preferences / Reports only. Try setting the number of decimal places to 6. It's quite possible that your number of shares actually is something like 234456.00000x (where x = 1 to 9)

  • ken123
    ken123 Member ✭✭
    Solved! Thanks for your response UKR!

    The issuer of this stock was acquired in a stock for stock transaction. There was a 'cash-in-lieu' cash-out of fractional shares. I calculated the fraction of a share that was 'sold' for cash-in-lieu, and only took the fraction out to the fifth decimal place. So, in response to your advice, I experimented by iteration, adding .000001, then .000002, then .000003, etc., to the fraction of shares sold for cash, and then checking to see whether the "Shares" column was corrected for the anomaly. When I added .000009 to the number of fractional shares cashed-out in the transaction, the .00000 disappeared from the Shares column. Yay!!! Thanks SO MUCH!!!!
  • UKR
    UKR SuperUser ✭✭✭✭✭
    For future reference, please remember to always use the exact number of shares purchased or sold as reported by the brokerage, the commission amount and the total $-amount. Do not enter the price per share. Instead, let Quicken calculate it to as many decimal places as it wants to.
    If you let Quicken calculate number of shares or amounts, rounding errors will creep in and cause discrepancies when Quicken compares the holdings in your account register to what the brokerage reports ... and you end up with Placeholder Transactions that need fixing. Or your account cash balance will not reconcile to the statement balance.