Asset Allocation Total Wrong

ChevelleJeff
ChevelleJeff Member
edited February 9 in Reports (Windows)
Every January I need to print reports for my Trust and this year printing the Asset Allocation report the totals for the Graph assest vue and the total for the Report vue are different. Even if they are displayed on the same page. It appears to only happen if you put in a date of 12/31/2021. Going back one day or forward one day works. This has worked for the past 11 years. The totals for each category of assest matches, just the grand total on the report vue is wrong by not adding the asset category totals correctly.

Answers

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    What I see is that the total in the graph matches the Investments total in the Accounts bar within less than 
    $1.00, but the total in the report does not agree with the graph total.

    In the Cash section of the report there are two equal -Cash- lines. If I subtract one of these from the report total, it matches the graph total. 

    So it appears that the cash in the investment accounts is being counted twice in the report. In accounts that do not normally have a cash balance, the cash would go down to zero depending on the date.

    Does this match what you are seeing? 
    QWin Premier subscription
  • ChevelleJeff
    ChevelleJeff Member
    No, I cannot relate the issue to cash in any way that I can see. The total value on the report is lower than the total value on the graph. The graph is correct. What I strongly suspect is the problem is that either the report or the graph not using any security price changes that may have occured on 12/31. I have not yet proved this but I guess I should go through the effort to help narrow it down.
  • ChevelleJeff
    ChevelleJeff Member
    Did a quick test and on the Investments tab set the date to 12/30 to eliminate price changes for 12/31 and got within $4000 of matching. Was off $7400 originally. Then took a look at the cash account and doubled the transactions that occured on 12/31 kind of what you were saying and added those and came within $4 of matching. So I think I may be convinced the Allocation Report is not using the transactions for the end date of the report in addition to what you said about the doubling. Or maybe its a problem with the last day of the year because when I run it for other dates it works fine.
  • ChevelleJeff
    ChevelleJeff Member
    OK, please ignore my last 2 comments. I'm sorry but they are incorrect and I dont know how to delete them. What I see after more careful analysis is that ever since 12/10/2021 the report has been wrong and the graph is correct. I checked everyday in december and random dates before December and see this to be correct. All the way into 2022, up to 1/4/2022, today, the report is wrong also.
    The only transaction on 12/10/2021 was a dividend payment which is near but not the same number I'm off. As I said its off ever since this transaction and never the same amount, but within a $500.

    Sorry for the confusion about. Just had my 69th birthday and feel old now.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Did the dividend payment remain in the account as Cash, or was it reinvested or the cash swept to a money market fund? If it remained as Cash that might explain your issue.

    Another possibility is that the dividend is recorded wrong, perhaps as a transfer to the same account, so the dividend does not get added to the account's cash balance.

    Look at the Cash section at the bottom of the report with the end date set after 12/10. Do you see two lines marked with -Cash- one at  the beginning and one at the end of the Cash section?  There is only supposed to be one.
    QWin Premier subscription
  • ChevelleJeff
    ChevelleJeff Member
    The cash is correct and only 1 cash entry at the bottom of the cash section. The totals on every section of the report (Domestic Bonds, Large Cap Stocks, Small Cap Stocks, Including the Cash section) all match the graph version of the report correctly. The only thing wrong is the grand total at the bottom, the Graph report totals correctly, the Report version does not. Why it started with the dividend I don't know, its actually a long term capital gain distribution. The distribution was in cash and is still in cash but all transaction in this brokerage account use the DIVX types and transfer to a linked checking account. No reinvestment. The total is not off by the amount of the distribution. The distribution was for $9517.22 and the total is off by $8778.99 and changes for every new end date you use even if there were no transactions on that end date. If I run the report with a Saturday end date then run is for Sunday end date, for example 12/11 and 12/12 the totals do not change. This tells me is may be something to do with stock pricing as they don't change on the weekend. I don't know how to prove that.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Have you tried deleting and re-entering the problem transaction?


    QWin Premier subscription
  • ChevelleJeff
    ChevelleJeff Member
    No but here's new info that may be zeroing in on the issue. As I said before, the totals on the allocation sections are correct but I see now that the section for Small Cap Stocks does not add up to the total it has for that section. When I add up the individual investments in that section they are off by the amount the grand total is off. I think this means that on 12/10 something happened and probably a new allocation was downloaded for whichever security is wrong. I added the allocated amounts for each security in the Small Cap section to their cooresponding amounts in the other sections and the totals match what they show in my portfolio. So I believe there is a possibility that the allocation for some other security probably some persent goes into Small Cap but for some reason it is not showing up. I will have to add the amounts for all the other securities and find which one is missing shares on this report. Hopefully that will be the amount of shares missing in the Small Cap section and then see what the allocation says to do in the security list.

    I believe that explains why is started on a certain date and does not correct and why it is not off by the amount of the only transaction that occurred on that day.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    It sounds like you are getting closer...

    Quicken does not record the history of asset allocation percentages, it only uses the most recent percentages for each security.

    Are you using just the built-in asset classes, or have you defined new ones? There have been issues when people have made allocations to user defined classes.
    QWin Premier subscription
  • ChevelleJeff
    ChevelleJeff Member
    To answer your question, all the allocations are as downloaded. Never touched by me. The security in question does happen to be the same one the cap gain distribution is for. This is wierd. The security is Fidelity ContraFund and is allocated by default at:

    84% Large Cap
    8% Small Cap
    6% International
    1% Cash
    1% Other

    Using this setup the small cap is skipped and all the others are OK
    I have changed the allocation a 100 times and it always fails unless it is only allocated to 1 category or there is only one category with a larger %. I have changed it to 93% Large cap and 7% small cap and it works. At this point I have to get the reports out so they are going out that way for now.

    Any other thoughts would be apprieciated.

    Any idea how to get quicken to look into this. Is there enoughf info for them to figure something out?
    Thanks for your help.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    I'm not sure what you mean by "it always fails." Do you mean that the allocation report is incorrect if you set the allocation manually and it has more than two asset classes? Remember if you want to specify the asset classes yourself, you must un-check the Download asset class box.

    What you describe sounds weird. I set up an account with just that fund in a test file. The allocations download as you list and if I set the allocation report to include just that account everything looks OK.

    Since you appear to be the only person affected, it is most likely a problem with your data file and it is unlikely that Quicken will do any serious investigation.

    If you want to explore further, you might customize your report to include just that security and see if you still see the problem.

    If there are not a lot of Bought and Sold or Reinvest transactions with this fund, you might back up your data just in case then delete and re-enter all the transactions, being careful to use the same lots for any sales.
    QWin Premier subscription
  • ChevelleJeff
    ChevelleJeff Member
    I deleted the transaction and the reports worked correctly with the original allocation. I manually added the transaction back in and the report failed again by not using the transaction. I got curious and moved the date of the transaction back to January 4th. The report worked correctly. Then I started moving the date forward and found when the transaction date hit August 3rd the report started to fail again. This is the only long term capital gain distribution in the file for year 2021. I see no logic to this at all but it is consistent with those particular dates.
    I guess now its time to create a blank file and try and recreate this senario somehow.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    If you'll bear with me, I am trying to catch up on this discussion.  In my file, I see a difference of only pennies but I don't think that relates (directly) with your issue.

    It appears you have gotten to the point of identify that the discrepancy is related to your investment in the Fidelity ContraFund.

    Today, that fund shows an asset mix of 83% LgCap and 2% Cash vs your report from yesterday of 84% and 1% -- just in case that makes any difference.  If you got a sizeable LTGain distribution on 12/10 for that fund, I would take it to be a sizeable investment for you as well, not that that matters specifically.  What does matter is that on 12/10 the NAV of the fund dropped from 20.27 on the 9th to 18.78 on the 10th.  I see they distributed $1.627/share on the 10th. 

    What I see that doing to your asset allocation for that particular day:
    On the 9th, considering only one share of that one fund, Quicken sees 1% of that $20.27 share value as cash ($0.2027).  On the 10th considering the one share and the cash received from that one share, you had $18.78 + 1.627 = $20.407 total value with now 1.8148 in cash (0.1878 + 1.627).  Effectively, what had been 1% cash one day became almost 9% cash the next day due to that distribution.  So a distribution (div, cap gain, etc.) can have an effect on the overall allocations.  Whether that is consequential to the overall portfolio is highly dependent on your diversification.

    But that still doesn't actually explain why quicken is reaching significantly different totals for the graph summary  and the report summary. 

    One think I would be doing at this stage is running that report with just that security, and just that security and cash.  Does that reinforce that the discrepancy is singularly associated to that security? 

    Another observation I make -- I see that report often fail to update dynamically.  It responds to some changes correctly.  As I change the asset mix, the existing report does not change.  I have to create a new Asset Allocation report to see those changes take effect.  That can certainly lead to misperceptions.  

    Hope you find something in here helpful.  
This discussion has been closed.