Why is it so difficult to accept and update investment transactions - lot assignment

S M
S M Member ✭✭
edited April 14 in Investing (Windows)
I download account activity from my investment account. Accept downloaded transactions will not accept all transactions. Many (many!) of them I have to go in and individually specify to select lots based on First In. Quicken should have ability to set a rule, "Always accept transactions based on First In". It takes 10 to 15 seconds to edit and update each one, which means a very long time to update a busy month of transactions.

C'mon, please, is there a solution to make "First In" a default condition for accepting investor account sell transactions?

Best Answer

  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    edited March 13 Answer ✓
    Quicken has that feature.  You need to go to Edit > Preferences > Downloaded transactions > check Settings for "Lot assignment after investment download" > select the account > check the box for "Automatic Assignment instead of prompting on Accept" > tick "Quicken Default (First Shares In for Equities)" > OK.  When transactions are downloaded, click on "Accept All" and Sell lot assignments will be done automatically and all transactions will be entered into the register.

    (QW Premier Subscription: R41.10 on Windows 10)

Answers

  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    edited March 13 Answer ✓
    Quicken has that feature.  You need to go to Edit > Preferences > Downloaded transactions > check Settings for "Lot assignment after investment download" > select the account > check the box for "Automatic Assignment instead of prompting on Accept" > tick "Quicken Default (First Shares In for Equities)" > OK.  When transactions are downloaded, click on "Accept All" and Sell lot assignments will be done automatically and all transactions will be entered into the register.

    (QW Premier Subscription: R41.10 on Windows 10)
  • S M
    S M Member ✭✭
    Good, thanks. The Default (First Shares) was working - and the Preferences setting to Automatic fixed the problem for me.
This discussion has been closed.