How do you fix lots, after deleting a stock remove registry entry

bflikkema
bflikkema Member ✭✭
edited October 1 in Investing (Windows)
I had entered a remove journal for a stock and specified lots. I have later decided I wanted to transfer rather than remove. I deleted the journal entry, but it did not update the share balance. The lots it removed are in the journal but they do not show up in the transaction history, or under the security detail view. The security detail view even still shows the amount removed that I deleted.

I have tried running the "rebuild investing lots" under File -> Validate and Repair but that did not fix it. How do I get the investing database to update and match the account registry?

Best Answer

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Answer ✓
    Deleting the Removed transaction should certainly have restored those lots to your holdings in Quicken.

    Perhaps a  hidden Placeholder is affecting what you see in the account. Go to Edit > Preferences > Investing Transactions and make sure the Show hidden transactions box is checked. 

    Placeholders will have a gray background in the account’s transaction list (register) even if they are not selected, and will have “Entry” in the Action column. Placeholders compensate for missing or incorrect investing transactions by forcing Quicken’s share balance for a security to match a specified value. This is usually the share count downloaded from your financial institution (FI).

    Also, rather than looking at the Security Detail View, I suggest you go to the account where you removed the shares and click on Holdings. That will show the details of what you currently hold in the account. You can click on the plus sign next to a security to see the lots in that account. You can also change the As of date to see what you held in the past. By changing the date, you can see when the holdings changed, then go to the transaction list for that date and see what caused the change.
    QWin Premier subscription

Answers

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Answer ✓
    Deleting the Removed transaction should certainly have restored those lots to your holdings in Quicken.

    Perhaps a  hidden Placeholder is affecting what you see in the account. Go to Edit > Preferences > Investing Transactions and make sure the Show hidden transactions box is checked. 

    Placeholders will have a gray background in the account’s transaction list (register) even if they are not selected, and will have “Entry” in the Action column. Placeholders compensate for missing or incorrect investing transactions by forcing Quicken’s share balance for a security to match a specified value. This is usually the share count downloaded from your financial institution (FI).

    Also, rather than looking at the Security Detail View, I suggest you go to the account where you removed the shares and click on Holdings. That will show the details of what you currently hold in the account. You can click on the plus sign next to a security to see the lots in that account. You can also change the As of date to see what you held in the past. By changing the date, you can see when the holdings changed, then go to the transaction list for that date and see what caused the change.
    QWin Premier subscription
  • bflikkema
    bflikkema Member ✭✭
    @Jim_Harman thanks, that did it! Well at least got me to where I could fix it.

    I changed my preferences to show hidden transactions. After I did that under holdings, same as security detail view, those sold lots showed with the date they were removed with a grey background. I then looked in the registry and the deleted entry was actually still there, but again with a grey background. I had to delete that now grayed out entry again. Once I did that the lots show correctly. Thanks!
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    The transaction with grey background was the Placeholder. At some point you probably did a Share Balance adjustment or accepted a Placeholder as part of downloading transactions or reconciling shares.
    QWin Premier subscription
This discussion has been closed.