Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

When I do One-Step Update, it reflects many securities sold. For each I have to go through and "acc

David Kosterlitz
David Kosterlitz Member ✭✭
edited December 2018 in Investing (Windows)
Allow "average cost" to be elected on a blanket basis for a section 529 account.  We have 529 account with frequent transactions to withdraw for college expenses.  When I do One-Step Update, it reflects many securities sold.  For each I have to go through and "accept" and then I choose "average cost."  This happens over and over.  I suggest that there should be a way to opt once, effective indefinitely, to use "average cost" for all securities in the account.  I don't see that option at present.

Comments

  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited September 2018

    What kind of securities are you holding in this "529 account"? Mutual Funds?

    Mutual Funds have an optional check box "Use average cost". Go into your Security List (under Tools menu). Edit each of these funds and put a checkmark at "Use average cost". That ought to take care of this issue.


    image

  • David Kosterlitz
    David Kosterlitz Member ✭✭
    edited December 2018
    I only just now saw this answer, which is helpful, but when I go to a money market fund held in that 529 plan and see the "use avg cost" box unchecked, and notice that average cost is lower than current cost (so I guess theoretically there is a built-in gain, I don't know exactly why), And then I check that box, a warning comes up saying the IRS restricts when you can make this change and that if you do so there is a way to preserve the lot identification basis records.  They say click Help for more info, but when I do, I can find none on either of these.  So I've not checked the box yet.  Any comments would be welcome.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited November 2018
    Note that the "Use Average Cost" is a security level, not account level decision. If you hold the same security in a taxable account where you want to track the cost basis of individual lots, you may want to leave this un-checked.

    For a money market fund, the cost *should* always be $1.00 per share. If Quicken is showing something different, I would go to the Security Detail view, select Update/Edit price history and look through the price history to check and correct your transactions on any date where it is different. 

    For a money market fund where the share price is constant, it *should* be safe to ignore the warning about changing your cost basis method.
    QWin Premier subscription
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    edited October 2018
    In my various retirement accounts at Fidelity, some of which have holdings in a MMF, I just carry that position in Q as Cash.

    There's really no need to go thru all of the Sales and Buys when there's no tax impact of the sale action (no CapGains or CapLosses).
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • David Kosterlitz
    David Kosterlitz Member ✭✭
    edited December 2018
    Thanks very much Jim Harman and NotACPA, for your answers and suggestions.  I guess I just like the fact that Quicken will download transactions from my banks and brokers and use it for all accounts for which it is available.  So for our two accounts at the state section 529 plan, they offered electronic update and I took it.  But since then, every time I do a one-step update, I try to click on "accept all" but it won't let me do it; instead it lists the 5 or 6 securities or mutual funds that were sold, as separate line items and makes me accept each individually and then I have to select "average cost" (don't want lot identification method) before it lets me move on and "accept" the next item that was sold.  But even after I do all that, at the end as I check "done" a message pops up telling me that my Quicken balance does not match the institution's balance and I hit "ignore" or "OK" or something.  The only solution I can think of now would be to simply delete these two 529 accounts from Quicken and handle them separately, though I'd rather keep them in Quicken if this process could be simplified.  Any further comments would be welcome...
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    edited September 2017

    Note that the "Use Average Cost" is a security level, not account level decision. If you hold the same security in a taxable account where you want to track the cost basis of individual lots, you may want to leave this un-checked.

    For a money market fund, the cost *should* always be $1.00 per share. If Quicken is showing something different, I would go to the Security Detail view, select Update/Edit price history and look through the price history to check and correct your transactions on any date where it is different. 

    For a money market fund where the share price is constant, it *should* be safe to ignore the warning about changing your cost basis method.

    For a money market fund where the share price is constant, it *should* be safe to ignore the warning about changing your cost basis method.
    Likewise it would be safe to not do the Average cost selection.  Take the other path to let Quicken default to the FIFO selection.  One click.  
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    edited September 2017

    Thanks very much Jim Harman and NotACPA, for your answers and suggestions.  I guess I just like the fact that Quicken will download transactions from my banks and brokers and use it for all accounts for which it is available.  So for our two accounts at the state section 529 plan, they offered electronic update and I took it.  But since then, every time I do a one-step update, I try to click on "accept all" but it won't let me do it; instead it lists the 5 or 6 securities or mutual funds that were sold, as separate line items and makes me accept each individually and then I have to select "average cost" (don't want lot identification method) before it lets me move on and "accept" the next item that was sold.  But even after I do all that, at the end as I check "done" a message pops up telling me that my Quicken balance does not match the institution's balance and I hit "ignore" or "OK" or something.  The only solution I can think of now would be to simply delete these two 529 accounts from Quicken and handle them separately, though I'd rather keep them in Quicken if this process could be simplified.  Any further comments would be welcome...

    ... then I have to select "average cost" (don't want lot identification method)
    What is wrong with lot identification?  Especially for a 529 plan?  You do not have to actually specify the lots.  Just leave the setting as it pops up and let Quicken default to its FIFO (first in, first out) default.  One click on the "Done" (or whatever the right-hand button is) and move forward.  

    Now the balance not matching is likely a separate issue and more likely related to past transactions than current transactions.  You'll need to expand on that info to get meaningful guidance.  Fundamentally, you'll need to go back and see where the discrepancy first arose.  Or you may need to confirm that the brokerage is sending the right information at the right precision (number of decimals).  
  • mtn_living
    mtn_living Member ✭✭
    edited October 2018
    I have this same problem. I have three securities which are money market mutual funds. I have gone to each one individually and marked them as average cost basis. However when I download transactions Quicken refuses to Accept All for transactions involving these securities. I can individually accept and it pops the window asking me to confirm average cost basis.

    The problem is that for this particular situation I'm managing tracking of someone's trust account and the account generates hundreds of little transactions for these money market funds. I have to sit and accept every single one indivually. It's making this a very tedious exercise.

    As with the original poster I don't understand why Quicken won't just Accept All with these transactions.
  • Michael Farley
    Michael Farley Member ✭✭
    edited October 2018

    I have this same problem. I have three securities which are money market mutual funds. I have gone to each one individually and marked them as average cost basis. However when I download transactions Quicken refuses to Accept All for transactions involving these securities. I can individually accept and it pops the window asking me to confirm average cost basis.

    The problem is that for this particular situation I'm managing tracking of someone's trust account and the account generates hundreds of little transactions for these money market funds. I have to sit and accept every single one indivually. It's making this a very tedious exercise.

    As with the original poster I don't understand why Quicken won't just Accept All with these transactions.

    I have the same problem as mtn_living with the Fidelity Government Money Market fund.  Even though I have Average Cost set for the security, it makes me accept the sale of this fund separately and verify to use average cost.  
This discussion has been closed.