Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

I copied my Quicken 2007 file in my relatively New Mac OS X 10.7.5. But I can't open it. What are

Unknown
Unknown Member
I copied my Quicken 2007 file in my relatively New Mac OS X 10.7.5.  But I can't open it.  What are my choices?

Comments

  • smayer97
    smayer97 SuperUser, Mac Beta, Canada Beta ✭✭✭✭✭
    edited January 2019
    Are you getting the error that QM2007 cannot run on your computer? If so, this means you have the PPC version (v16.0.x) and not the LC compatible version (v16.1+). At this point, You have 2 choices: Buy Quicken 2017 for Mac or get the Quicken 2007 Lion Compatible version. I suggest that you first make sure that Quicken 2017 for Mac will meet your needs, since it is not an upgrade from QM2007 but rather from Quicken Essentials (which was re-written from the ground up, starting in 2010), so there are some features that are still not there e.g. loan amortization*, 2-line display, QuickMath, or are not as fully developed yet, e.g. Customized Reports, investment lot management, performance reports and stats (therefore some data may not carry over). You can start here:
    http://www.quicken.com/mac/compare

    *NOTE: Support for fixed rate loans has been announced but there is no announced timing for support for variable rate loans.

    Currently, the main advantages of QM2017 over QM2007 include the ability to sync cash, bank, and credit card accounts using Quicken Mobile for mobile devices (iOS and Android) and the ability to save receipts with transactions via computer or mobile device. There are a few other minor features that QM2007 does not have. Note that QM2017 is being supported until April 30, 2020 whereas it has been announced that security fixes have ceased for QM2007 since QM2017 is released...see http://www.quicken.com/support/update-quicken-mac-2007-support-policies-may-2016 yet online access will continue as long as the FI/Bank supports it and their security updates don't prevent it.

    You may want to review the List of Obstacles and Hindrances for Migrating from QM2007 or QWin to Quicken for MacAdd your vote to any features that are missing for you. Your VOTES matter!

    Be aware of data that will and will not carry forward: 
    https://www.quicken.com/support/what-data-gets-carried-over
    Then look at the updates since the original release here:
    https://www.quicken.com/support/quicken-2017-mac-release-notes
    Also read some of the Fixes and Improvements that are being released soon here:
    http://www.quicken.com/upcoming-product-fixes-and-improvements
    You will also want to look at a more detailed comparison done by a SuperUser which also identifies nuances not mentioned elsewhere (and read on for comments from other users too on that same discussion thread): 
    https://getsatisfaction.com/quickencommunity/topics/can-anyone-who-has-switched-from-2007-to-2015-he...
    Take a look at the following videos to give you a better idea:
    https://www.youtube.com/user/QuickenMac

    If you find that QM2017 does not meet your needs, the alternative is to obtain and run QM2007 Lion Compatible (LC), which will run on Mac OS X 10.6.8 to 10.12 Sierra (so far) by contacting Quicken support here: http://www.quicken.com/contact-support

    NOTE: If you purchase QM2017, you can get QM2007 for free by contacting support. Just select QM2017 support. Some of the cheapest places to purchase it are places like Amazon.

    (If you find this reply helpful, please be sure to click "Like", so others will know, thanks.)
    you have
    Have Questions? Check out these FAQs:
    COMPLETE list of Product Ideas - Quicken for Mac to VOTE on

    Object to Quicken's business model, using up 25% of your screen?
    Add your vote here:
    Quicken should eliminate the LARGE Ad space when a subscription expires

    (
    Canadian user since '92, STILL using QM2007)
  • Unknown
    Unknown Member
    edited August 2018
    Just an FYI...I contacted Quicken Support Chat just now and requested a copy of Quicken Mac 2007 v 16.1 and above after telling them I had QM 2007 that was incompatible with my copy of Sierra.

    The agent told me that it is no longer available on their servers and wouldn't provide it to me.  They stated I would have to purchase Quicken Mac 2017.  

    So...if you're thinking about getting a copy of Lion compatible QM 2007, good luck with support on that.  
  • smayer97
    smayer97 SuperUser, Mac Beta, Canada Beta ✭✭✭✭✭
    edited May 2017
    gmalis1 said:

    Just an FYI...I contacted Quicken Support Chat just now and requested a copy of Quicken Mac 2007 v 16.1 and above after telling them I had QM 2007 that was incompatible with my copy of Sierra.

    The agent told me that it is no longer available on their servers and wouldn't provide it to me.  They stated I would have to purchase Quicken Mac 2017.  

    So...if you're thinking about getting a copy of Lion compatible QM 2007, good luck with support on that.  

    interesting...not sure when that change occurred since another user very recently stated the opposite. Could also be incorrect, as one agent may be misinformed. Would not be the first time.

    Plus, it would make little sense for Quicken to stop providing it as an intermediary since it would mean cutting off a lot of potential upgraders. And in terms of comparison, QM2007 is only like QW2013, in terms of number of versions back. But  I would not put it past them.
    Have Questions? Check out these FAQs:
    COMPLETE list of Product Ideas - Quicken for Mac to VOTE on

    Object to Quicken's business model, using up 25% of your screen?
    Add your vote here:
    Quicken should eliminate the LARGE Ad space when a subscription expires

    (
    Canadian user since '92, STILL using QM2007)
  • smayer97
    smayer97 SuperUser, Mac Beta, Canada Beta ✭✭✭✭✭
    edited May 2017
    gmalis1 said:

    Just an FYI...I contacted Quicken Support Chat just now and requested a copy of Quicken Mac 2007 v 16.1 and above after telling them I had QM 2007 that was incompatible with my copy of Sierra.

    The agent told me that it is no longer available on their servers and wouldn't provide it to me.  They stated I would have to purchase Quicken Mac 2017.  

    So...if you're thinking about getting a copy of Lion compatible QM 2007, good luck with support on that.  

    M Cohen  please do let us know what your results are if you try to get QM2007 LC.
    Have Questions? Check out these FAQs:
    COMPLETE list of Product Ideas - Quicken for Mac to VOTE on

    Object to Quicken's business model, using up 25% of your screen?
    Add your vote here:
    Quicken should eliminate the LARGE Ad space when a subscription expires

    (
    Canadian user since '92, STILL using QM2007)
  • Unknown
    Unknown Member
    edited May 2017
    gmalis1 said:

    Just an FYI...I contacted Quicken Support Chat just now and requested a copy of Quicken Mac 2007 v 16.1 and above after telling them I had QM 2007 that was incompatible with my copy of Sierra.

    The agent told me that it is no longer available on their servers and wouldn't provide it to me.  They stated I would have to purchase Quicken Mac 2017.  

    So...if you're thinking about getting a copy of Lion compatible QM 2007, good luck with support on that.  

    I should try again.  I have little credence in believing anything that Quicken support personnel has to offer...aside from reading from a scripted flow chart response sheet.

    I'll try again in the next few days...see what happens and I'll post back here with the results. 
  • smayer97
    smayer97 SuperUser, Mac Beta, Canada Beta ✭✭✭✭✭
    edited May 2017
    gmalis1 said:

    Just an FYI...I contacted Quicken Support Chat just now and requested a copy of Quicken Mac 2007 v 16.1 and above after telling them I had QM 2007 that was incompatible with my copy of Sierra.

    The agent told me that it is no longer available on their servers and wouldn't provide it to me.  They stated I would have to purchase Quicken Mac 2017.  

    So...if you're thinking about getting a copy of Lion compatible QM 2007, good luck with support on that.  

    That would be great. Looking forward to your report back.
    Have Questions? Check out these FAQs:
    COMPLETE list of Product Ideas - Quicken for Mac to VOTE on

    Object to Quicken's business model, using up 25% of your screen?
    Add your vote here:
    Quicken should eliminate the LARGE Ad space when a subscription expires

    (
    Canadian user since '92, STILL using QM2007)
  • Unknown
    Unknown Member
    edited May 2017
    gmalis1 said:

    Just an FYI...I contacted Quicken Support Chat just now and requested a copy of Quicken Mac 2007 v 16.1 and above after telling them I had QM 2007 that was incompatible with my copy of Sierra.

    The agent told me that it is no longer available on their servers and wouldn't provide it to me.  They stated I would have to purchase Quicken Mac 2017.  

    So...if you're thinking about getting a copy of Lion compatible QM 2007, good luck with support on that.  

    Here's the chat I just had no more than five minutes ago:

    Jenny BMay 9, 2017, 6:53pm

    Alright. Here's the thing, Quicken Mac 2007 is not compatible with Sierra and in order for your to have Quicken on that new Mac OS, you have to purchase the latest version of Quicken which is the Quicken Mac 2017. No worries. I can provide you a $10 discount since you are upgrading from unsupported version

    And then when I told her that QM2007 v12.1 and higher IS supported in Sierra:

    Oh, Alright. I got confuse. Quicken Essentials is the version that is not compatible with Sierra. I'm sorry about that, As much as I'd love to help you have the download of Quicken Mac 2007, we no longer have that in our system because it is a sunset version and is not Supported. You can look for other retails tore if they still have the version that you want.


    So, there you have it.  No help whatsoever.  I'm going to try and load QM2007 on my wife's old MacBook and see if I can load it there and then update it.  Maybe yes...maybe not.  
  • smayer97
    smayer97 SuperUser, Mac Beta, Canada Beta ✭✭✭✭✭
    edited January 2019

    Are you getting the error that QM2007 cannot run on your computer? If so, this means you have the PPC version (v16.0.x) and not the LC compatible version (v16.1+). At this point, You have 2 choices: Buy Quicken 2017 for Mac or get the Quicken 2007 Lion Compatible version. I suggest that you first make sure that Quicken 2017 for Mac will meet your needs, since it is not an upgrade from QM2007 but rather from Quicken Essentials (which was re-written from the ground up, starting in 2010), so there are some features that are still not there e.g. loan amortization*, 2-line display, QuickMath, or are not as fully developed yet, e.g. Customized Reports, investment lot management, performance reports and stats (therefore some data may not carry over). You can start here:
    http://www.quicken.com/mac/compare

    *NOTE: Support for fixed rate loans has been announced but there is no announced timing for support for variable rate loans.

    Currently, the main advantages of QM2017 over QM2007 include the ability to sync cash, bank, and credit card accounts using Quicken Mobile for mobile devices (iOS and Android) and the ability to save receipts with transactions via computer or mobile device. There are a few other minor features that QM2007 does not have. Note that QM2017 is being supported until April 30, 2020 whereas it has been announced that security fixes have ceased for QM2007 since QM2017 is released...see http://www.quicken.com/support/update-quicken-mac-2007-support-policies-may-2016 yet online access will continue as long as the FI/Bank supports it and their security updates don't prevent it.

    You may want to review the List of Obstacles and Hindrances for Migrating from QM2007 or QWin to Quicken for MacAdd your vote to any features that are missing for you. Your VOTES matter!

    Be aware of data that will and will not carry forward: 
    https://www.quicken.com/support/what-data-gets-carried-over
    Then look at the updates since the original release here:
    https://www.quicken.com/support/quicken-2017-mac-release-notes
    Also read some of the Fixes and Improvements that are being released soon here:
    http://www.quicken.com/upcoming-product-fixes-and-improvements
    You will also want to look at a more detailed comparison done by a SuperUser which also identifies nuances not mentioned elsewhere (and read on for comments from other users too on that same discussion thread): 
    https://getsatisfaction.com/quickencommunity/topics/can-anyone-who-has-switched-from-2007-to-2015-he...
    Take a look at the following videos to give you a better idea:
    https://www.youtube.com/user/QuickenMac

    If you find that QM2017 does not meet your needs, the alternative is to obtain and run QM2007 Lion Compatible (LC), which will run on Mac OS X 10.6.8 to 10.12 Sierra (so far) by contacting Quicken support here: http://www.quicken.com/contact-support

    NOTE: If you purchase QM2017, you can get QM2007 for free by contacting support. Just select QM2017 support. Some of the cheapest places to purchase it are places like Amazon.

    (If you find this reply helpful, please be sure to click "Like", so others will know, thanks.)
    you have

    Just discovered that the link above to the "List of Obstacles and Hindrances for Migrating from QM2007 or QWin..." was broken. It is now fixed.
    Have Questions? Check out these FAQs:
    COMPLETE list of Product Ideas - Quicken for Mac to VOTE on

    Object to Quicken's business model, using up 25% of your screen?
    Add your vote here:
    Quicken should eliminate the LARGE Ad space when a subscription expires

    (
    Canadian user since '92, STILL using QM2007)
Sign In or Register to comment.