Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Quicken Premier Version R 6:12 Build:27.1.6.12

Neal
Neal Member ✭✭
edited December 2018 in Investing (Windows)
For some time now I have had issues with the Portfolio X-Ray in opening this feature. I have received the same error message as follows: "Invalid User ID\u003cbr/\u003eError in decrypting the UserID - Auth Token not found\u003cbr/\u003eCannot Authernticate - User not found". My version is Quicken Primier Version R6:12 build 27.1.6.12.

Comments

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited October 2018
    If you haven't already, I suggest that you reset X-Ray:  exit Quicken, set the variable ResetXRay to 1 in the Xray.INI file located within the hidden \ProgramData folder, start Quicken and select Get Started in the Portfolio X-Ray views on the Investing tab.
  • Neal
    Neal Member ✭✭
    edited March 2018
    I have not been able to locate the hidden \Programdata folder in my quicken folder; searched both Quicken and subfolder under quicken, after changing the search to locate hidden files.  Can you provide a path to the folder?
  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited September 2018

    This error occurs
    when you created your XRay under one Quicken ID, then changed to a different
    Quicken ID in your file (Edit > Preferences > Quicken ID, Mobile &
    Alerts). 

    You can reset this
    manually, if you don't want to change back to the original Quicken ID:

    1. With Quicken closed, use
      Windows File Explorer and go to

      C:\ProgramData\Quicken\Inet\Common\Localweb\Xray or

      C:\ProgramData\Intuit\Quicken\Inet\Common\Localweb\Xray depending on
      your Quicken version
    2. Double-click XRay.INI to open it with Notepad
    3. Change ResetXRay=0 to ResetXRay=1 and Save the change (Ctrl + S)
    4. Open Quicken and go to the
      Investing tab to select XRay and click Get Started button.

    (the above was posted by Quicken
    Tamara in an older message thread here in the Community)

  • Neal
    Neal Member ✭✭
    edited October 2018
    I had to change my email address last year and have confirmed that it is correct in Quicken as well as my Account. The data that is in the XRay.ini is FirstAfterInstall=0 and LastTimeWasInvalid=0, which have I have changed both as well as each and neither changes have worked.  Both statements were changed back to "0" when I reopened Quicken.  The statement "ResetXRay" is not listed in this file.  This file was originally set up on 10/17/2017; not sure if that has any bearing on this issue.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited March 2018
    Neal said:

    I had to change my email address last year and have confirmed that it is correct in Quicken as well as my Account. The data that is in the XRay.ini is FirstAfterInstall=0 and LastTimeWasInvalid=0, which have I have changed both as well as each and neither changes have worked.  Both statements were changed back to "0" when I reopened Quicken.  The statement "ResetXRay" is not listed in this file.  This file was originally set up on 10/17/2017; not sure if that has any bearing on this issue.

    If resetting the Quicken ID did not work, I would try adding the assignment to ResetXRay I suggested earlier.  

    If the issue persists, I suggest you perform a clean uninstall, install and update.  If you haven’t already, you may want to review: https://www.quicken.com/support/using-qcleanui-uninstall-quicken. To update Quicken, I recommend that you download and apply the Mondo Patch: https://www.quicken.com/support/patching-updates-windows
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited November 2018
    Neal,

    I think the trick is when you edit XRay.ini file, if the ResetXRay line is not present, add ResetXRay=1 to the file, save it, then open Quicken and see if that solves your problem.
    QWin Premier subscription
  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited September 2018

    Just for reference ... this is what it looks like on my machine:

    image

  • Neal
    Neal Member ✭✭
    edited September 2018
    I have added the RestXRay=1, as the second and fourth lines, saved, and reopened Quicken, selected Investing, then refresh XRay, the open page came up, selected "get start", which opened up the agreement, selected approve and depressed the continue button, and received the same error code as before.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited March 2018
    Neal said:

    I have added the RestXRay=1, as the second and fourth lines, saved, and reopened Quicken, selected Investing, then refresh XRay, the open page came up, selected "get start", which opened up the agreement, selected approve and depressed the continue button, and received the same error code as before.

    Ummm, you said "I have added the RestXRay=1"

    Is that just a typo in your post or did you really spell that incorrectly in the INI file?

    ResetXRay=1              Reset..., not Rest...

    Did you leave all the remaining lines unchanged, whatever they were originally?

  • Neal
    Neal Member ✭✭
    edited March 2018
    Most likely a typo at that time.  This is what I have done since yesterday:
    Twice removed and reinstalled Quicken 2018 from disc received last year, (file dated 8/27), as well as twice removed and reinstalled Quicken from my account on line, (file dated 10/17).  With all installations the XRay.ini file was not loaded in the XRay folder, at which time I added the line ResetXRay=1, and in all of the restarts the line was changed to "0". I made no other changes to the file.  Each time when I reopened the program, I could get to the legal page and after that it gave me the same error. I do have a 2017 disc, which I could install under a new folder name, but I am not sure if that would further cause problems.  Also, because each time I could get to the legal page, and the problem after that gave me the error, it sounds to me that the error is caused by another file in a different folder/file, therefore not sure if reinstalling 2017 would help.
  • Unknown
    Unknown Member
    edited July 2018
    Neal said:

    I have added the RestXRay=1, as the second and fourth lines, saved, and reopened Quicken, selected Investing, then refresh XRay, the open page came up, selected "get start", which opened up the agreement, selected approve and depressed the continue button, and received the same error code as before.

    This exact thing happened to me. I added the resetxray=1 got the get started screen and still had the error code. 
  • Unknown
    Unknown Member
    edited September 2018
    Anything else I can try to get this xray working? I am having the exact same issue as Neail and I did not have a type mistake. This is very frustrating 

  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited July 2018
    Khalil said:

    Anything else I can try to get this xray working? I am having the exact same issue as Neail and I did not have a type mistake. This is very frustrating 

    Assuming that your Quicken software is installed and updated to the latest available patch release level ...

    If you haven't done
    so already, I'd say it's time to contact Quicken Support via Chat or Phone and
    request help.

    Quicken Support:

    • To contact Quicken Support,
      please use this link only:

       https://www.quicken.com/support#contact-support  and select Chat or Phone support
    • If you have purchased Premium
      Support (separately or included as part of your subscription to Quicken
      2018 Premier or above) call the number that can be found at the top of the
      My Account page at https://www.quicken.com/my-account  (US) or https://www.quicken.com/canada/my-account (Canada) next to
      "Quicken Premium Support" 
      when you log in with your Quicken ID.
    • Other links or phone numbers
      found elsewhere on the Internet, even in some posts here in the Community,
      may not be from Quicken or may not be up-to-date. Use those at your own
      risk.
    • Unlike other so-called
      "Quicken support providers", this Quicken Support is free for
      supported versions.

This discussion has been closed.