Home Quicken for Windows Business and Rental Property Tools (Windows)
Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Emailing Invoice Not Sending

I just upgraded (?) to Quicken HBRP 2018. When I attempt to email an invoice, the process proceeds as it should, finishing by telling me that the email was sent. IT WASN'T. No email arrives anywhere. I've attempted sending it to myself, nothing comes in. 

Comments

  • ScooterlamScooterlam SuperUser ✭✭✭✭✭
    edited August 2018
    Hi, 

    Same issue here.   Same as you describe.  I also had an issue with emailing reports (same behaviour).   https://getsatisfaction.com/quickencommunity/topics/email-reports-in-qw-is-it-working
    Sadly, this email was closed with no comments.

    Are you able to send a report via email?  I suspect you will be unable to do that as well.

    Scott
    2018 QW HBR r7.5
  • Quicken_TykaQuicken_Tyka Moderator mod
    edited July 2018
    Hey Phineas,

    Sorry to hear that you are unable to send an invoice.

    Try the steps at https://getsatisfaction.com/quickencommunity/topics/problem-emailing-invoices-in-new-version-of-quic....

    Let me know how it goes!

    -Quicken Tyka
    ~~~***~~~
  • UnknownUnknown Member
    edited April 2018
    Been there, done that. No luck. The PDF printer is working fine, I can generate a PDF of the invoice. It just doesn't send it anywhere. How is the email function working now? Is it using a Quicken email server instead of the mail client on the computer?
  • mshigginsmshiggins SuperUser ✭✭✭✭✭
    edited April 2018
    From C. D. Bales:



    I have no problem emailing invoices to myself using Q2018 R7.5.



    I think you'll need to look for more information to submit here that will help explain your problem.



    [FYI: The fact that the invoice did not "arrive", does not mean that it was not "sent".]
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • UnknownUnknown Member
    edited October 2018
    I'm glad that you have no problems, but that's not exactly helpful to me. I came HERE looking for more information, where would you suggest I look? I'm running Windows 10 v. 1709, Q2018 R 7.5. I have described the problem in its entirety. There are no error messages. Are there log files I can examine? Settings somewhere I haven't found? What is the address of the email server that is being used? I have "sent" invoices to 3 clients and myself, some multiple times. None of them were received by the intended recipient. Not in the Inbox, not in the Spam folder, not in the Trash, just not there.There appears to be no "sent" folder (or any other folders) in Quicken to check to assist in further troubleshooting.

    I've been using this function for over a decade. This is the first time I've been unable to get it working.  Since it appears that it no longer uses the mail client (Outlook 2007 in my case), how does it work? I can, of course, generate PDF invoices and attach them to emails, but that's a work-around, not an acceptable solution. If I sound irritated, it's because I am. I didn't find out there was a problem until I called the clients to find out why the invoices hadn't been paid. I was forced to "upgrade" against my will and better judgement. Now I've lost functionality I need and gained nothing.
  • NotACPANotACPA SuperUser, Windows Beta Beta
    edited April 2018

    I'm glad that you have no problems, but that's not exactly helpful to me. I came HERE looking for more information, where would you suggest I look? I'm running Windows 10 v. 1709, Q2018 R 7.5. I have described the problem in its entirety. There are no error messages. Are there log files I can examine? Settings somewhere I haven't found? What is the address of the email server that is being used? I have "sent" invoices to 3 clients and myself, some multiple times. None of them were received by the intended recipient. Not in the Inbox, not in the Spam folder, not in the Trash, just not there.There appears to be no "sent" folder (or any other folders) in Quicken to check to assist in further troubleshooting.

    I've been using this function for over a decade. This is the first time I've been unable to get it working.  Since it appears that it no longer uses the mail client (Outlook 2007 in my case), how does it work? I can, of course, generate PDF invoices and attach them to emails, but that's a work-around, not an acceptable solution. If I sound irritated, it's because I am. I didn't find out there was a problem until I called the clients to find out why the invoices hadn't been paid. I was forced to "upgrade" against my will and better judgement. Now I've lost functionality I need and gained nothing.

    Have you looked in BOTH your default email client AND in MS Outlook to see if the item is in the "Out Basket" (i.e., not actually sent) from one of them?

    And, I was able to email the Treasurer's report from within Q to our club's newsletter Editor without a problem.  So, I echo C.D. Bales' comment that the problem appears to be specific to your setup.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • UnknownUnknown Member
    edited April 2018

    I'm glad that you have no problems, but that's not exactly helpful to me. I came HERE looking for more information, where would you suggest I look? I'm running Windows 10 v. 1709, Q2018 R 7.5. I have described the problem in its entirety. There are no error messages. Are there log files I can examine? Settings somewhere I haven't found? What is the address of the email server that is being used? I have "sent" invoices to 3 clients and myself, some multiple times. None of them were received by the intended recipient. Not in the Inbox, not in the Spam folder, not in the Trash, just not there.There appears to be no "sent" folder (or any other folders) in Quicken to check to assist in further troubleshooting.

    I've been using this function for over a decade. This is the first time I've been unable to get it working.  Since it appears that it no longer uses the mail client (Outlook 2007 in my case), how does it work? I can, of course, generate PDF invoices and attach them to emails, but that's a work-around, not an acceptable solution. If I sound irritated, it's because I am. I didn't find out there was a problem until I called the clients to find out why the invoices hadn't been paid. I was forced to "upgrade" against my will and better judgement. Now I've lost functionality I need and gained nothing.

    Outlook IS my default mail client. There are no new emails in either the Outbox or the Sent folder. In previous versions of Quicken, when I sent the invoice, I would get a pop-up asking permission to access Outlook. After "sending" the email, I would have to open Outlook before the email would actually send. Otherwise, it would just sit in the Outbox until I opened Outlook. I changed my default mail client to the Mail app in Win10, there was no change in behavior.  It does not appear that this version of Quicken is using the mail client at all. Can anyone confirm if Q2018 uses the mail client or a dedicated mail server similar to QuickBooks? Would be nice if Tyka would check back in, or someone else from Quicken.

     
  • Greg_the_GeekGreg_the_Geek SuperUser, Windows Beta ✭✭✭✭✭
    edited April 2018
    I just tried emailing an invoice using Quicken 2018 R7.5 and had no problem. Do you get the "Email sent successfully" message? Quicken 2018 uses it's own SMTP (Simple Mail Transfer Program) similar to QuickBooks. What type of firewall software are you using?
    Quicken Subscription HBRP - Windows 10
  • UnknownUnknown Member
    edited April 2018
    Thank you for eliminating the email client as the culprit. Yes, I get the "Email sent successfully" message. Windows Defender firewall, default settings. I have just installed Q2018 on another computer with Windows 7. I am getting the same behavior. "Email sent successfully", but it never arrives.
  • Greg_the_GeekGreg_the_Geek SuperUser, Windows Beta ✭✭✭✭✭
    edited April 2018
    Who hosts your email? Have you tried changing the email address when sending the invoice?
    Quicken Subscription HBRP - Windows 10
  • ScooterlamScooterlam SuperUser ✭✭✭✭✭
    edited August 2018
    +1 Greg the Geek,

    I was having similar issues as OP - but also with sending reports.   I was using yahoo mail as my "from" address. Changing "from" address to my gmail account, I was successful in sending & receiving a report. As I recall, yahoo mail has, in the past for me, refused to relay mail in other applications.

    Quicken Moderator, I am only speaking for myself re: reports and not for OP....They may still have an issue with emailing invoices...

    Scott
    2018 QW r7.5
  • UnknownUnknown Member
    edited April 2018
    Scott said:

    +1 Greg the Geek,

    I was having similar issues as OP - but also with sending reports.   I was using yahoo mail as my "from" address. Changing "from" address to my gmail account, I was successful in sending & receiving a report. As I recall, yahoo mail has, in the past for me, refused to relay mail in other applications.

    Quicken Moderator, I am only speaking for myself re: reports and not for OP....They may still have an issue with emailing invoices...

    Scott
    2018 QW r7.5

    Interesting! That works. I switched the "from" to my gmail address and the email actually arrived at my inbox. I then tried my @sbcglobal.net and my @frontier.com addresses (which both utilize the Yahoo mail service) and they both worked. The Yahoo address that won't work is a free yahoo account, the other two are associated with paid accounts, cell and landline. 

    Mark this one solved.

    Thank you.
  • mshigginsmshiggins SuperUser ✭✭✭✭✭
    edited April 2018

    I'm glad that you have no problems, but that's not exactly helpful to me. I came HERE looking for more information, where would you suggest I look? I'm running Windows 10 v. 1709, Q2018 R 7.5. I have described the problem in its entirety. There are no error messages. Are there log files I can examine? Settings somewhere I haven't found? What is the address of the email server that is being used? I have "sent" invoices to 3 clients and myself, some multiple times. None of them were received by the intended recipient. Not in the Inbox, not in the Spam folder, not in the Trash, just not there.There appears to be no "sent" folder (or any other folders) in Quicken to check to assist in further troubleshooting.

    I've been using this function for over a decade. This is the first time I've been unable to get it working.  Since it appears that it no longer uses the mail client (Outlook 2007 in my case), how does it work? I can, of course, generate PDF invoices and attach them to emails, but that's a work-around, not an acceptable solution. If I sound irritated, it's because I am. I didn't find out there was a problem until I called the clients to find out why the invoices hadn't been paid. I was forced to "upgrade" against my will and better judgement. Now I've lost functionality I need and gained nothing.

    From C. D. Bales:


    https://www.quicken.com/support#windows
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
This discussion has been closed.