Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Price History Not Accounting for Past Split

Geobrick
Geobrick Member ✭✭
edited October 2018 in Investing (Windows)
I bought Visa several months after a split but the downloaded price history (prior to when I bought it) shows pre-split pricing. This has the effect of making the chart look like the stock took a dive on the day of the split and impacts the way the long term performance of the stock may be interpreted. 

While the data associated with time I've owned it is correct, I could easily (and wrongly) interpret the 5 year chart and conclude the stock is way below overall market performance over that same period. I don't know if Visa is the only stock impacted by this historical data issue.

I tried deleting all the pre-split historical data but when I updated the historical data, the prices came back without accounting for the March 18, 2015 4:1 split. So all historical prices are 4x too high. Any suggestions? Should I add the split into my register even if it happened before I ever bought the stock?

Comments

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited October 2018
    If you want the chart to include the split, I suggest you enter the split.  

    My understanding is the third-party quote provider Quicken uses is supposed to provide the split history with the price history but I can confirm this split is not provided.  If you haven't already, you may want to report the issue to Quicken support.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited September 2018
    When you pull up the Security Detail View and view the Price History graph, is there a checkmark at "Split adjust"?
  • Geobrick
    Geobrick Member ✭✭
    edited October 2018
    Thanks. I haven't reported the issue to Quicken Support yet. I'm willing to report it but I'm not sure how to do it through the link you provided. I see I can call or chat with support. Is that what you meant?

    Update: OK. No need to report this issue since selecting "Split Adjust" corrects the issue. Another 'User Error'. The price history still contains the pre-split numbers but the chart is now correct.
  • Geobrick
    Geobrick Member ✭✭
    edited June 2018
    UKR said:

    When you pull up the Security Detail View and view the Price History graph, is there a checkmark at "Split adjust"?

    No. It wasn't checked. Checking it corrects the chart. Thanks.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited June 2018
    Geobrick said:

    Thanks. I haven't reported the issue to Quicken Support yet. I'm willing to report it but I'm not sure how to do it through the link you provided. I see I can call or chat with support. Is that what you meant?

    Update: OK. No need to report this issue since selecting "Split Adjust" corrects the issue. Another 'User Error'. The price history still contains the pre-split numbers but the chart is now correct.

    Is that what you meant?
    Yes.
  • Geobrick
    Geobrick Member ✭✭
    edited June 2018
    Geobrick said:

    Thanks. I haven't reported the issue to Quicken Support yet. I'm willing to report it but I'm not sure how to do it through the link you provided. I see I can call or chat with support. Is that what you meant?

    Update: OK. No need to report this issue since selecting "Split Adjust" corrects the issue. Another 'User Error'. The price history still contains the pre-split numbers but the chart is now correct.

    Thanks. I'll remember that for next time.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited June 2018
    Geobrick said:

    Thanks. I haven't reported the issue to Quicken Support yet. I'm willing to report it but I'm not sure how to do it through the link you provided. I see I can call or chat with support. Is that what you meant?

    Update: OK. No need to report this issue since selecting "Split Adjust" corrects the issue. Another 'User Error'. The price history still contains the pre-split numbers but the chart is now correct.

    Selecting "Split Adjust" does not correct the issue unless the split is present.  I have confirmed the split is not being provided by third-party quote service.
  • Geobrick
    Geobrick Member ✭✭
    edited June 2018
    Geobrick said:

    Thanks. I haven't reported the issue to Quicken Support yet. I'm willing to report it but I'm not sure how to do it through the link you provided. I see I can call or chat with support. Is that what you meant?

    Update: OK. No need to report this issue since selecting "Split Adjust" corrects the issue. Another 'User Error'. The price history still contains the pre-split numbers but the chart is now correct.

    Selecting "Split Adjust" corrected the chart for me (but not the data on the 'edit price history' list). There are no splits shown in the transaction history for the security for any date (which would be correct since I bought the stock several months after the split). I'm not sure why selecting "Split Adjust" works for me. (I'm using Quicken 2017 Home and Business for Windows).
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    edited June 2018
    Geobrick said:

    Thanks. I haven't reported the issue to Quicken Support yet. I'm willing to report it but I'm not sure how to do it through the link you provided. I see I can call or chat with support. Is that what you meant?

    Update: OK. No need to report this issue since selecting "Split Adjust" corrects the issue. Another 'User Error'. The price history still contains the pre-split numbers but the chart is now correct.

    Based on my just done experiment ... 

    When I added Visa to a test account as a new security, the hidden split was not included in the data; the "split adjust" check box had no effect.  

    When I followed up on that with a Download Historical Prices request, the hidden split effect did come through; the "Split Adjust" checkbox had the desired and expected effect.  

    I refer to those as "hidden splits" because there is no way to see their presence other than through that Split Adjust box.  There is a data point being stored in the price history records, but no viewable record of it (unlike a visible StkSplt transaction in a transaction list).  At times there can be discontinuities on the dates associated with these hidden splits and the transaction list StkSplts.  Those discontinuities can lead to odd behaviors in the price charts.  FWIW
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited June 2018
    Geobrick said:

    Thanks. I haven't reported the issue to Quicken Support yet. I'm willing to report it but I'm not sure how to do it through the link you provided. I see I can call or chat with support. Is that what you meant?

    Update: OK. No need to report this issue since selecting "Split Adjust" corrects the issue. Another 'User Error'. The price history still contains the pre-split numbers but the chart is now correct.

    Confirmed.  The price history pulled when we add the security is missing the split but the split does appear if we explicitly Download Historical Prices.
  • Geobrick
    Geobrick Member ✭✭
    edited June 2018
    Geobrick said:

    Thanks. I haven't reported the issue to Quicken Support yet. I'm willing to report it but I'm not sure how to do it through the link you provided. I see I can call or chat with support. Is that what you meant?

    Update: OK. No need to report this issue since selecting "Split Adjust" corrects the issue. Another 'User Error'. The price history still contains the pre-split numbers but the chart is now correct.

    So that's probably why it worked in my case. 

    As I said in the initial post, I tried deleting the pre-split historical data in the price history then re-downloaded it to see if it would correct the problem. I can't know if the 'split adjust' selection would have worked before that because I wasn't aware of the 'split adjust' selection box until UKR pointed it out after I already re-downloaded the price history.
This discussion has been closed.