Unable to mass edit

Since the last update, I've not been able to mass edit transactions. It doesn't matter what field I try to change. I know how to do it. I've done it many times. So this is not a "How do I" question. Like I said, it was fine before the update. I've had no error messages. I click the "Replace All" button and nothing happens

Thanks

Comments

  • Unknown
    Unknown Member
    edited October 2018
    Unless you give the exact steps to reproduce the problem you are seeing, it is highly unlikely that there is anything anyone (including the Quicken developers to fix a problem) can do.
  • Unknown
    Unknown Member
    edited October 2018
    P.S.  You also need to give the details on what version of Quicken you are using.
  • Unknown
    Unknown Member
    edited September 2018
    OK, first time on here. I'll update in a minute. Thanks

  • Quicken Alex
    Quicken Alex Moderator ✭✭✭
    edited May 2020

    OK, first time on here. I'll update in a minute. Thanks

    Hello Kenneth,

    Welcome to our Quicken Community! It might help to review this conversation (including the comments/replies): https://getsatisfaction.com/quickencommunity/topics/add-your-quicken-information-to-your-posts

    Please also be as detailed as possible in your description, and remember a picture's worth a thousand words (but also be sure to edit out any personal identifying information, for your privacy and security)!

    Hope this helps!
    Alex
  • Unknown
    Unknown Member
    edited October 2018
    Year: 2018
    Version: R12.15
    Build: 27.1.12.15

    1. I select a range by clicking one transaction, hold "Shift", click another transaction.
    2. Now they're all highlighted.
    3. I right click on one and select "Edit Transaction(s)".
    4. I pick which field I want Replaced. 
    5. I type what I want it changed to. 
    6. I then click "Replace All"
    7. Absolutely nothing happens. I've tried all fields.
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    edited May 2020

    Year: 2018
    Version: R12.15
    Build: 27.1.12.15

    1. I select a range by clicking one transaction, hold "Shift", click another transaction.
    2. Now they're all highlighted.
    3. I right click on one and select "Edit Transaction(s)".
    4. I pick which field I want Replaced. 
    5. I type what I want it changed to. 
    6. I then click "Replace All"
    7. Absolutely nothing happens. I've tried all fields.
    When you click Edit Transactions, are you getting the "Find and Replace" Dialog box?

    Are you clicking the "Select" checkbox to the right of each transaction in that dialog?
    Q user since DOS version 5
    Now running Quicken Windows Subscription, Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • splasher
    splasher SuperUser ✭✭✭✭
    edited October 2018
    IIRC, in the past you did not have to select the checkboxes (Select column) at the left to do a find & replace, but they have evidently changed that condition.

    My first attempt (with boxes unchecked), nothing was changed, but if I clicked "Select All", it then changed them as expected.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • Unknown
    Unknown Member
    edited May 2020

    Year: 2018
    Version: R12.15
    Build: 27.1.12.15

    1. I select a range by clicking one transaction, hold "Shift", click another transaction.
    2. Now they're all highlighted.
    3. I right click on one and select "Edit Transaction(s)".
    4. I pick which field I want Replaced. 
    5. I type what I want it changed to. 
    6. I then click "Replace All"
    7. Absolutely nothing happens. I've tried all fields.
    I see a missing step in your procedure.

    Between step 3 and 4 select, click Select All.

    The transactions are not selected by default after the "search".
  • Unknown
    Unknown Member
    edited May 2020

    IIRC, in the past you did not have to select the checkboxes (Select column) at the left to do a find & replace, but they have evidently changed that condition.

    My first attempt (with boxes unchecked), nothing was changed, but if I clicked "Select All", it then changed them as expected.

    I have used this method to change transactions so seldomly that I don't remember if they use to automatically select them or not in the past (it would make sense to do it in this case).
  • splasher
    splasher SuperUser ✭✭✭✭
    edited May 2020

    IIRC, in the past you did not have to select the checkboxes (Select column) at the left to do a find & replace, but they have evidently changed that condition.

    My first attempt (with boxes unchecked), nothing was changed, but if I clicked "Select All", it then changed them as expected.

    Just confirmed this in QW2016, if you follow the OP's steps (not making any selections), the replacement happens to the whole group that was selected in the register.

    It would appear, Dev has changed this process to abide by the Selection column, which it probably should have from the beginning.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • Unknown
    Unknown Member
    edited May 2020

    IIRC, in the past you did not have to select the checkboxes (Select column) at the left to do a find & replace, but they have evidently changed that condition.

    My first attempt (with boxes unchecked), nothing was changed, but if I clicked "Select All", it then changed them as expected.

    I think they should abide by the Selection column, but given that came there through selecting those very same transactions, they probably should have made to a "Select All" as part of this flow.
  • splasher
    splasher SuperUser ✭✭✭✭
    edited May 2020

    IIRC, in the past you did not have to select the checkboxes (Select column) at the left to do a find & replace, but they have evidently changed that condition.

    My first attempt (with boxes unchecked), nothing was changed, but if I clicked "Select All", it then changed them as expected.

    I always thought it odd that the column was not adhered to and it should (IMO) start off with all of them selected as you suggest.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • joe kane
    joe kane Member ✭✭✭✭
    edited May 2020

    IIRC, in the past you did not have to select the checkboxes (Select column) at the left to do a find & replace, but they have evidently changed that condition.

    My first attempt (with boxes unchecked), nothing was changed, but if I clicked "Select All", it then changed them as expected.

    That said, it just makes the case for detailed release notes, and not just high level fly overs.  This is especially true any time the user interface is changed (even if its fixing a bug) that changes the way something works. 
  • Unknown
    Unknown Member
    edited May 2020

    Year: 2018
    Version: R12.15
    Build: 27.1.12.15

    1. I select a range by clicking one transaction, hold "Shift", click another transaction.
    2. Now they're all highlighted.
    3. I right click on one and select "Edit Transaction(s)".
    4. I pick which field I want Replaced. 
    5. I type what I want it changed to. 
    6. I then click "Replace All"
    7. Absolutely nothing happens. I've tried all fields.
    Well damn!! I've never had to do that before. Is it new, or was I doing it subconsciously? That definitely worked. Thank you. I feel stupid now. Ugh..Thank you very much!!
  • splasher
    splasher SuperUser ✭✭✭✭
    edited May 2020

    Year: 2018
    Version: R12.15
    Build: 27.1.12.15

    1. I select a range by clicking one transaction, hold "Shift", click another transaction.
    2. Now they're all highlighted.
    3. I right click on one and select "Edit Transaction(s)".
    4. I pick which field I want Replaced. 
    5. I type what I want it changed to. 
    6. I then click "Replace All"
    7. Absolutely nothing happens. I've tried all fields.
    Don't feel stupid.  In 2016, when you went to the Find and Replace screen, the boxes were unchecked, BUT Quicken acted like they were checked.  Quicken just changed it to work as it should, nothing you did wrong.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • Unknown
    Unknown Member
    edited May 2020

    Year: 2018
    Version: R12.15
    Build: 27.1.12.15

    1. I select a range by clicking one transaction, hold "Shift", click another transaction.
    2. Now they're all highlighted.
    3. I right click on one and select "Edit Transaction(s)".
    4. I pick which field I want Replaced. 
    5. I type what I want it changed to. 
    6. I then click "Replace All"
    7. Absolutely nothing happens. I've tried all fields.
    BTW the reason why I caught it so fast is because most of my mass edits have usually been by using Find and Replace, which also doesn't set the checked flag, but also never would do anything unless you checked them.  So I was use to doing Select All.

    So when I first did the mass edit using the selecting from the register, and saw nothing checked, it didn't occur to me that it would work like they were selected.
    So I automatically hit Select All.

    I have always thought that in Find/Replace should have selected them all by default, and certainly should be doing it when coming from a register select.
  • Unknown
    Unknown Member
    edited May 2020

    Year: 2018
    Version: R12.15
    Build: 27.1.12.15

    1. I select a range by clicking one transaction, hold "Shift", click another transaction.
    2. Now they're all highlighted.
    3. I right click on one and select "Edit Transaction(s)".
    4. I pick which field I want Replaced. 
    5. I type what I want it changed to. 
    6. I then click "Replace All"
    7. Absolutely nothing happens. I've tried all fields.
    I work on computers a lot and it never dawned on me to select all. A little embarrassing. Like when I accidentally got on a ladder near my ceiling fan. Did you guys know that you're supposed to turn them off when you get close? Yeah, that kind of hurt, lol. Great community here. I'm very impressed. Thanks to everyone!
This discussion has been closed.