How to get the "Remove Memorized Payees not used in X months" feature to work?

I'm running Quicken for Windows 2016. Want to get my Memorized Payees cleaned up and pared to the most used payees so that it will work better for me. 
So I've been trying the feature:
Edit>Preferences>Data Entry and Quickfill > "Remove memorized payees not used in the last <10> months".
Then I click OK and then close and reopen Quicken. And nothing has changed with my Memorized Payee List.
Anyone have any tips on how to get this to work?

Comments

  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited October 2018
    Go back into Preferences and look for the "Remove memorize payees" option setting.
    Is there a checkmark in the box to the left of this option setting? If not, click the box to put a checkmark in it.
  • Unknown
    Unknown Member
    edited May 2020

    Go back into Preferences and look for the "Remove memorize payees" option setting.
    Is there a checkmark in the box to the left of this option setting? If not, click the box to put a checkmark in it.

    Hi UKR - thanks for your quick reply.
    Yes, when I go to Edit>Preferences>Data Entry and Quickfill, 
    There is a checkmark in front of: Remove memorized payees not used in the last <10> months.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited May 2020

    Go back into Preferences and look for the "Remove memorize payees" option setting.
    Is there a checkmark in the box to the left of this option setting? If not, click the box to put a checkmark in it.

    Please tell us more. What makes you think that the function does not work?
    How many entries do you have in your list? Can you show us a screen snapshot of the File Information window?
  • Unknown
    Unknown Member
    edited May 2020

    Go back into Preferences and look for the "Remove memorize payees" option setting.
    Is there a checkmark in the box to the left of this option setting? If not, click the box to put a checkmark in it.

    What makes me think the function does not work is that I click the checkbox mentioned above (to only keep the last 10 months worth), and then click OK. And then for good measure close and reopen Quicken. And the Memorized Payee list hasn't changed. 
    How many entries do I have in my list? I can not see a way find out. I had a lot this morning. I've deleted about 500 today (by selecting a group and then deleting them).
    Can I show you a screen snapshot of the File Information window. Yes, absolutely. I'm very good with screen snapshots, I work in the software industry, but where is the File Information window?
  • Unknown
    Unknown Member
    edited May 2020

    Go back into Preferences and look for the "Remove memorize payees" option setting.
    Is there a checkmark in the box to the left of this option setting? If not, click the box to put a checkmark in it.

    OK, I have about 1700 entries. (I did a print preview, it's 47 pages worth at 38 payees per page.)
  • splasher
    splasher SuperUser ✭✭✭✭
    edited May 2020

    Go back into Preferences and look for the "Remove memorize payees" option setting.
    Is there a checkmark in the box to the left of this option setting? If not, click the box to put a checkmark in it.

    Hold down CTRL while clicking About Quicken on the Help menu to display the stats on your data file.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited May 2020

    Go back into Preferences and look for the "Remove memorize payees" option setting.
    Is there a checkmark in the box to the left of this option setting? If not, click the box to put a checkmark in it.

    File Information comes up when you click Help, then Shift-click About Quicken.

    How about:

    Rebuild MPL

    After creating a
    backup of your Quicken data file ...

    To rebuild the Memorized Payee List from existing transactions, click Tools,
    hold down Shift and CTRL, then click Memorized Payee List.

  • Unknown
    Unknown Member
    edited May 2020

    Go back into Preferences and look for the "Remove memorize payees" option setting.
    Is there a checkmark in the box to the left of this option setting? If not, click the box to put a checkmark in it.

    image
    Here is my Quicken File Info...
  • Unknown
    Unknown Member
    edited October 2018
    I was just playing with this and I might have an idea of what the problem is.

    It seems that if you lock a payee, it will not be deleted.
    Mine is set to delete older than 13 months:


    Now I unlocked a few, closed and reopened the Memorized Payee List.


    BTW you can sort by the Last Used column, and select multiple payees and delete them to clean them up manually.
  • Unknown
    Unknown Member
    edited May 2020

    I was just playing with this and I might have an idea of what the problem is.

    It seems that if you lock a payee, it will not be deleted.
    Mine is set to delete older than 13 months:


    Now I unlocked a few, closed and reopened the Memorized Payee List.


    BTW you can sort by the Last Used column, and select multiple payees and delete them to clean them up manually.

    Hi QPW - thank you for the suggestion. However, my Memorized Payee List has the same columns as you, from left to right, up until "Amount". Mine ends there, I don't have the 3 columns you have to the right of amount. I'm running Quicken 2016 deluxe. I did go into several of my actual Payees, and they are not locked. I don't think I have any locked (at least, I've never locked any).
  • Unknown
    Unknown Member
    edited May 2020

    Go back into Preferences and look for the "Remove memorize payees" option setting.
    Is there a checkmark in the box to the left of this option setting? If not, click the box to put a checkmark in it.

    UKR - thanks for all your help and suggestions. I'll likely try to rebuild the MPL tomorrow. Do the stats above lead you to think my file size, or number of Memorized Payees could be the problem?
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    edited May 2020

    I was just playing with this and I might have an idea of what the problem is.

    It seems that if you lock a payee, it will not be deleted.
    Mine is set to delete older than 13 months:


    Now I unlocked a few, closed and reopened the Memorized Payee List.


    BTW you can sort by the Last Used column, and select multiple payees and delete them to clean them up manually.

    Try narrowing the TAG and Memo columns in the MPL by moving the cursor over the lines adjacent to those columns until it turns into a LEFT-RIGHT arrow icon, then slide that divider to the left to narrow the column.

    Did the missing 3 right columns become visible?

    ALSO, it's possible that you've used 1613 payees in the last 10 months.  Have you tried reducing the number of months to, say, 6?
    Q user since DOS version 5
    Now running Quicken Windows Subscription, Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • Unknown
    Unknown Member
    edited May 2020

    I was just playing with this and I might have an idea of what the problem is.

    It seems that if you lock a payee, it will not be deleted.
    Mine is set to delete older than 13 months:


    Now I unlocked a few, closed and reopened the Memorized Payee List.


    BTW you can sort by the Last Used column, and select multiple payees and delete them to clean them up manually.

    The lock column isn't displayed by default, select the Options button to turn it on.
  • Unknown
    Unknown Member
    edited May 2020

    I was just playing with this and I might have an idea of what the problem is.

    It seems that if you lock a payee, it will not be deleted.
    Mine is set to delete older than 13 months:


    Now I unlocked a few, closed and reopened the Memorized Payee List.


    BTW you can sort by the Last Used column, and select multiple payees and delete them to clean them up manually.

    I just checked the Memorized Payee List on Quicken 2017, and it does have the lock column, so I believe that Quicken 2017 will have it too.

    But I notice the the "Last Used" column was added in the subscription version of Quicken (2018/2019)
  • Unknown
    Unknown Member
    edited May 2020

    I was just playing with this and I might have an idea of what the problem is.

    It seems that if you lock a payee, it will not be deleted.
    Mine is set to delete older than 13 months:


    Now I unlocked a few, closed and reopened the Memorized Payee List.


    BTW you can sort by the Last Used column, and select multiple payees and delete them to clean them up manually.

    Typo there, of course I meant that I believe Quicken 2016 will have it too.
  • Unknown
    Unknown Member
    edited May 2020

    I was just playing with this and I might have an idea of what the problem is.

    It seems that if you lock a payee, it will not be deleted.
    Mine is set to delete older than 13 months:


    Now I unlocked a few, closed and reopened the Memorized Payee List.


    BTW you can sort by the Last Used column, and select multiple payees and delete them to clean them up manually.

    Hi - Thanks to all who are coming up with suggestions. Very appreciated.
    I found how to display the lock column and only about 10 of my Memorized Payee List was locked. I also tried reducing the number of months to 4, that didn't work either.
    I have not added 1613 payees in the last 10 months - just not that many transactions. My payees are built up over close to 20 years. For example, I see some vendors in there that I used once 18 years ago.
    I can't narrow the Tag or Memo column - seems like my version doesn't allow that (I use Excel all the time, so I'm pretty darn sure I'm attempting to narrow the columns correctly - my cursor turns to a hand and I don't get the LEFT-RIGHT arrow icon.
    At this point, I think my options are: either sort by category and delete large groups manually, or try the rebuild the MPL steps. 
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited May 2020

    I was just playing with this and I might have an idea of what the problem is.

    It seems that if you lock a payee, it will not be deleted.
    Mine is set to delete older than 13 months:


    Now I unlocked a few, closed and reopened the Memorized Payee List.


    BTW you can sort by the Last Used column, and select multiple payees and delete them to clean them up manually.

    Maybe you have some data corruption preventing the clean up. Might be worth taking a backup, then validate your data.


    File | File Operations | Validate & Repair: Validate
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Unknown
    Unknown Member
    edited May 2020

    I was just playing with this and I might have an idea of what the problem is.

    It seems that if you lock a payee, it will not be deleted.
    Mine is set to delete older than 13 months:


    Now I unlocked a few, closed and reopened the Memorized Payee List.


    BTW you can sort by the Last Used column, and select multiple payees and delete them to clean them up manually.

    Try the rebuild steps for the MPL.  It really shouldn't hurt anything.
    I actually tried it, but it changed nothing for me.  If it really messed up something you can go to a backup, and you will know that there is some kind of problem.

    And who knows maybe it will fix the problem.
  • Unknown
    Unknown Member
    edited May 2020

    I was just playing with this and I might have an idea of what the problem is.

    It seems that if you lock a payee, it will not be deleted.
    Mine is set to delete older than 13 months:


    Now I unlocked a few, closed and reopened the Memorized Payee List.


    BTW you can sort by the Last Used column, and select multiple payees and delete them to clean them up manually.

    Hi - so I did the rebuild of the MPL. With the result that it has auto-locked all of my Memorized Payees! Thus making sure that the Delete Payees older than a certain month certainly won't work. Sigh...I'm thinking next I may just delete them all and start over...
  • Unknown
    Unknown Member
    edited May 2020

    I was just playing with this and I might have an idea of what the problem is.

    It seems that if you lock a payee, it will not be deleted.
    Mine is set to delete older than 13 months:


    Now I unlocked a few, closed and reopened the Memorized Payee List.


    BTW you can sort by the Last Used column, and select multiple payees and delete them to clean them up manually.

    You can unlock them all at once by selecting the first payee, going to the last payee and holding down the shift and selecting the last payee.  Then just right click to get the menu for unlocking them.
  • Unknown
    Unknown Member
    edited May 2020

    I was just playing with this and I might have an idea of what the problem is.

    It seems that if you lock a payee, it will not be deleted.
    Mine is set to delete older than 13 months:


    Now I unlocked a few, closed and reopened the Memorized Payee List.


    BTW you can sort by the Last Used column, and select multiple payees and delete them to clean them up manually.

    Thanks - I wondered if there was a way. I just did that.  Selected them all, found the menu, and unchecked "Lock". And Quicken processed for a while, and then removed every single Memorized Payee!!! Are you kidding me, Quicken!?!!
    (No worries about that - I just rebuilt it, but I had decided to just start fresh anyway and now I know another quick way to delete all of them!!! :-)
  • Unknown
    Unknown Member
    edited May 2020

    I was just playing with this and I might have an idea of what the problem is.

    It seems that if you lock a payee, it will not be deleted.
    Mine is set to delete older than 13 months:


    Now I unlocked a few, closed and reopened the Memorized Payee List.


    BTW you can sort by the Last Used column, and select multiple payees and delete them to clean them up manually.

    Very strange!
  • Unknown
    Unknown Member
    edited May 2020

    I was just playing with this and I might have an idea of what the problem is.

    It seems that if you lock a payee, it will not be deleted.
    Mine is set to delete older than 13 months:


    Now I unlocked a few, closed and reopened the Memorized Payee List.


    BTW you can sort by the Last Used column, and select multiple payees and delete them to clean them up manually.

    I know! I was able to duplicate it. At any rate, my problem is solved - I have no more memorized payees at all!

    Thanks to everyone who worked through this with me. I learned a lot that will be useful for the future...
This discussion has been closed.