Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Setting categories for investment registers

I tried to add columns to my investment registers so I can categorize the transactions. The option isn't available in the pulldown and help says "This feature is available in non-investment registers only." So how do you get your investment transactions to show up in category reports? For example, my interest from IRA's is not showing up in my income on budgets.

Comments

  • Note, I did find one way. If I edit the transaction to put it in the Misc Income box than the Interest income box, it allows me to add a category. Is this the right way?
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    Post your Interest income, in ANY investment account using the "Enter Transactions" button at the top left of the account register.
    Same for any other Investment transaction.
    THEN, be sure to include _IntInc, _DivInc, etc (Q's pre-defined investment categories) in your budgets.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • Thanks. I assume you mean to include IntInc in a report. But I don't run reports, I just use the Spending tab to look at Income and Expenses. That tab seems to only use non-investment categories.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited September 2019
    Thanks. I assume you mean to include IntInc in a report. But I don't run reports, I just use the Spending tab to look at Income and Expenses. That tab seems to only use non-investment categories.
    Investment transactions use these built-in categories with the underscore prefix which are hidden by default. The Transactions view on the Spending tab may not be customized to include these built-in categories.
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    I'm confused.  In your initial post you said "So how do you get your investment transactions to show up in category reports? ", but now you're saying "I don't run reports".
    So, which is it?
    And, I can confirm (I just checked it out) that the Spending tab doesn't include Investment accounts ... UNLESS, the cash in a taxable brokerage account with the option "Show Cash in a Checking account" selected.  THAT checking account will be included.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • NotACPA Yes sorry, I mis-spoke. I think of the Spending tab as the same as a report; not sure why it doesn't behave the same way.
  • Sherlock Well that's too bad but at least I found the workaround above.
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    OR, you could try running a REAL report.  REPORTS, Spending, and then select from the various options.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • Not sure why you feel the need to be snarky. The fact is, there IS an Income pull-down on the Spending tab, and there is a reason that Spending tab exists. That interface is very useful for some things compared to a report. But I have trouble understanding why anyone would want their Income category to not include all their income? It's a valid question.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    About the Spending tab view:
    At the top of the view there are three filter fields:
    The first one on the left selects the accounts to include. If "All Accounts" is chosen, investment accounts are automatically included (no need for a linked cash account).
    The middle one selects the Date Range, default: Last 30 days
    The third filter selects the type of transactions to show:
    - Spending
    - Spending without taxes (default)
    - Income
    If, for example, I want to see properly recorded dividend or interest income transactions from my investment accounts, recorded within the last 30 days, then the filters must be set to
    [All accounts] [Last 30 days] [Income]
    As was suggested previously, some of these built-in categories (the ones with an _underscore like _DivInc or _IntInc) may have been created as hidden categories. Please go into Tools / Category List and locate these categories. Remove the "Hide" checkmark from the categories that you actually use.
  • Thanks. The hidden categories looked promising but it doesn't seem to work. I went to the _IntInc and changed it to not hidden, then I select All accounts for a day in which there is an interest transaction in an investment account, and it still doesn't appear.

    Here's what else I can say. I have IRA accounts that were set up as tax deferred IRA's and use an investment register. I also have IRA's that were set up as tax deferred savings accounts and have "normal" registers (not sure the technical term for that.) The Spending tab does include interest in the savings IRA's based on the category you assign. But it doesn't include interest in the "'investment" IRA's which automatically codes as the "_intinc" category. So while the category could be the issue, it seems more like investment accounts are being filtered as was suggested above. Perhaps unless that "show balance in checking" is checked as specified above which opens a whole other can of worms.

    I'm just puzzled why everyone wouldn't want ALL their income to show.
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    Not sure why you feel the need to be snarky.
    Not snarky.  Providing an option that does what you want NOW ... instead of waiting to see if Q's programmers EVER do what you want.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
This discussion has been closed.