Home Quicken for Windows Investing (Windows)

why does stock still show in portfolio after being sold?

I bought 100 shs of VTV on 12/31/2018
I sold all 100 shs of VTV on 03/18/2019
My portfolio still shows an entry for VTV, even though the position is zero. Why?

This is just the most recent example of this behavior.

For by far most of my positions, when I sell it completely (share count goes to zero), the position is no longer shown in the portfolio. That's as expected: when I no longer hold the stock, I don't expect it to show up in my portfolio (duh).

But for VTV, it still shows up in my portfolio with a zero share balance.

I used straight Buy and Sell transactions, and had only those two transactions.

Best Answer

Answers

  • NotACPANotACPA SuperUser ✭✭✭✭✭
    Try doing PORTFOLIO, click Options and then UNcheck "Show Closed Lots".
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • Jim_HarmanJim_Harman SuperUser ✭✭✭✭✭
    Just to check - if you select Options at the top right, is "Show closed lots" selected?

    Also to be sure there isn't something odd going on with rounding, try editing the Sold transaction so the "Sell all shares" option is selected.
    -- Jim QWin Premier subscription
  • NotACPANotACPA SuperUser ✭✭✭✭✭
    Just to check - if you select Options at the top right, is "Show closed lots" selected?

    Also to be sure there isn't something odd going on with rounding, try editing the Sold transaction so the "Sell all shares" option is selected.

    Great minds run in the same circles!

    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • Bur DavisBur Davis Member ✭✭
    edited January 11
    @NotACPA and @Jim_Harman, thanks for those suggestions, but no dice.

    a) Show Closed Lots was unchecked. I checked, then unchecked it, just for grins. Same thing (closed lot is still showing).
    b) I edited the Sell transaction and chose 'Sell All Shares' and that didn't help either.

    I guess I can try the workaround of hiding the security from the Security List if it bugs me too much (although I wonder whether that would have the unwanted side-effect of hiding the security when I'm viewing holdings from the period when I owned the position).

    Btw, I notice where this seems to happen fairly consistently is with options: I'll sell a put contract (SellShort), then buy to close (CvrShort), at which point the position is closed out, zero contracts held. But the closed lot still shows in the security list.

    Any other suggestions welcome...
  • Bur DavisBur Davis Member ✭✭
    Thanks for the suggestions, but:
    - I have tried deleting an re-entering. No luck.
    - There was no prior investment history with the security.
    - The Short Sale and the Cover are matched up in all cases.
  • JohnDeLoJohnDeLo Member
    In Portfolio, go to Options on right click "Customize Current View" then the "Securities" Tab. Uncheck the one you don't want to show.
  • Bur DavisBur Davis Member ✭✭
    Thanks, @JohnDeLo. This will work as long as I never intend to own that security again. I do wonder, though, why most securities with a zero position no longer show up in my portfolio automatically, while other securities with a zero position persist in being displayed?
Sign In or Register to comment.