Home Quicken for Mac Registers & Transactions (Mac)
Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Printed check numbers no longer increment to the next check number (Q Mac)

Steve SchifrinSteve Schifrin Member ✭✭
Quicken (Premier Subscription) for Mac 5.16.1: Since the last update, when printing checks, the next check number in the printing set-up no longer increments to the last printed check number +1. Any ideas how to fix this.

Best Answers

«1

Answers

  • Hello @Steve Schifrin

    Thank you for reaching out on the community and telling us about your issue. That is odd. Does it show up on the check or on the transaction in the register? Could you take a screen shot of the check screen as well so we can see if there's anything out of the ordinary? With a bit more we can see if we find anything out of the ordinary.

    Once you get a chance just report back here!

    Thanks,

    Quicken Francisco

     


  • John_in_NCJohn_in_NC SuperUser, Mac Beta Beta
    I am printing checks and do not see this.

    The +/- is used when manually entering a check transaction (not to be printed, as PRINT would be the check number in the latter case).

    And as far as I remember (and from what I see when testing with older versions of Quicken for Mac), the +/- never changed the Initial Check Number in the check printing setup. You typed in the first check number, and never had to mess with it again. (Then again, I am not jumping back and fourth between handwritten and printed checks in the same account.)

    Can you explain more of what you are seeing that isn't expected?
  • Steve SchifrinSteve Schifrin Member ✭✭
    Thank you both so much for your help. First, a point I neglected to mention -- I'm using pre-printed, pre-numbered Deluxe voucher checks for printing. I've attached the print screen from QMac, and there's plainly an warning icon near the check number that cautions about a duplicate check number. The noted check number was printed days ago, and has been corrected with each successive print job. Until this last update to QMac, this number used to increment by 1, in the case of a single-check print job, or by the number of checks printed. It now remains frozen as you see it.
    Maybe I should reset the odometer with the next printed check number?
  • John_in_NCJohn_in_NC SuperUser, Mac Beta Beta
    Thanks for the additional info, Steve.

    I use preprinted voucher checks as well, and I am familiar with that duplicate check number warning as shown in your screenshots; (I see that when I am testing files.) 

    You can try "resetting the odometer" as you mentioned, but haven't you been doing that already? (Or are you correcting the check number after each printed check?)

    Out of curiosity, if you go into the check writing account and create a new check, what happens when you + in the check number column?


  • Steve SchifrinSteve Schifrin Member ✭✭
    I went looking for a printing preference similar to older versions of Quicken, but couldn't find an odometer reset. I write checks from one checking account, and write them in the Check Register window, using Command-J. In that window, there is no check number, and in the Register, the check number is always PRINT until the Print Checks command is sent, a window comes up to list the checks to be printed -- no check number yet -- and on OK, a Preview of the voucher check comes up, with a writable area for the check number. That's where, up until last week, the next available new check number was displayed, highlighted. I now have to correct that number before printing the check, and the correct number will appear in the Register when printing is complete. I honestly don't write multiple checks that often, so I haven't found out if multiple checks increment that number properly. That's a good troubleshooting question, and I'll print some misc checks and see what happens. Thanks, John.
  • John_in_NCJohn_in_NC SuperUser, Mac Beta Beta
    The dialog you mention is the only way I know to "reset" the check number.

    If you are testing checks, you can always print the checks to PDF so that you don't waste consumables. Quicken will still see the checks as printed. (This is what I do for testing purposes.)

    I have seen occasional posts (as in 1 every few years) about a user who can't increment (manually entered) check numbers. But, they are so rare/posted with little info that it has been hard to ascertain if it truly is a bug or user error.
  • Steve SchifrinSteve Schifrin Member ✭✭
    John, continued thanks for your thoughts. Last night I dummied up three checks, printed them to blank paper after correcting the "next check number" in the print dialogue, and smacked my forehead, forgetting that it's the checks that are pre-printed with check numbers (Quicken doesn't print them), and the odometer number is solely for the purpose of keeping the check register in sync. I was surprised, however, to find that after a half-dozen single-check jobs, three checks moved the "next check number" up by three, and now seems correct. I'll verify that with some pre-printed checks, just to prove it out, as it's a small cost for correcting this issue. I'll report back if the proofing fails, but I think you nailed it, and I'm grateful.
  • John_in_NCJohn_in_NC SuperUser, Mac Beta Beta
    I am glad that (you hopefully) have gotten this working! Thanks for the update.
  • Jack AndersonJack Anderson Member ✭✭
    Under tools pull down to account list. Find the account used to write checks. Select edit & then select online services. At the bottom of the box that appears, deactivate online services. When you go to write checks, the reference to send online is gone. You do not need to continue unchecking the box to write a check.
  • Steve SchifrinSteve Schifrin Member ✭✭
    Thanks, Jack. I appreciate your thought. This problem referred specifically to printing pre-numbered voucher checks, and had no online implications except for the eventual auto-reconciliation (online, direct connect) of the account, which seems to have continued to work once the check number in the register were correct.
  • I am having the identical problem since the last update. My odometer is now 18 check numbers behind with the duplicate flag. I reset it, and the batch updates the register check numbers to agree with the pre-printed check numbers. The next time I print checks, the odometer has incremented by the number of checks I have printed but is still exactly 18 checks behind. I tried printing some dummy checks but if I delete those lines from the register, I'm back where I started. If it were only off a couple, maybe I wouldn't mind cluttering up my check register, but 18 is just too many to swallow. I wasted an hour "chatting" with a support person tonight and they finally concluded it was a software problem and that I should "report a problem" from the program link. I tried doing it 6 times and each time I got an error saying I wasn't connected to the internet (my 500Mb/s is working just fine), so I found my way here. I'm still amazed that calling tech support is a dead end if they determine it is a software bug. Why can't they file the report with the developers who can actually fix it? After spending a hour on the problem, they probably understand what needs to be done better than most casual users.
  • I just verified that 18 is the exact number of handwritten checks I've written on that account since I opened it in 2009. Interesting. But when I entered those checks the numbers were the numbers pre-printed on the pocket checks, not in the sequence of my computer pre-printed check stock.
  • Steve SchifrinSteve Schifrin Member ✭✭
    Hi, Richard. My problem printing pre-numbered voucher checks has returned, and the "next check" number is stuck on the same number as before. So, I go to print checks, correct the incorrect "next check" number, and load up the printer (making sure to resort the blanks, since the program has no facility for reverse-order printing, as it used to). If I write and print more checks in the same session, without quitting QMac, the "next check" number is correct. If I quit the program and restart it to write more checks, that number reverts back to its old stuck position. Now it's obvious that the numbers are incrementing correctly until the program quits, but that particular piece of information is not being updated when the program quits. Definitely a software bug, or a conflict with some other running software. -SS-
  • GypsyGuyGypsyGuy Member
    I am using Quicken for Mac (subscription) and am having the same issue with printing pre-numbered checks. The check counter has frozen at a check written several weeks ago and that's what is entered when I go to print the checks. I now must enter the correct check number. A fix for this would be so much appreciated.
  • Steve SchifrinSteve Schifrin Member ✭✭
    At least, when I preview the printing queue, there’s a place to update the starting check number, and the entries in the register will be correct.
  • John_in_NCJohn_in_NC SuperUser, Mac Beta Beta
    I am now seeing this in my file as well.

    I will submit a bug report.
  • Steve SchifrinSteve Schifrin Member ✭✭
    John, I printed a few checks this morning, and ran an immediate, full "last-modified date" search on the computer, and wasn't able to find a smoking gun file that could be where the application stores the check odometer. Have you tried uninstalling and re-installing the application? I haven't, but may just be dumb enough to give it a try...
  • John_in_NCJohn_in_NC SuperUser, Mac Beta Beta
    Reinstalling the app likely wouldn't help here as we all (in this thread) are seeing it :-)

    When I was testing/gathering creating screenshots for the bug report (which has been submitted), I noticed the counter works until you relaunch the program. Then it reverts. (It did this in a new file as well.)

    This is something the developers will have to address.
  • Steve SchifrinSteve Schifrin Member ✭✭
    Yes, I noticed that as well. Thank you.
  • I am having same problem. Please update to correct this problem. Odometer is hung on last check printed prior to most recent update!
  • FWIW, I have had the exact same problem for weeks. The Print dialog check number is stuck at #2608. If a manually fix it, the fix remains until I quit and relaunch Quicken. It the reverts to #2608. Nothing I try gets to a permanent fix. This never happened until recently. I am forced to conclude it is some newly introduced bug in the application or at least some settings/preferences error that I can't seem to fix.
  • Steve SchifrinSteve Schifrin Member ✭✭
    Thanks, Ted. And thanks for a very long history of Mac advice and columns. I think I've been "reading" you since my 128k Macintosh first smiled at me.
  • I am having exactly the same problem with the check number not updating. I have noticed that when I enter a check, go to print, correct the number, print it, and subsequently print more checks the numbering keeps up. As soon as I quit and re open Quicken the check number is stuck and goes back in the same number.
  • RCinNJRCinNJ Member ✭✭✭✭
    I have had this exact problem since 5.15.1. Got tired of resetting the check number (which works for short time) and found this post. Here are screen shots from 6/22 and 7/10 showing that QM reverted to Check number 687. On 6/22 the number should have been #695 and on 7/10 the number should have been #700. I never experienced this until QM version 5.16.
  • Richard@[email protected] Member ✭✭✭
    For the record and not to repeat everything that was documented above, I have had the same problem printing pre-printed check numbers since the upgrade to 5.16. I print so few manual checks that I just changed the check number each time without realizing that it was a bug. Thanks to all for the information - I hope it will be corrected.
  • R. BarreR. Barre Member ✭✭
    I'm having the exact same problem.
  • By the way, the check number increases correctly during an individual session. It only resets when the program is quit and re-opened. I am stuck at #12385 on restart.
  • BugSlayerBugSlayer Member
    Have the problem as described well by RCinNJ as well as others. Have been manually entering for some time but got stubborn and finally ended up here. Glad to see the problem has been reported. Apparently the storage area for check numbers is not being refreshed with the work area value because we are all at some old number?
  • SneffelsSneffels Member
    I have the same problem. Have to manually enter the correct "next" check numbers.
This discussion has been closed.