Do you use invoicing for your small business? We want your feedback! Learn More

Quicken cannot process date range (after adding new account)

After adding a new investment account with online download, quicken freezes at start-up and then exits with an error message "cannot process date range; enter new range". When I work with a back up that does not include this new account, quicken works just fine.

This new account is large. Has over 500 stocks (it is with an investment advisor who buys several stocks for very small positions). Is there a maximum in terms of number of securities an account can hold? I have also reduced the number of securities in my securities list tracked by quicken to below 2000 as needed.

I have sufficient hard disk space. My Ram is 8 GB. So not sure it is memory issues.

Windows 10s laptop with Quicken subscription service. I have done all the updates to latest version. I have reinstalled quicken.

I opened a new quicken file, with just this new account, and it is working fine. So it is an issue ONLY when I add this new account to my current data file. My current data file is over 200 GB/20 years of data. Maybe the issue is file size?

I have called Quicken help and they were not able to diagnose/fix the issue. Their recommendation was archive the current file and start with a new one.

My options are:
- continue with my current file without the new account. Track new account standalone in a separate file.
- Try in a high memory /spec computer (don't have one yet to try it)
- Any other suggestions?



  • Bala_home
    Bala_home Member ✭✭
    sorry typo above. My current data file is more than 200 MB (not GB!). Thanks.

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited October 2020
    If you haven't already, you may want to review:

    If you haven't already, I suggest you attempt a Copy and Validate as described in:
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Beyond the "fixed limits" I will say something about the performance of Quicken investment accounts.  It doesn't take kindly to a lot of securities and lots in an given account.  Most likely even if you don't run up against a limit the performance of that account will most likely be terrible.

    Also look at this part of the article that @Sherlock posted:
    Note: Once the limit has been reached, there is no way to decrease the limit count. 
    This is my website:
  • Bala_home
    Bala_home Member ✭✭
    Thank you @Chris_QPW and @Sherlock. Both of you were right.

    A copy and validate helped import the account; I had to break it down into 3 pieces to get it into the master file but did so without the previous error.

    But once I got everything in, the performance was so slow it was not worth it. So I will just keep this troublesome account as a one-off separate file and live with it. Thanks for the very helpful and quick advice!
This discussion has been closed.