Home Quicken for Mac Errors and Troubleshooting (Mac)
Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Setting Up Direct Connect with Suntrust Bank

It has a been a year since I started this journey and I still can't direct connect to Suntust Bank via Quicken. I have used Quicken for over 20 years and direct connect for about 10 years up until last year. I posted a previous thread but it was closed and never really got answered. As a note, I can get web connect or Quicken connect to work, but I don't have the two way directionality that is available through Direct Connect for bill pay, etc.

About a month ago, I started again on my journey to get this resolved, and here is where I am. Originally I used Quicken Home and Business for Windows on my Mac through a 3rd party emulator. I thought that may be my issue, so I converted my subscription to Quicken Premier for mac. While i have been disappointed in my transition to Premier for Mac, this still didn't resolve my issue. I reached out to my bank Suntrust, and they confirmed that I need a new online banking PIN (not just my regular web based log in info) to get Direct Connect to work. I received my online user name and PIN, and tried to setup my direct account work, but I still can't get it to work. So today, I spent 45 min on the phone with Suntrust and over 2 hours on the phone with Quicken (Ticket ID 8144636) with a big portion as a 3 way call. During the process the Quicken agent downloaded some of the Log files for review. In summary, I am no further along than when I started. Suntrust says that it is a Quicken issue. Quicken says that it is a Suntrust issue. I asked the Quicken agent repeatedly for escalation support, but i was never able to talk to anyone above his level. He stated that a manager would call me back, and that he would send me an email regarding scheduling a time...at this point I haven't received any additional information. I am very frustrated and disappointed with the entire situation, as I am paying both the Bank and Quicken for a service should be available but doesn't work.

So here is what I see when I try to set it up.

I select connection type

I select Suntrust Bank

I enter my online user ID and provided PIN, and then I get a pop up window to update my password.

So, I update the password and hit submit and then I get an error that my bank doesn't accept my information.

So from my perspective, it look as if the root cause is being triggered by this request for password update. Because the password is updated by this request, the submittal doesn't match the banks original expectation. Suntrust says that they are not initiating this request. I don't know how to overcome this issue, and according to both Suntrust and Quicken, neither do they.

I would appreciate any help and support to resolve this issue, as I have been unsuccessful up to this point.

Answers

  • BoatnmaniacBoatnmaniac SuperUser ✭✭✭✭
    This sounds very much like a similar issue connecting to SunTrust with Quicken for Windows.  When we get the prompt to enter a new PW, we can enter the PW we already have (do not create and enter a new one) and then Ctrl+Shift+Enter which then completes the set up process without the error message.  I don't know anything about Macs but if they have something like a Ctrl+Shift+Enter function capability you might want to give that a try.
    (QW Premier Subscription: R31.8 on Windows 10)
  • Chris_QPWChris_QPW Member ✭✭✭✭
    I wonder what Ctrl+Shift+Enter actually does.  The Quicken developers tend to use Ctrl+Shift and a "Easter egg" sequence for when they want to add some "hidden" functionality, for troubleshooting or bypassing certain operations.  It isn't anything that is built-in to Windows.  It is just the program looking for that sequence and doing something different.
    (I'm using the latest Quicken subscription version)
  • It won't let me enter the same password on the password update screen as it says that it matches the previous one. I tried it on the user name and password screen, but it seems to add a hidden digit to the password. Maybe there is a different set of hot keys needed for Mac.
  • BoatnmaniacBoatnmaniac SuperUser ✭✭✭✭
    It won't let me enter the same password on the password update screen as it says that it matches the previous one. I tried it on the user name and password screen, but it seems to add a hidden digit to the password. Maybe there is a different set of hot keys needed for Mac.
    Well, I knew it might be a long shot and might not work for you but it was worth a try.  Sorry, but I'm not going to be able to assist you on this.  Hopefully, someone who knows something about Macs (and SunTrust) will be able to.
    (QW Premier Subscription: R31.8 on Windows 10)
  • BoatnmaniacBoatnmaniac SuperUser ✭✭✭✭
    Chris_QPW said:
    I wonder what Ctrl+Shift+Enter actually does.  The Quicken developers tend to use Ctrl+Shift and a "Easter egg" sequence for when they want to add some "hidden" functionality, for troubleshooting or bypassing certain operations.  It isn't anything that is built-in to Windows.  It is just the program looking for that sequence and doing something different.
    I've wondered about that, too.  Maybe I'm wrong but my guess is that this SunTrust setup issue has a common causal thread in both QW and QM and with both EWC and DC processes.  And why does it still exist many months after TT's have been submitted?
    (QW Premier Subscription: R31.8 on Windows 10)
  • I tried post a follow up yesterday, but it got flagged stating it had to be reviewed... not sure what's going on.
  • Follow up basically stated that I received an email from Quicken Support and that they were going to call me back at 2:00 +/- 15 min. I never received a call. At 2:45 I received another email stating that the follow up call was going to be late, but with no updated time. At this point I still have not heard from them. In the follow up note, the agent sent me a portion of the Log that he downloaded from my computer. I am not a programmer, so I don't know what it meant. One curious items was that it had a line "message - please contact your financial institution to enroll". I find this interesting because when I was on the phone with Suntrust, they stated that I was clearly enrolled for the service. They could even see that the PIN being supplied by Quicken was incorrect... I guess due to the fact Quicken was asking me to update it when it wasn't necessary. Therefore, it seems to me there is something fouled up in the Quicken coding for Suntrust bank. Suntrust web agent told me that she had seen this issue once before with Quicken for Windows, and the only way there were able to resolve was from a 3 way call with actions taken on the Quicken end.

    So I guess for now I wait.
  • Dear Scott: I have been having a somewhat related problem with Suntrust that I think may be at the root of your issue. I read in another thread that Suntrust changed its online password requirements in Oct 2020 to require the use of a special character. When I try to set up online banking in QW, I am prompted for my web credentials with Suntrust. (These work, since I am able to log on to their website.) The next screen says that Suntrust requires me to change my password since this is the first time I am connecting with QW. This screen says that the PW can't be more than 8 characters and cannot include special characters or punctuation, just letters and numbers. When I input a password meeting these requirements, QW says it is looking for my accounts at Suntrust and then shows a CC-503 error. I believe this error is caused by Suntrust's new password requirements.
  • Matt, thank you for your follow up. What you are showing on your screen is what I am seeing. Have you been able to get yours to work in Direct Connect with Suntrust?

    As you mention, I can get signed in using Web Connect or Quicken connect using my username and password for Suntrust as used on the website. In discussing Direct Connect with Suntrust, they stated that I need to use my direct online user account number and 4 digit online banking PIN. This is different account information as compared to the web site credentials or my check card PIN, etc. When I use this information, I get to the password screen you show, and the only way to proceed is to enter something new. In talking with Suntrust they are not prompting this password change from their side, so when a new password is entered it doesn't get accepted by Suntrust at the log in.

    For anyone keeping score at home, I received an email from Quicken support on 12/7/20 wanting to setup a follow up call with me and my bank. Quicken still states that the issue is with Suntrust, and Suntrust states that the issue is with Quicken. I have requested a scheduled time from Quicken support for this 3 way call with the bank tp take place. As part of my original issue, I was on a 3 way call for over an hour with Suntrust and Quicken support (an additional hour plus) but I could not get it resolved. During that call I asked for escalation with Quicken support because Suntrust could not do anything from their end, and I was unable to get transferred within Quicken to the next tier of support. To date, I still do not have a schedule as to when Quicken Support will be available to support this 3 way call. So for now, I continue to wait for a solution or clue regarding the next steps.
  • lmillerlmiller Member
    I have the identical problem, and followed your previous post, Scott, beefore it was unceremoniously closed (!) Against my better judgment, I renewed our account with Quicken, thinking they'd sorted through all the technical problems after literally years of nightmares. Apparently, I was mistaken.

    The '0000' problem can be circumvented by typing '00000' (on Mac), which gets you past the 4-digit password problem. But SunTrust still fails to recognize the pw that Quicken stores on your behalf. If I can't get an answer here, I guess I will have to head over to social media, and post until someone takes responsibility.
  • vawasvawas Member ✭✭
    I have Quicken for windows and have had this problem for over a year. I tried the "Ctrl Shift Enter" suggested by Boatnmaniac and it did not work. I can't believe that after more than a year this has not been resolved. My next plan is to change banks.
  • James JJames J Member ✭✭
    I have been using Quicken for a couple decades. We have many accounts spread across at least six banking/brokerage accounts and an additional three credit card accounts. We have two separate Quicken accounts to organize our own money and my parent's money, which I help manage. Usually adding an account to Quicken is easy.

    Today for the first time I tried to add a Suntrust checking account and I got the same change password prompt that is captured in a screen shot above. What the heck is this supposed to mean? My password is fine, I can use it to log onto my Suntrust account.
  • James JJames J Member ✭✭
    Well, that was annoying, but I got it to work. When first attempting to link a any account to Quicken, Quicken presents you with that window where you enter your financial institution's name. Well, just like the 123 shades of off-white in our house than I all look the same until I need to patch a wall, there are 123 variations of "Suntrust" in that Quicken window. They all look the same, but evidently they do not all work.

    After some trial and error, choosing "SunTrust Banks", the one with an plural "bankS" worked properly. "Suntrust Bank" did not work. "Suntrust" did not work. "Suntrust Small Business" did not work, even though the account I am linking is a small business checking account . . .

    Goofy.
  • BoatnmaniacBoatnmaniac SuperUser ✭✭✭✭
    James J said:
    Well, that was annoying, but I got it to work. When first attempting to link a any account to Quicken, Quicken presents you with that window where you enter your financial institution's name. Well, just like the 123 shades of off-white in our house than I all look the same until I need to patch a wall, there are 123 variations of "Suntrust" in that Quicken window. They all look the same, but evidently they do not all work.

    After some trial and error, choosing "SunTrust Banks", the one with an plural "bankS" worked properly. "Suntrust Bank" did not work. "Suntrust" did not work. "Suntrust Small Business" did not work, even though the account I am linking is a small business checking account . . .

    Goofy.
    "SunTrust Banks" is a new set up link that did not exist last month.  Maybe there has been something done in the background to fix this issue?  It wouldn't be the first time a fix was put in place but never communicated to anyone.
    It would be interesting to find out if others posting here try setting up with "SunTrust Banks" and get the same good results you did.
    (QW Premier Subscription: R31.8 on Windows 10)
  • donpjrdonpjr Member
    Boatnmaniac. You're a godsend. I stumbled on this thread looking for a solution to exactly this problem with Suntrust. Your solution worked. Of course it should have been obvious. Just fake a changed password and do a Ctrl-shift enter that nobody knows about and it works. Well done Quicken. I'm so frustrated with this software. Currently rebuilding a 20 year old corrupt data file that will result in me losing years of valuable data. They need a competitor. Anyway thanks Boatnmaniac.
  • MilonavLkcMilonavLkc Member
    I have been struggling with SunTrust and Quicken (Mac version 6.0.3) since December experiencing the same problem as all of you. I had many phone calls with both of them with no solution and always one side blamed the other. (I got the impression that their customer support people who work there have very limited skills and poor technical knowledge.) Quicken ConnLog report shows that "A server with the specified hostname could not be found", which explains me now why "Suntrust Bank" doesn't work. However, when I tried to find "SunTrust Banks", it was not listed. Am I correct to assume that it has to do with the Quicken for Mac new update not being released yet? Thanks!
  • I looked today and I don't see a Suntrust Banks offered as an option in the Mac version.
  • BoatnmaniacBoatnmaniac SuperUser ✭✭✭✭
    edited January 26
    The FI lists for Q Win and Q Mac are different from each other but I had hoped that the new Q Win "SunTrust Banks" FI link would also be available for Q Mac.  I just now pulled up the Q Mac FI list from https://www.quicken.com/support/fi-list-support-quicken-versions and found "SunTrust Bank" and "SunTrustWebConnectforMAC" but no "SunTrust Banks".  So whatever change(s) were made to the Q Win link in "SunTrust Banks" does not appear to have been carried over to Q Mac...at least not yet.
    Maybe @Quicken Sarah might be able to step in here or get someone else from the Quicken Team engaged?  There should not be this type of connection issue occurring for such a long period of time.
    (QW Premier Subscription: R31.8 on Windows 10)
  • MilonavLkcMilonavLkc Member
    Called Quicken today and spoke with the supervisor who told me that "SunTrust Bank" is still valid host name for Q Mac version and that "SunTrust Banks" was only a workaround fix for Q Win version. He suggested me to talk to SunTrust's supervisor and ask for escalation with its back office OFEX (Open Financial Exchange) to investigate further if there is an issue on the SunTrust's server with my account ID. I'm still not convinced it's the right way to fix the problem. It seems that they don't know how to find the root cause and just playing a ping-pong game to avoid being responsible. So, the saga still continues with no solution on sight...
  • MSheffMSheff Member
    I set up a new quicken account and I am having the same issue with SunTrust. I use windows. I did find the SunTrust BankS but I still cannot use direct connect. Quicken only gives me the option for web express. I need the direct connect because I would like to pay bills. I had the direct connect set up with SunTrust on an old quicken file that I was using. Any work arounds?
  • BoatnmaniacBoatnmaniac SuperUser ✭✭✭✭
    MSheff said:
    I set up a new quicken account and I am having the same issue with SunTrust. I use windows. I did find the SunTrust BankS but I still cannot use direct connect. Quicken only gives me the option for web express. I need the direct connect because I would like to pay bills. I had the direct connect set up with SunTrust on an old quicken file that I was using. Any work arounds?
    In order to use DC with SunTrust you need to be subscribed to their PC Banking service.  There is a $5.95/month fee SunTrust will charge for basic PC Banking.  It increases to $9.95/month if you want bill pay included.
    SunTrust does not charge a monthly fee for the Express Web Connect (EWC) connection but EWC cannot be used with Quicken to send bill pay commands to any bank.  If you wish to avoid the PC Banking fees, you can log into your online SunTrust account and use their free basic bill pay service there.  The payments will be downloaded to Quicken via EWC when the payments have been transacted.
    If you have not signed up for PC Banking service you can do that by calling their Customer Service, accessing your online SunTrust account or at https://www.suntrust.com/microsites/pcbankingenrollment/pcbanking/agreement.aspx.
    Once you are subscribed to it I believe you will need to set up or will be provided a unique login that you will need to use with Quicken. 
    Then use the "SunTrust" setup link, click on the "Advanced Options" link, select "Direct Connect" and follow the prompts using the unique login information.  ("SunTrusts" does not have a "Direct Connect" option so don't use it to set up DC.)
    Since you are trying to set up DC, hopefully you will not encounter the PW issue identified above.  If you do, try using this solution to complete the set up process:
    This sounds very much like a similar issue connecting to SunTrust with Quicken for Windows.  When we get the prompt to enter a new PW, we can enter the PW we already have (do not create and enter a new one) and then Ctrl+Shift+Enter which then completes the set up process without the error message.  I don't know anything about Macs but if they have something like a Ctrl+Shift+Enter function capability you might want to give that a try.
    (QW Premier Subscription: R31.8 on Windows 10)
Sign In or Register to comment.