Home Quicken for Windows Reports (Windows)
Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Any way to set default columns for subreport?

The column choices (Description, memo, category etc.) for reports I memorize generally stick; but if I double-click a total to generate a new subreport showing the items within the total, the window seems to display ALL columns - Clr, Tag, Tax Item, Num - I don't want those. Is there a setting I am missing to have the subreports keep the same column choices as the main report, or to set default columns for new reports?
Tagged:

Answers

  • q_lurkerq_lurker SuperUser ✭✭✭✭✭
    I don't believe there is any such setting available.  The 'subreport' you cite is really a tightly filtered standard report - usually for Banking Transactions or similar, perhaps filtered to a specific payee or category..  It will have the standard columns for that report and there is no way to memorize those settings (as far as I know).    
  • Joseph WitkinJoseph Witkin Member ✭✭
    edited December 2020
    Something has changed recently. The "subreport" as I call it (because of the way it is generated) is created with every column displayed except "notes", and the formatting is terrible - right justified, category column only 3 spaces wide, all the left-sided columns out of the window to the left, can only be seen by scrolling. Enlarging the window is not saved.

    Just noticed that if I drag one of the dividers to resize any column of the subreport, even a little bit, the formatting corrects, with the columns now left-justified, date showing, column widths reasonable. Still more columns than I would like, but a lot better than the way it first comes up.

    This is definitely something new. (Win 10 x64 latest, QW latest)
  • Quicken_TykaQuicken_Tyka Moderator mod
    Hello @Joseph Witkin

    Thank you for taking the time to share the details of your experience and feedback with the Community, although I apologize that you have not yet received a follow-up response.

    Please navigate to Help > About Quicken and provide the release that you are running?

    May I also ask that you please capture a screenshot of the issue that you are seeing? I would like to test and recreate this issue if possible and report this issue if applicable.

    Thank you,

    -Quicken Tyka

    ~~~***~~~
  • Joseph WitkinJoseph Witkin Member ✭✭
    Hello,

    Quicken version R30.14, Build 27.1.30.14. Windows 10 x64 version 20H2.

    See attached screen shots. I pulled up a summary report and double-clicked one of the numbers to bring up a subreport of its constituent figures.

    The Initial Report Formatting jpegs show how the subreport comes up. It comes up as jpeg 1; jpeg 2 is the same window scrolled to show the other half. Tag column huge, category column tiny.

    If I drag any of the column dividers to resize a column, even a tiny bit, all the columns jump to the formatting in the “After Drag” jpegs. Still not great but slightly better.

    Of note is that the window for all reports comes in taking up the right side of my monitor screen only, like about half the screen, even though it would be much more readable if the window were wider. I can widen it manually but it does not save.

    There used to be an option to automatically resize columns – can’t find it now.

    Curious if you reproduce. Could this be corruption in my data file? Could it help to uninstall and reinstall the application?

    Unrelated suggestion:
    A number of versions back, there used to be an option to display categories in reports right-justified. If categories are nested, showing only the main heading, which may have numerous subcategories within it, is not as useful as if the final subcategory is showing. This setting seems to be gone. Would love it back! (eg Business Expenses:Car Expenses:Insurance – I need to see “Insurance” in the report column, not “Business Expenses”.)


    Thanks,

    Joe
  • Joseph WitkinJoseph Witkin Member ✭✭
    I did find that if I save the ORIGINAL report in a window expanded enough for the entire subreport with all its columns to be visible without scrolling (which is much wider than the original report itself needs since it has unnecessary columns removed), the window size does save, and subreports open in a form that is at least readable, though I still wish there were a way to set defaults so columns I never use don't appear and take up space.
Sign In or Register to comment.